Importante
O suporte para o Microsoft InfoPath 2013 terminou em 14 de julho de 2026. Recomendamos migrar formulários e fluxos de trabalho existentes do InfoPath para soluções compatíveis do Microsoft 365. Saiba mais sobre a desativação do InfoPath.
Você pode criar um modelo de formulário que possa funcionar com um banco de dados do Microsoft SQL Server para consultar dados ou consultar e enviar dados.
Neste artigo
- Visão geral
- Considerações de compatibilidade
- Antes de você começar
- Criar o modelo de formulário
- Configurar as opções de envio
Visão Geral
Um formulário pode ter uma conexão de dados primária, chamada de conexão de dados principal, e pode, opcionalmente, ter uma ou mais conexões de dados secundárias. Dependendo de suas metas para o formulário, uma conexão de dados pode consultar ou enviar dados de formulário para uma fonte de dados externa, como um banco de dados do Microsoft SQL Server ou um serviço Web.
Quando você cria um modelo de formulário baseado em um banco de dados, o Microsoft Office InfoPath cria uma fonte de dados principal com grupos que contêm campos de consulta e campos de dados e uma conexão de dados de consulta como a conexão de dados principal para o modelo de formulário. Esses campos e grupos correspondem à maneira como os dados são armazenados nas tabelas do banco de dados. Os campos de consulta contêm os dados inseridos por um usuário para limitar os resultados da consulta aos registros que correspondam aos dados nos campos de consulta. Quando um formulário baseado nesse modelo de formulário usa a conexão de dados principal, o InfoPath cria uma consulta usando os dados nos campos de consulta. O InfoPath envia a consulta por meio da conexão de dados da consulta. O banco de dados retorna os resultados da consulta de volta para o formulário por meio da conexão de dados da consulta. Os resultados da consulta são colocados em campos de dados, que podem ser editados por meio de controles vinculados a esses campos.
Como a estrutura de dados da consulta e os campos de dados devem corresponder à maneira como os dados são armazenados no banco de dados, você não pode modificar esses campos ou grupos na fonte de dados principal. Você só pode adicionar campos ou grupos ao grupo raiz na fonte de dados principal. Encontre links para obter mais informações sobre fontes de dados na seção Consulte também .
Um formulário poderá enviar dados a um banco de dados por meio da conexão de dados principal do formulário se o modelo de formulário no qual o formulário se baseia e o banco de dados atenderem aos seguintes requisitos:
- O modelo de formulário não é compatível com o navegador O InfoPath não criará uma conexão de dados de envio na conexão de dados principal se você estiver criando um modelo de formulário compatível com o navegador. Para permitir que os usuários enviem dados em um formulário baseado em um modelo de formulário compatível com o navegador, use um serviço Web que funcione com o banco de dados.
- A tabela à esquerda em cada par de tabelas relacionadas na fonte de dados principal contém uma chave primária Pelo menos uma das relações para cada par de tabelas relacionadas deve incluir uma chave primária da tabela esquerda.
- Nenhum dos campos de dados na fonte de dados principal do formulário armazena um tipo de dados binário grande O InfoPath desabilitará o envio de conexão de dados se a consulta incluir campos que possam armazenar um tipo de dados binário grande, como imagens, imagens, objetos OLE, anexos de arquivos, o tipo de dados de memorando do Office Access ou o tipo de dados de Texto SQL.
Quando o InfoPath habilita o envio de conexão de dados, os usuários têm permissão para enviar os dados nos campos de dados na fonte de dados principal para o banco de dados. Se o InfoPath habilitar a conexão de envio de dados, você poderá personalizar as opções de envio para os formulários baseados nesse modelo de formulário.
Considerações de compatibilidade
Ao criar um modelo de formulário baseado em um banco de dados, você tem a opção de criar um modelo de formulário compatível com o navegador. O InfoPath criará uma conexão de dados de consulta como a conexão de dados principal em um modelo de formulário compatível com o navegador. No entanto, modelos de formulário compatíveis com o navegador não podem ser configurados para permitir que os usuários enviem dados para um banco de dados. Portanto, se você estiver criando um modelo de formulário com base em um banco de dados do SQL Server e quiser que seus usuários enviem seus dados de formulário para o banco de dados por meio da conexão de dados principal, não será possível tornar esse modelo de formulário compatível com o navegador.
Antes de começar
Para criar seu modelo de formulário com base em um banco de dados do SQL Server, você precisará das seguintes informações do administrador de banco de dados:
- O nome do servidor que contém o banco de dados ao qual você conectará seu modelo de formulário.
- O nome do banco de dados que você usará com este modelo de formulário.
- A autenticação exigida pelo banco de dados. O banco de dados pode usar a autenticação do Microsoft autenticação do Windows ou do SQL Server para determinar como os usuários podem acessar o banco de dados.
- O nome da tabela que contém os dados que você deseja enviar para o formulário ou que receberá dados do formulário. Esta é a tabela primária. Se você vai usar mais de uma tabela no banco de dados, precisará dos nomes dessas outras tabelas filho. Você também precisa dos nomes dos campos nas tabelas filho que têm relações com os campos na tabela primária.
Criar o modelo de formulário
Para criar um modelo de formulário com uma conexão de dados de consulta, você precisa fazer o seguinte:
- Criar o modelo de formulário Quando você cria um modelo de formulário baseado em um banco de dados, o InfoPath cria uma conexão de dados de consulta como a conexão de dados principal entre o modelo de formulário e o banco de dados. Esse processo cria automaticamente a fonte de dados principal do modelo de formulário.
- Adicionar um ou mais controles para exibir os resultados da consulta Para permitir que os usuários vejam e editem os dados nos campos da fonte de dados principal quando abrirem o formulário, você pode adicionar um controle ao modelo de formulário e vincular esse controle a um campo na fonte de dados principal.
Etapa 1: Criar o modelo de formulário
No menu Arquivo , clique em Criar um modelo de formulário.
Em Criar um novo, na caixa de diálogo Criar um modelo de formulário , clique em Modelo de formulário.
Na lista Com base em , clique em Banco de dados.
Se estiver criando um modelo de formulário compatível com o navegador, marque a caixa de marca Habilitar somente recursos compatíveis com o navegador.
Observação
O Assistente para Conexão de Dados não permitirá o envio de conexão de dados em um modelo de formulário compatível com o navegador. Para permitir que os usuários enviem seus dados para um banco de dados a partir de formulários baseados em um modelo de formulário compatível com o navegador, adicione uma conexão de dados secundária a um serviço Web que funcione com o banco de dados. Encontre links para obter mais informações sobre conexões de dados secundárias na seção Consulte também .
Clique em OK.
No Assistente para Conexões de Dados, clique em Selecionar Banco de Dados.
Na caixa de diálogo Selecionar Fonte de Dados , clique em Nova Fonte.
Na lista A que tipo de fonte de dados você deseja se conectar, clique em Microsoft SQL Server e em Avançar.
Na caixa Nome do servidor, digite o nome do servidor com o banco de dados do SQL Server.
Em Credenciais de logon, siga um destes procedimentos:
- Se o banco de dados determinar quem tem acesso com base nas credenciais usadas em uma rede do Microsoft Windows, clique em Usar Autenticação do Windows.
- Se o banco de dados determinar quem tem acesso com base em um nome de usuário e senha especificados que você obtém do administrador de banco de dados, clique em Usar o seguinte Nome de Usuário e Senha e digite seu nome de usuário e senha nas caixas Nome de Usuário e Senha .
Clique em Avançar.
Na lista Selecione o banco de dados que contém os dados desejados, clique no nome do banco de dados que deseja usar, marque a caixa de marca Conectar a uma tabela específica, clique no nome da tabela primária e clique em Avançar.
Na próxima página do assistente, digite um nome para o arquivo que armazena as informações de conexão de dados na caixa Nome do Arquivo e clique em Concluir para salvar essas configurações.
Se você planeja usar outras tabelas na conexão de dados de consulta, poderá adicionar as outras tabelas nesta página do assistente.
Quão?- Clique em Adicionar Tabela.
- Na caixa de diálogo Adicionar Tabela ou Consulta , clique no nome da tabela filho e clique em Avançar. O InfoPath tenta definir as relações fazendo a correspondência de nomes de campo em ambas as tabelas. Se você não quiser usar a relação sugerida, selecione-a e clique em Remover relação. Para adicionar uma relação, clique em Adicionar relação. Na caixa de diálogo Adicionar Relação, clique no nome de cada campo relacionado na respectiva coluna e clique em OK.
- Clique em Concluir.
- Para adicionar outras tabelas filho, repita estas etapas.
Clique em Avançar.
Na última página do assistente, digite um nome para a conexão de dados principal. Esse nome será exibido na lista Fonte de dados no painel de tarefas Fonte de dados .
Se o seu modelo de formulário atender aos requisitos da seção Visão geral , esta página do assistente indicará que o InfoPath habilitou o envio de conexão de dados na conexão de dados principal. Para alterar o nome da conexão de envio de dados, digite um novo nome na caixa apropriada. Se quiser que os usuários enviem os dados de formulário por meio de outra conexão de envio de dados que será adicionada ao modelo de formulário posteriormente, desmarque a caixa de marcar Habilitar envio para esta conexão.
Observação
Se o seu modelo de formulário não atender aos requisitos da seção Visão geral, o InfoPath desabilitará o envio de conexão de dados e as caixas Inserir um nome para o envio de conexão e a caixa Habilitar envio para esta conexão marcar estarão indisponíveis (desabilitadas). Se o InfoPath desabilitar o envio de conexão de dados, a conexão de dados principal para seu modelo de formulário terá apenas uma conexão de dados de consulta.
Etapa 2: adicionar um ou mais controles para exibir os resultados da consulta
- Se o painel de tarefas Controles não estiver visível, clique em Mais Controles no menu Inserir, ou pressione ALT+I, C.
- Arraste um controle para o modelo de formulário.
- Na caixa de diálogo Associação de Controle , selecione o grupo ou campo ao qual você deseja vincular o controle.
Configurar as opções de envio
Se o seu modelo de formulário e as tabelas selecionadas no Assistente para Conexões de Dados atenderem aos requisitos da seção Visão geral , o InfoPath configurará seu modelo de formulário para enviar dados por meio de sua conexão de dados principal. Se você optar por usar essa conexão de envio de dados, o InfoPath configurará o modelo de formulário para que os usuários possam enviar seus dados de formulário para o banco de dados e adicionará o botão Enviar à barra de ferramentas Standard e o comando Enviar ao menu Arquivo quando os usuários preencherem o formulário. O InfoPath também configura o modelo de formulário para que, quando os usuários enviem seus formulários, o formulário permaneça aberto e uma mensagem seja exibida para o usuário indicando se o formulário foi enviado com êxito. Você pode alterar o texto do botão Enviar e o comportamento depois que o usuário envia um formulário.
No menu Ferramentas , clique em Enviar Opções.
Para alterar o nome do botão Enviar que aparece na barra de ferramentas Standard e o comando Enviar que aparece no menu Arquivo quando os usuários preenchem o formulário, digite o novo nome na caixa Legenda na caixa de diálogo Opções de Envio.
Dica
Se você quiser atribuir um atalho de teclado a esse botão e comando, digite um e comercial (&) antes do caractere que deseja usar como atalho de teclado. Por exemplo, para atribuir ALT+B como atalho de teclado para o botão e o comando Enviar , digite Su&bmit.
Se você não quiser que as pessoas usem o comando Enviar ou o botão Enviar na barra de ferramentas Standard quando preencherem o formulário, desmarque a caixa de marcar Mostrar o item de menu Enviar e o botão da barra de ferramentas Enviar.
Por padrão, depois que os usuários enviam um formulário, o InfoPath mantém o formulário aberto e exibe uma mensagem para indicar se o formulário foi enviado com êxito. Para alterar esse comportamento padrão, clique em Avançado e siga um destes procedimentos:
Para fechar o formulário ou criar um novo formulário em branco depois que o usuário enviar um formulário preenchido, clique na opção desejada na lista Após envio .
Para criar uma mensagem personalizada para indicar se o formulário foi enviado com êxito, marque a caixa Usar mensagens personalizadas marcar e digite suas mensagens nas caixas Em caso de sucesso e Em caso de falha.
Dica
Use uma mensagem na caixa Em falha para informar aos usuários o que fazer se eles não puderem enviar o formulário. Por exemplo, você pode sugerir que os usuários salvem o formulário e contatem alguém para obter mais instruções.
Se você não quiser exibir uma mensagem depois que o usuário enviar um formulário, desmarque a caixa marcar Mostrar mensagens de sucesso e falha.