Importante
O suporte para o Microsoft InfoPath 2013 terminou a 14 de julho de 2026. Recomendamos a migração de formulários e fluxos de trabalho existentes do InfoPath para soluções suportadas do Microsoft 365. Saiba mais sobre a descontinuação do InfoPath.
Os modelos de formulário do Microsoft Office InfoPath criados são projetados para serem abertos e preenchidos online, no próprio InfoPath ou usando um navegador da Web. No entanto, os utilizadores podem optar por imprimir uma cópia de um formulário preenchido para os seus registos pessoais ou para fins de arquivo. Por esta razão, é aconselhável verificar se o seu modelo de formulário parece aceitável quando é impresso. Por exemplo, é aconselhável certificar-se de que os controlos no seu modelo de formulário cabem dentro das margens da página impressa e que o texto no formulário impresso é legível.
Além disso, pode utilizar o painel de tarefas Vistas para criar uma versão especial do modelo de formulário (denominado vista de impressão), concebido especificamente para fins de impressão.
Este artigo explica como criar uma vista de impressão para o seu modelo de formulário e outras técnicas para criar modelos de formulário fáceis de imprimir.
Neste artigo
- A diferença entre imprimir um modelo de formulário e um formulário
- Introdução às vistas de impressão
- Estruturar uma vista de impressão baseada numa vista existente
- Estruturar uma vista de impressão especificamente para Word
A diferença entre imprimir um modelo de formulário e um formulário
Pode imprimir o seu modelo de formulário para ter uma ideia geral de como os controlos e outros objetos aparecem na página impressa ou para verificar as definições de impressão, tais como cabeçalhos ou rodapés. Quando imprime um modelo de formulário a partir do modo de estrutura, poderá ver alguns itens no modelo de formulário impresso, tais como botões, que não são apresentados quando um utilizador imprime um formulário baseado no seu modelo de formulário.
Quando os utilizadores imprimem um formulário com base no seu modelo de formulário, o InfoPath faz ajustes ao formulário ou remove determinados itens que não fazem sentido num contexto impresso. Por exemplo, o texto informativo Inserir Item que é apresentado por predefinição em tabelas de repetição não será apresentado no formulário impresso. Os controlos de botão, entradas de caixa de listagem ou setas de deslocamento também não o serão, pois estes itens perdem o significado na página impressa.
Introdução às vistas de impressão
Embora os modelos de formulário sejam projetados para coletar dados de formulário em um formato eletrônico, você pode criar um modo de exibição de impressão, que é um modo de exibição projetado especificamente para impressão. Isto é útil quando pretende que os utilizadores imprimam formulários utilizando um esquema específico ou imprimam apenas determinadas partes do formulário.
Se o seu modelo de formulário contiver várias vistas, pode criar uma vista de impressão para cada vista. Em alternativa, pode designar uma vista de impressão única que se aplica a todas as vistas no modelo de formulário. Por exemplo, se o modelo de formulário contiver três vistas distintas, poderá criar uma vista de impressão que consolide as informações chave de cada uma dessas vistas numa única página impressa.
Para criar e associar uma vista de impressão a uma vista existente, pode utilizar a ligação Criar Versão de Impressão para Esta Vista no painel de tarefas Vistas . Quando clica nesta ligação, o InfoPath faz o seguinte:
- Cria uma nova vista em branco denominada Nome da Versão de Impressão, em que nome é o nome da vista na qual a vista de impressão se baseia.
- Associa a vista de impressão à vista na qual se baseia. Esta associação está registada na caixa de diálogo Ver Propriedades , no separador Definições de Impressão . Por exemplo, imagine que criou uma vista de impressão baseada numa vista Aprovação no seu modelo de formulário. Quando os utilizadores clicarem no botão Imprimir na vista Aprovação , o InfoPath imprime tudo o que aparecer na vista Aprovação da Versão de Impressão .
Após criar uma vista de impressão, pode estruturá-la de modo a refletir a forma como pretende que o formulário seja apresentado quando for impresso. Normalmente, isso envolve copiar e colar controles de outros modos de exibição no modelo de formulário no modo de exibição de impressão. Se necessário, pode substituir determinados controlos por outros controlos na vista de impressão. Por exemplo, pode substituir uma caixa de lista pendente, que oculta entradas da caixa de listagem por predefinição, por uma caixa de listagem padrão, que apresenta as entradas por predefinição. Ao fazê-lo, todas as entradas são apresentadas no formulário impresso. Também pode especificar opções de impressão personalizadas para a vista de impressão na caixa de diálogo Ver Propriedades , tais como cabeçalhos, rodapés e margens da página.
Estruturar uma vista de impressão baseada numa vista existente
Por predefinição, quando um utilizador imprime um formulário que não tem uma vista de impressão específica associada, a vista atualmente apresentada no computador do utilizador é impressa. Se criar uma vista de impressão, o InfoPath imprime essa vista em vez da vista atual. Pode designar qualquer vista existente como vista de impressão. O seguinte procedimento explica como utilizar uma vista existente como base para uma vista de impressão.
No menu Exibir , clique em Gerenciar Modos de Exibição.
Na lista Selecione um modo de exibição , no painel de tarefas Modos de exibição, clique no modo de exibição para o qual você deseja criar um modo de exibição de impressão.
Em Ações, clique em Criar Versão de Impressão para esta Exibição.
Na caixa de diálogo Criar Versão de Impressão, digite um nome para a visualização de impressão e clique em OK.
No painel de tarefas Vistas , faça duplo clique na vista de impressão.
Na caixa de diálogo Ver Propriedades, selecione as opções pretendidas nos separadores Definições de Impressão e Configurar Página e, em seguida, clique em OK. Por exemplo, pode especificar predefinições de margem para a vista de impressão ou adicionar cabeçalhos ou rodapés.
Para mudar para a vista original, no painel de tarefas Vistas , clique no nome da vista na lista Selecionar uma vista .
Para selecionar tudo na vista, prima CTRL+A.
Para copiar a seleção para a Área de Transferência, prima CTRL+C.
Para mudar para a vista de impressão, no painel de tarefas Vistas , clique no nome da vista na lista Selecionar uma vista .
Para colar a seleção da vista original na vista de impressão, prima CTRL+V.
Elimine quaisquer controlos ou elementos de esquema de que não necessite ou adicione controlos adicionais.
Dica
Para determinar rapidamente se os controles e outros elementos de design caberão em uma página impressa, você pode exibir uma guia de largura de página ao longo do lado direito do modelo de formulário clicando em Guia de Largura de Página no menu Exibir . Uma guia de largura de página aparece como uma linha vertical tracejada no modelo de formulário. A linha indica onde se encontra a margem direita da página impressa, com base na impressora predefinida do seu computador.
Para adicionar quebras de página à vista de impressão, clique onde pretende que comece uma nova página e, em seguida, no menu Inserir , clique em Quebra de Página.
Observação
Uma quebra de página é apresentada como uma linha horizontal tracejada num modelo de formulário. Se pré-visualizar o modelo de formulário, não verá esta linha tracejada ou qualquer outra indicação de quebra de página. Para ver como a quebra de página afetará os formulários impressos baseados no seu modelo de formulário, clique em Pré-visualizar
na barra de ferramentas Standard.
Estruturar uma vista de impressão especificamente para Word
Se é um designer de formulários avançado que compreende tecnologias XML, pode utilizar o Assistente para Adicionar Vista de Impressão para Word para criar uma vista de impressão baseada no Microsoft Office Word que imprime dados de formulário diretamente a partir do Word. Isto permite-lhe tirar partido da gama de funcionalidades de impressão disponíveis no Word. Para tal, tem de ter acesso a um ficheiro de Transformação XSLL (XSLT) existente que transforme os dados no seu modelo de formulário num formato adequado para imprimir a partir de Word. Quando um utilizador imprime um formulário que contém uma vista de impressão baseada em Word, os dados nesse formulário serão impressos diretamente a partir do Word. O ficheiro XSLT tem de ser criado utilizando o Microsoft Office Word 2003 ou o Microsoft Office Word 2007.
Observação
Para saber mais sobre como criar o arquivo XSLT, consulte o Software Development Kit (SDK) do Microsoft Office InfoPath 2003. O SDK contém uma ferramenta, denominada Assistente do InfoPath para Word, que permite utilizar o Word 2003 ou Word 2007 para imprimir dados de formulário do InfoPath. Para localizar o SDK do InfoPath 2003, consulte a seção Consulte também .
- No menu Exibir , clique em Gerenciar Modos de Exibição.
- Em Ações, no painel de tarefas Exibições, clique em Adicionar Modo de Exibição de Impressão para Word.
- Siga as instruções no Assistente para Adicionar Vista de Impressão para Word para especificar o ficheiro XSLT que pretende utilizar para a vista de impressão baseada em Word.
- Na lista Selecione um modo de exibição, no painel de tarefas Modos de exibição, clique no modo de exibição para o qual você deseja designar o modo de exibição de impressão baseado em Word e, em seguida, clique em Exibir Propriedades.
- Clique no separador Definições de Impressão .
- Na lista Selecione uma vista existente para utilizar ao imprimir esta vista, clique na vista de impressão baseada em Word.