Importante
O suporte para o Microsoft InfoPath 2013 terminou em 14 de julho de 2026. Recomendamos migrar formulários e fluxos de trabalho existentes do InfoPath para soluções compatíveis do Microsoft 365. Saiba mais sobre a desativação do InfoPath.
Você pode preencher uma caixa de listagem, uma caixa de listagem suspensa ou uma caixa de combinação com dados de uma conexão de dados de consulta com um banco de dados do Microsoft SQL Server.
Neste artigo
- Visão geral
- Antes de você começar
- Etapa 1: Adicionar uma conexão de dados de consulta
- Etapa 2: Configurar o controle
Visão Geral
Uma caixa de listagem, caixa de listagem suspensa ou caixa de combinação exibe itens que um usuário pode selecionar ao preencher um formulário baseado em seu modelo de formulário. Você pode configurar esses tipos de controles para mostrar os dados de uma conexão de dados secundária com um banco de dados do Microsoft SQL Server. Uma conexão de dados secundária é qualquer conexão de dados com uma fonte de dados externa que você adiciona a um modelo de formulário para que os usuários que preenchem formulários com base nesse modelo de formulário possam obter dados ou enviar dados para uma fonte de dados externa, como um serviço Web.
Quando você adiciona uma conexão de dados secundária que consulta dados ao seu modelo de formulário, o Microsoft Office InfoPath cria uma fonte de dados secundária com campos e grupos de dados que correspondem à maneira como os dados são armazenados no banco de dados. A conexão de dados da consulta obtém dados do serviço Web e armazena esses dados na fonte de dados secundária do formulário. Por padrão, os dados na fonte de dados secundária estão disponíveis somente enquanto os usuários estão conectados a uma rede. Você pode configurar a conexão de dados secundária para salvar os resultados da consulta nos computadores dos usuários, para que eles tenham acesso aos dados quando o formulário não estiver conectado a uma rede.
Observação
Se você estiver usando uma conexão de dados secundária para recuperar dados confidenciais de uma fonte de dados externa, convém desabilitar esse recurso para ajudar a proteger os dados contra uso não autorizado em caso de perda ou roubo do computador. Se você desabilitar esse recurso, os dados estarão disponíveis somente se o usuário estiver conectado à rede.
Como a estrutura de dados na fonte de dados secundária deve corresponder à maneira como os dados são armazenados no banco de dados, você não pode modificar campos ou grupos existentes na fonte de dados secundária. Encontre links para obter mais informações sobre conexões de dados e fontes de dados na seção Consulte também .
Antes de começar
Antes de usar valores de um banco de dados do SQL Server para preencher um controle em seu modelo de formulário, você precisa das seguintes informações do administrador de banco de dados:
- O nome do servidor com o banco de dados que você usará com este modelo de formulário.
- O nome do banco de dados que você usará com este modelo de formulário.
- A autenticação exigida pelo banco de dados. O banco de dados pode usar a autenticação do Microsoft autenticação do Windows ou do SQL Server para determinar como os usuários podem acessar o banco de dados.
- O nome da tabela que contém os dados que você deseja enviar para o formulário. Esta é a tabela primária. Se você planeja usar mais de uma tabela no banco de dados, precisará dos nomes das outras tabelas filhas. Você também precisa dos nomes dos campos nas tabelas filho que têm relações com os campos na tabela primária.
- Se você pode armazenar com segurança os resultados da consulta nos computadores dos usuários para uso offline.
Etapa 1: Adicionar uma conexão de dados de consulta
Se não tiver uma conexão de dados de consulta existente que possa ser usada em seu modelo de formulário, siga estas etapas para adicionar uma conexão de dados secundária ao seu modelo de formulário que consulta dados. Se o seu modelo de formulário já tiver uma conexão de dados secundária que você possa usar, ignore esta seção e vá para a Etapa 2: Configurar o controle.
No menu Ferramentas , clique em Conexões de Dados.
Na caixa de diálogo Conexões de Dados , clique em Adicionar.
No Assistente para Conexões de Dados, clique em Criar uma nova conexão com, em Receber dados e em Avançar.
Na próxima página do assistente, clique em Banco de Dados (somente Microsoft SQL Server ou Microsoft Office Access) e, em seguida, clique em Avançar.
Na próxima página do assistente, clique em Selecionar Banco de Dados.
Na caixa de diálogo Selecionar Fonte de Dados , clique em Nova Fonte.
Na próxima página do assistente, na lista A que tipo de fonte de dados você deseja se conectar, clique em Microsoft SQL Server e em Avançar.
Na caixa Nome do servidor, digite o nome do servidor que contém o banco de dados do SQL Server.
Em Credenciais de logon, siga um destes procedimentos:
- Se o banco de dados determinar quem tem acesso com base nas credenciais usadas em uma rede do Microsoft Windows, clique em Usar Autenticação do Windows.
- Se o banco de dados determinar quem tem acesso com base em um nome de usuário e senha especificados que você obtém do administrador de banco de dados, clique em Usar o seguinte Nome de Usuário e Senha e digite seu nome de usuário e senha nas caixas Nome de Usuário e Senha .
Clique em Avançar.
Na lista Selecione o banco de dados que contém os dados desejados , clique no nome do banco de dados que deseja usar, clique em Conectar-se a uma tabela específica, clique no nome da tabela principal e clique em Avançar.
Na próxima página do assistente, na caixa Nome do Arquivo , digite um nome para o arquivo que armazena as informações de conexão de dados e clique em Concluir para salvar essas configurações.
Se você planeja usar outras tabelas na conexão de dados de consulta, poderá adicionar as outras tabelas nesta página do assistente.
Adicionar outras tabelas- Clique em Adicionar Tabela.
- Na caixa de diálogo Adicionar Tabela ou Consulta , clique no nome da tabela filho e clique em Avançar. O InfoPath tenta definir as relações fazendo a correspondência de nomes de campo em ambas as tabelas. Se você não quiser usar a relação sugerida, selecione-a e clique em Remover relação. Para adicionar uma relação, clique em Adicionar relação. Na caixa de diálogo Adicionar Relação, clique no nome de cada campo relacionado na respectiva coluna e clique em OK.
- Clique em Concluir.
- Para adicionar outras tabelas filho, repita estas etapas.
Clique em Avançar.
Para armazenar os resultados da consulta com o modelo de formulário, selecione a caixa marcar Armazenar uma cópia dos dados no modelo de formulário. Marcar essa caixa de marcação armazena os resultados da consulta no modelo de formulário. Porque os dados são armazenados no modelo de formulário. Os dados estão disponíveis nos formulários que os usuários preenchem, mesmo que seus computadores não estejam conectados a uma rede.
Observação
Marcar essa caixa de marcação armazena os resultados da consulta no modelo de formulário. Como os dados são armazenados no modelo de formulário, eles ficam disponíveis nos formulários que os usuários preenchem, mesmo que seus computadores não estejam conectados a uma rede. Se você estiver obtendo dados confidenciais dessa conexão de dados, convém desabilitar esse recurso para ajudar a proteger os dados em caso de perda ou roubo do computador.
Clique em Avançar.
Na próxima página do assistente, digite um nome descritivo para essa conexão de dados secundária. Se desejar que o formulário receba dados automaticamente quando for aberto, marque a caixa marcar Recuperar dados automaticamente quando o formulário for aberto.
Etapa 2: Configurar o controle
Se o modelo de formulário tiver vários modos de exibição, clique em Nome do modo de exibição no menu Exibir para acessar o modo de exibição com o controle onde você deseja exibir os dados da fonte de dados secundária.
Clique duas vezes no controle de caixa de listagem, caixa de listagem suspensa ou caixa de combinação que você deseja preencher.
Clique na guia Dados.
Em Entradas da caixa de listagem, clique em Pesquisar valores de uma fonte de dados externa.
Na lista Fonte de Dados , clique na fonte de dados que você deseja usar.
Clique em Selecionar XPath
ao lado da caixa Entradas .Na caixa de diálogo Selecionar um Campo ou Grupo , especifique quais dados serão mostrados para o usuário e quais dados serão enviados para a fonte de dados externa seguindo um destes procedimentos.
Especifique que os dados que o usuário verá são os mesmos dados que o usuário enviará- Clique em um campo e clique em OK.
Especificar que os dados que o usuário verá são diferentes dos dados que o usuário enviará
Observação
Neste cenário, os dados que o usuário verá são de um dos campos do grupo, e os dados que o usuário enviará estão em outro campo do mesmo grupo.
- Clique em um grupo e depois em OK.
- Na caixa de diálogo Propriedades do Controle , clique em Selecionar XPath
ao lado da caixa Valor . - Na caixa de diálogo Selecionar um Campo ou Grupo, clique em um campo que contenha os dados que o usuário enviará para a fonte de dados externa e clique em OK.
- Na caixa de diálogo Propriedades do Controle , clique em Selecionar XPath
ao lado da caixa Nome de exibição . - Na caixa de diálogo Selecionar um Campo ou Grupo, clique em um campo que contenha os dados que aparecerão no controle e clique em OK.
Se o campo na caixa Nome de exibição tiver valores com nomes de exibição semelhantes e você desejar exibir apenas nomes exclusivos, marque a caixa marcar Mostrar somente entradas com nomes de exibição exclusivos.