Problema conhecido para as atualizações de segurança 3098779 e 3097997 para .NET Framework 4.5.1 e 4.5.2 após instalar .NET Framework 4.6 no Windows 8.1, Windows RT 8.1 e Windows Server 2012 R2

Sumário
Os clientes que atualizarem do .NET Framework 4.5.1 ou 4.5.2 para o .NET Framework 4.6 ou que instalarem o Visual Studio 2015 após instalarem as atualizações 3098779 e 3097997 poderão encontrar problemas quando executarem aplicativos do .NET Framework.

Além disso, os clientes que usarem um sistema com o Microsoft .NET Framework 4.6 instalado e que aplicarem manualmente as atualizações de segurança 3098779 e 3097997 para o Microsoft .NET Framework 4.5.1 e 4.5.2 no Windows 8.1, Windows RT 8.1 e Windows Server 2012 R2 poderão encontrar problemas quando executarem aplicativos do .NET Framework.

Observação Sistemas operacionais anteriores com o .NET Framework 4.5.1 ou 4.5.2 instalado não são afetados por esse problema porque as atualizações de segurança 3098779 e 3097997 não se aplicam a eles.
Sintomas

Cenário 1

  • Você está usando .NET Framework 4.5.1 ou 4.5.2 no Windows 8.1, Windows RT 8.1 ou Windows Server 2012 R2.
  • Você instalou todas as atualizações recentes para .NET Framework 4.5.1 e 4.5.2, incluindo as atualizações 3098779 e 3097997.
  • Você baixou e instalou .NET Framework 4.6 ou instalou Microsoft Visual Studio 2015.
Neste cenário, alguns componentes do .NET Framework 4.6 não são atualizados conforme esperado, ou alguns aplicativos do .NET Framework não iniciam ou executam corretamente.

Cenário 2

  • Você está usando .NET Framework 4.6 no Windows 8.1, Windows RT 8.1 ou Windows Server 2012 R2.
  • Você aplica manualmente as atualizações 3098779 e 3097997 ou qualquer outra atualização não destinada ao .NET Framework 4.6, embora essas atualizações sejam destinadas ao .NET Framework 4.5.1 e 4.5.2.

    Observação Não há suporte a este cenário. Para obter mais informações sobre como determinar o aplicativo correto para uma atualização do Microsoft .NET Framework, consulte o artigo da Base de Dados de Conhecimento Microsoft 3136092.
Neste cenário, alguns aplicativos do .NET Framework não são iniciados ou executados corretamente.
Resolução

Resolução do cenário 1

Os clientes podem resolver esses problemas atualizando para o .NET Framework 4.6.1 a partir dos seguintes sites do Centro de Download da Microsoft:

Como alternativa, os clientes podem desinstalar as atualizações 3098779 e 3097997 se tiverem atualizado seus sistemas para o .NET Framework 4.6 ou se tiverem instalado o Visual Studio 2015 a partir de um sistema totalmente atualizado com o .NET 4.5.1 ou 4.5.2 que tenha as atualizações 3098779 e 3097997 instaladas.

Os clientes então deverão repetir a verificação do Windows Update e baixar e instalar as atualizações 3098785 e 3098000. Essas são as atualizações correspondentes ao Microsoft Security Bulletin MS15-118 para .NET Framework 4.6 no Windows 8.1, Windows RT 8.1 ou Windows Server 2012 R2. Essa ação corrigirá o erro de correspondência de versão.

Resolução do cenário 2

Os clientes que aplicarem manualmente as atualizações 3098779 e 3097997 em sistemas que têm o .NET Framework 4.6 instalado devem estar cientes de que não há suporte a esse cenário. Essas atualizações não se aplicam ao .NET Framework 4.6.

Portanto, clientes que utilizam .NET Framework 4.6 devem desinstalar as atualizações 3098779 e 3097997 e, depois, reanalisar o Windows Update e instalar somente as atualizações que se aplicam ao .NET Framework 4.6. Essa ação corrigirá o erro de correspondência de versão.

Do mesmo modo, os clientes que estiverem usando o .NET 4.5.1 ou 4.5.2 deverão assegurar-se de que não haja atualizações aplicáveis a qualquer outra versão do .NET Framework instalada em seus sistemas. Por exemplo, as atualizações destinadas ao .NET Framework 4.6 não devem ser aplicadas a sistemas com o .NET 4.5.1 ou 4.5.2 instalado. Para obter mais informações sobre como determinar o aplicativo correto para as atualizações do Microsoft .NET Framework 4.6 e 4.6.1, consulte o artigo da Base de Dados de Conhecimento Microsoft 3136092
Situação
A Microsoft confirmou que esse problema ocorre nos produtos listados na seção "Aplicável a".

Aplicável a

Este artigo se aplica ao seguinte:

  • Microsoft .NET Framework 4.6 quando usado com:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1
  • Microsoft .NET Framework 4.5.2 quando usado com:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1
  • Microsoft .NET Framework 4.5.1 quando usado com:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1
Propriedades

ID do Artigo: 3118750 - Última Revisão: 01/20/2016 14:38:00 - Revisão: 5.0

Microsoft .NET Framework 4.6, Microsoft .NET Framework 4.5.2, Microsoft .NET Framework 4.5.1

  • atdownload kbbug kbexpertiseinter kbfix kbsecbulletin kbsecurity kbsecvulnerability KB3118750
Comentários