Sintomas
Quando você instala um servidor do site do Microsoft System Center Configuration Manager (SCCM) 2007 antes de 1º de dezembro de 2007, o servidor do site do SCCM não processa dados de resumo de status de anúncio. Esses dados também são conhecidos como dados de resumo do status da oferta. Nesse caso, os arquivos de status (.svf) se acumulam na pasta offersum.box localizada na pasta \Arquivos de Programas\Microsoft Configuration Manager\inboxes no servidor do site SCCM.
Observação Se você atualizar do Microsoft System Management Server (SMS) 2003 para o SCCM 2007, a pasta offersum.box estará localizada na pasta \SMS\Inboxes.
Além disso, o arquivo Offersum.log contém erros semelhantes aos seguintes:
Tally 00011280001F2000. Nova Hora de Início: 01/12/2007 00:00:00, Nova Hora de Expiração: 08/12/2007 00:00:00 ---->: Uma exceção foi gerada: Erro não especificado Avisar>: Não foi possível inicializar as propriedades dos resumidores.
Essas mensagens de erro ocorrem a cada minuto no arquivo Offersum.log.
Quando você instala um servidor do site do SCCM após 1º de dezembro de 2007, o servidor do site do SCCM não pode processar mensagens de status. Esse comportamento ocorre porque a pasta offersum.box não foi criada com êxito. Isso bloqueia o sistema de mensagens de status. Além disso, o arquivo Statmgr.log contém entradas semelhantes às seguintes:
Aguardando SMS_INBOX_MANAGER caixa de entrada "Resumidor de Status da Oferta" para o SMS_OFFER_STATUS_SUMMARIZER.
Observação Nenhuma outra função do sistema de sites é afetada por esse problema. Somente o componente de resumo do status da oferta é afetado por esse problema.
Causa
Esse problema ocorre porque um cálculo de data incorreto é usado para determinar intervalos de resumo. O cálculo de data é executado logo após o thread do Summarizer de Status da Oferta do SMS Executivo é iniciado.
Resolução
Informações do Service Pack
Para resolver esse problema, obtenha o service pack mais recente do Microsoft System Center Configuration Manager 2007, disponível neste site da Microsoft: http://www.microsoft.com/download/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
Para obter uma lista de problemas resolvidos neste service pack, clique no seguinte número de artigo na Base de Dados de Conhecimento Microsoft:
971348 Lista de hotfixes e atualizações contidos no System Center Configuration Manager 2007 Service Pack 2
Informações de hotfix
Para obter o pacote autônomo para esta atualização, acesse o site do Catálogo do Microsoft Update .
Para obter mais informações sobre como baixar arquivos de suporte da Microsoft, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento Microsoft:
119591 Como obter arquivos de suporte da Microsoft do serviços online A Microsoft examinou esse arquivo em busca de vírus. A Microsoft utilizou o software de detecção de vírus mais recente disponível na data em que o arquivo foi postado. O arquivo está armazenado em servidores de segurança avançada que ajudam a evitar alterações não autorizadas nele.
Informações sobre o hotfix
Um hotfix com suporte agora está disponível na Microsoft. No entanto, ele se destina a corrigir apenas o problema descrito neste artigo. Aplique-o somente a sistemas que estão enfrentando esse problema específico. Esse hotfix pode receber testes adicionais. Portanto, se você não for gravemente afetado por esse problema, recomendamos aguardar o próximo service pack do System Center Configuration Manager 2007 que contém esse hotfix.
Para resolver esse problema imediatamente, entre em contato com os Serviços de Suporte ao Cliente da Microsoft para obter o hotfix. Para obter uma lista completa de números de telefone dos Serviços de Suporte ao Cliente da Microsoft e informações sobre os custos de suporte, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support Observação Em casos especiais, os encargos que normalmente são incorridos para chamadas de suporte poderão ser cancelados se um Suporte da Microsoft Professional determinar que uma atualização específica resolverá o problema. Os custos de suporte em geral aplicam-se a questões e problemas de suporte adicionais que não se enquadrem na atualização específica em questão.
Pré-requisitos
System Center Configuration Manager 2007 deve ser instalado antes de aplicar esse hotfix.
Necessidade de reinicialização
Você não precisa reiniciar o computador depois de aplicar esse hotfix.
Informações sobre a substituição de hotfixes
Esse hotfix não substitui nenhum hotfix lançado anteriormente.
Informações do arquivo
A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas em UTC (Tempo Universal Coordenado). Quando você exibe as informações sobre os arquivos, elas são convertidas no horário local. Para saber a diferença entre a hora UTC e a hora local, use a guia Fuso Horário no item Data e Hora do Painel de Controle.
Data |
Hora |
Versão |
Tamanho |
File name |
---|---|---|---|---|
01 de dezembro de 2007 |
06:50 |
4.0.5931.111 |
88,504 |
Offersum.dll |
Depois de aplicar esse hotfix, as mensagens de status que são registradas em log na pasta offersum.box são processadas. Se você monitorar o arquivo Offersum.log, as entradas semelhantes às seguintes poderão aparecer para várias mensagens diferentes:
Tempo inválido para a oferta 'AdvertisementName' com messageID do client ClientName.
Observe que o valor messageID variará. Além disso, o número de vezes que a entrada de log é repetida para qualquer cliente específico varia.
Quando o componente do summarizer de status lê uma mensagem de status, o componente de resumo de status compara o carimbo de data/hora na mensagem com a hora de início de um determinado intervalo de resumo. Quando a mensagem que está sendo processada fica fora do intervalo determinado, a entrada de log é gerada no arquivo Offersum.log. Por exemplo, uma mensagem de status gerada em 3 de dezembro e processada em 5 de dezembro não aparecerá no resumo Desde 12:00:00 . Portanto, a entrada de log de 3 de dezembro pode ser ignorada.
Quatorze intervalos de resumo de status diferentes são definidos. Os intervalos de resumo de status se assemelham às informações de Intervalos de Exibição que estão disponíveis quando você exibe resumos de mensagens de status no console SMS Administrador. Por exemplo, os intervalos de resumo de status se assemelham desde 00:00:00 ou desde domingo.