Adicionar ou subtrair tempos

Digamos que você precise adicionar dois valores de tempo diferentes juntos para obter um total. Ou você precisa subtrair um valor de hora de outro para obter o tempo total gasto trabalhando em um projeto.

Como você verá nas seções abaixo, o Excel facilita a adoção ou subtração de tempo.

Adicionar tempos

Suponha que você queira saber quantas horas e minutos serão necessários para concluir duas tarefas. Você estima que a primeira tarefa levará seis horas e 45 minutos e que a segunda tarefa levará nove horas e 30 minutos.

Aqui está uma maneira de configurar isso na planilha.

  1. Insira 6:45 na célula B2e insira 9:30na célula B3.

  2. Na célula B4, digite =B2+B3 e pressione Enter.

    Tempo somado para duas tarefas

    O resultado é de 16:15 a 16 horas e 15 minutos para a conclusão das duas tarefas.

    Dica: Você pode também somar horários usando a função AutoSoma para somar números. Selecione a célula B4 e, na guia Página Inicial, escolha AutoSoma. A fórmula terá a seguinte aparência: =SOMA(B2:B3). Pressione Enter para obter o mesmo resultado, 16 horas e 15 minutos.

Até agora as coisas foram fáceis, mas você precisará de uma etapa extra se a soma ultrapassar 24 horas. É necessário aplicar um formato especial ao resultado da fórmula.

Para adicionar mais de 24 horas:

  1. Na célula B2 digite 12:45 e na célula B3 digite 15:30.

  2. Digite =B2+B3 na célula B4 e depois pressione Enter.

    O tempo somado acima de 24 horas totaliza um resultado inesperado de 4:15

    O resultado é 4:15, que não é o que você pode esperar. Isso porque a hora da Tarefa 2 é em 24 horas. 15:30 é o mesmo que 3:30.

  3. Para exibir o tempo além de 24 horas, selecione a célula B4.

  4. Na guia Página Inicial, no grupo Células, escolha Formatar e escolha Formatar Células.

    Na guia Página Inicial, botão Formatar e o botão Formatar Células no menu

  5. Na caixa Formatar Células, escolha Personalizado na lista Categoria.

  6. Na caixa Tipo, na parte superior da lista de formatos, digite [h]:mm;@ e escolha OK.

    Anote os dois pontos após [h] e um ponto e vírgula após mm.

O resultado é 28 horas e 15 minutos. O formato estará na lista Tipo na próxima vez que precisar dele.

Subtrair tempo

Aqui está outro exemplo: digamos que você e seus amigos saibam seus horários de início e término em um projeto voluntário e querem saber quanto tempo você gastou no total.

Siga estas etapas para obter o tempo decorrido, que é a diferença entre duas vezes.

  1. Na célula B2, insira a hora de início e inclua "a" para AM ou "p" para PM. Em seguida, pressione Enter.

  2. Na célula C2, insira a hora de término, incluindo "a" ou "p" conforme apropriado e pressione Enter.

  3. Digite outros horários de início e de término para os amigos Júlio e Leila.

  4. Na célula D2, subtraia a hora de término da hora de início inserindo a fórmula =C2-B2e pressione Enter.

    Um tempo subtraído do outro para obter o tempo decorrido

  5. Na caixa Formatar Células, clique em Personalizada na lista Categoria.

  6. Na lista Tipo, clique em h:mm (para horas e minutos) e clique em OK.

    Agora, podemos ver que Richard trabalhou 3 horas e 45 minutos.

    Tempos decorridos listados na coluna D

  7. Para obter os resultados de Júlio e Leila, selecione a célula D2 e arraste-a até a célula D4 para copiar a fórmula.

    A formatação da célula D2 é copiada juntamente com a fórmula.

Para subtrair o tempo que é superior a 24 horas:

É necessário criar uma fórmula para subtrair a diferença entre duas vezes que totalizam mais de 24 horas.

Siga as etapas abaixo:

  1. No exemplo acima, selecione a célula B1 e arraste-a até a célula B2 para aplicar a formatação às duas células ao mesmo tempo.

  2. Na caixa Formatar Células, clique em Personalizada na lista Categoria.

  3. Na caixa Tipo, na parte superior da lista de formatos, digite d/m/aaaa h:mm AM/PM.

    Observe o espaço vazio no final de yyyy e no final de mm.

    O novo formato estará disponível quando você precisar dele na lista Tipo.

  4. Na célula B1, digite a data de início, inclusive dia/mês/ano e o horário usando “a” ou “p” para AM e PM.

    Tempo decorrido acima de 24 horas

  5. Faça o mesmo para a data de término na célula B2.

  6. Digite a fórmula =(B2-B1)*24 na célula B3.

O resultado é 31,5 horas.

Observação: Você pode adicionar e subtrair mais de 24 horas em Excel para a Web mas não pode aplicar um formato de número personalizado.

Adicionar tempos

Imagine que você queira saber quantas horas e minutos serão necessários para concluir duas tarefas. Você estima que a primeira tarefa levará 6 horas e 45 minutos e a segunda levará 9 horas e 30 minutos.

  1. Na célula B2, digite 6:45 e, na célula B3, digite 9:30.

  2. Digite =B2+B3 na célula B4 e depois pressione Enter.

Tempo somado para duas tarefas

Serão necessárias 16 horas e 15 minutos para concluir as duas tarefas.

Dica: Você também pode adicionar tempos usando o AutoSum. Clique na célula B4. Em seguida, clique em Home > AutoSum. A fórmula terá a seguinte aparência: =SOMA(B2:B3). Pressione Enter para obter o resultado: 16 horas e 15 minutos.

Subtrair tempo

Digamos que você e seus amigos saibam as horas de início e de término em um projeto voluntário e queiram saber quanto tempo foi gasto com essa atividade. Em outras palavras, vocês querem saber o tempo decorrido ou a diferença entre dois tempos.

  1. Na célula B2, digite a hora de início, insira um espaço e depois digite “a” para AM ou “p” para PM e pressione Enter. Na célula C2, digite a hora de término, incluindo “a” ou “p”, conforme apropriado, e pressione Enter. Digite as outras horas de início e de término para os seus amigos Joy e Leslie.

  2. Na célula D2, subtraia a hora de término da hora de início digitando a fórmula: =C2-B2 e depois pressionando Enter.

Um tempo subtraído do outro para obter o tempo decorrido

Agora, podemos ver que Richard trabalhou 3 horas e 45 minutos.

  1. Para obter os resultados de Joy e Leslie, copie a fórmula clicando na célula D2 e arrastando-a até a célula D4. A formatação na célula D2 é copiada junto com a fórmula.

Tempos decorridos listados na coluna D

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×