Como corrigir um #DIV/0! erro

O Microsoft Excel mostra o erro #DIV/0! quando um número é dividido por zero (0). Isso acontece quando você insere uma fórmula simples, como =5/0, ou quando uma fórmula se refere a uma célula que contém 0 ou está vazia, como mostrado na imagem.

Exemplos de fórmulas que causam #DIV/0! erros.

Para corrigir o erro, faça o seguinte:

  • Verifique se o divisor na função ou fórmula não é zero (0) nem uma célula em branco.

  • Altere a referência de célula na fórmula para outra célula que não tenha um valor zero (0) ou em branco.

  • Insira #N/D na célula que é referenciada como divisor na fórmula, que alterará o resultado da fórmula para #N/D para indicar que o valor do divisor não está disponível.

Muitas vezes o #DIV/0! o erro não pode ser evitado porque suas fórmulas estão aguardando a entrada de você ou de outra pessoa. Nesse caso, você não deseja que a mensagem de erro seja exibida, portanto, há alguns métodos de tratamento de erros que você pode usar para suprimir o erro enquanto aguarda a entrada.

Avaliar o denominador para 0 ou nenhum valor

A maneira mais simples de suprimir o erro #DIV/0! é usando a função SE para avaliar a existência do denominador. Se for 0 ou nenhum valor, mostre um 0 ou nenhum valor como o resultado da fórmula em vez do valor do erro #DIV/0! ou calcule a fórmula.

Por exemplo, se a fórmula que retorna o erro for =A2/A3, use =SE(A3;A2/A3,0) para retornar 0 ou =SE(A3;A2/A3;"") para retornar uma cadeia de caracteres vazia. Você também pode exibir uma mensagem personalizada como esta: =SE(A3;A2/A3;"Entrada Necessária"). Com a função QUOCIENTE do primeiro exemplo, você usaria =SE(A3;QUOCIENTE(A2;A3);0). Isso informa ao Excel que SE(A3 existir, retorne o resultado da fórmula, caso contrário, ignore-o).

Exemplos de resolução #DIV/0! erros.

Use IFERROR para suprimir o #DIV/0! erro

Você também pode suprimir esse erro aninhando sua operação de divisão dentro da função IFERROR. Novamente, usando A2/A3, você pode usar =SEERRO(A2/A3;0). Isso informa o Excel se sua fórmula avalia como um erro e retorna 0, ou se retorna o resultado da fórmula.

Para as versões do Excel anteriores ao Excel 2007, você pode usar o método SE(ÉERROS()): =SE(ÉERROS(A2/A3);0;A2/A3) Confira Funções É.

Observação: os métodos IFERROR e IF(ISERROR()) são manipuladores de erro de manta, já que eles suprimim todos os erros, não apenas #DIV/0!. Você precisa garantir que sua fórmula funcione corretamente antes de aplicar qualquer tratamento de erros, caso contrário, talvez você não perceba que sua fórmula não está funcionando como esperado.

Dica: Se a verificação de erro estiver ligada no Excel, você poderá clicar em Imagem do botão ao lado da célula que mostra o erro. Clique em Mostrar Etapas de Cálculo se não estiver disponível e escolha a resolução que funcione para seus dados.

Você tem alguma dúvida sobre uma função específica?

Postar uma pergunta no fórum da comunidade do Excel

Ajude-nos a melhorar o Excel

Você tem sugestões sobre como podemos melhorar a próxima versão do Excel? Em caso afirmativo, confira os tópicos no site User Voice do Excel.

Confira também

Função SE

Função SEERRO

Funções É

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detectar erros em fórmulas

Funções do Excel (ordem alfabética)

Funções do Excel (por categoria)

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×