Como corrigir uma #REF! erro

Como corrigir uma #REF! erro

O erro #REF! é mostrado quando uma fórmula se refere a uma célula que não é válida. Isso geralmente ocorre quando células que foram referenciadas por fórmulas são excluídas ou algo é colado sobre elas.

Exemplo - erro #REF! causado pela exclusão de uma coluna

O exemplo a seguir usa a fórmula =SOMA(B2;C2;D2) na coluna E.

Uma fórmula que usa referências de células explícitas como =SOMA(B2;C2;D2) poderá causar um erro #REF! se uma coluna for excluída.

Se você excluisse as colunas B, C ou D, isso causaria uma #REF! erro. Nesse caso, excluiremos a coluna C (Vendas de 2007) e a fórmula agora lê =SUM(B2,#REF!,C2). Quando você usa referências de célula explícitas como esta (onde você faz referência a cada célula individualmente, separada por uma vírgula) e exclui uma linha ou coluna referenciada, o Excel não pode resolvê-la, portanto, ela retorna o #REF! erro. Esse é o principal motivo pelo qual o uso de referências de células explícitas em funções não é recomendado.

Exemplo do erro #REF! causado pela exclusão de uma coluna.

Solução

  • Se excluiu linhas ou colunas por engano, você pode clicar imediatamente no botão Desfazer na Barra de Ferramentas de Acesso Rápido (ou pressionar CTRL+Z) para restaurá-las.

  • Ajuste a fórmula para que ela use uma referência de intervalo em vez de células individuais, como =SOMA(B2:D2). Agora você pode excluir qualquer coluna dentro do intervalo de soma, e o Excel ajustará automaticamente a fórmula. Você também pode usar =SOMA(B2:B5) para uma soma de linhas.

Exemplo - PROCV com referências de intervalo incorretas

No exemplo a seguir, =PROCV(A8;A2:D5;5;FALSO) retornará um erro #REF! porque está procurando um valor de retorno da coluna 5, mas o intervalo de referência é A:D, que só tem quatro colunas.

Exemplo de uma fórmula VLOOKUP com um intervalo incorreto.  Formula is =VLOOKU(A8,A2:D5,5,FALSE).  Não há quinta coluna no intervalo VLOOKUP, portanto, 5 causa uma #REF! erro.

Solução

Ajuste o intervalo para ser maior ou reduza o valor de pesquisa de coluna para corresponder ao intervalo de referência. =PROCV(A8;A2:E5;5;FALSO) seria um intervalo de referência válida, assim como =PROCV(A8;A2:D5;4;FALSO).

Exemplo - ÍNDICE com uma referência incorreta de linha ou coluna

Nesse exemplo, a fórmula =ÍNDICE(B2:E5;5;5) retorna um erro #REF! porque o intervalo de índice é de quatro linhas por quatro colunas, mas a fórmula está pedindo para retornar o que está na quinta coluna e na quinta linha.

Exemplo de uma fórmula ÍNDICE com uma referência de intervalo inválida.  A fórmula é =ÍNDICE(B2:E5;5;5), mas o intervalo é de apenas quatro linhas por quatro colunas.

Solução

Ajuste as referências de linha ou coluna para que estejam dentro do intervalo de pesquisa de ÍNDICE. =ÍNDICE(B2:E5;4;4) retornaria um resultado válido.

Exemplo – referência a uma pasta de trabalho fechada com INDIRETO

No exemplo a seguir, uma função INDIRECT está tentando fazer referência a uma workbook que está fechada, causando uma #REF! erro.

Exemplo de um erro #REF! causado porque INDIRETO faz referência a uma pasta de trabalho fechada.

Solução

Abra a workbook referenciada. Você encontrará o mesmo erro se referenciar uma lista de trabalho fechada com uma função de matriz dinâmica.

Problemas OLE

Se você tiver usado um link OLE (Vinculação e Incorporação de Objeto) que está retornando um #REF! error e, em seguida, inicie o programa que o link está chamando.

Observação: OLE é uma tecnologia que você pode usar para compartilhar informações entre programas.

Problemas de DDE

Se você tiver usado um tópico DDE (Dynamic Data Exchange) que está retornando um #REF! error, primeiro verifique se você está fazendo referência ao tópico correto. Se você ainda estiver recebendo uma #REF! error, check your Trust Center Settings for external content as outlined in Block or unblock external content in Office documents.

Observação: O DDE (Dynamic Data Exchange)é um protocolo estabelecido para a troca de dados entre programas baseados no Microsoft Windows.

Problemas de Macro

Se uma macro inserir uma função na planilha que faz referência a uma célula acima da função, e a célula que contém a função estiver na linha 1, a função retornará #REF! , pois não há células acima da linha 1. Verifique a função para determinar se um argumento faz referência a uma célula ou a intervalo de células que não é válido. Isso pode exigir a edição da macro no VBE (Editor do Visual Basic) para levar essa situação em conta.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community, obter suporte na Comunidade de respostas ou sugerir um novo recurso ou melhoria no UserVoice do Excel.

Confira também

Visão geral de fórmulas no Excel

Como evitar fórmulas quebradas

Detectar erros em fórmulas

Funções do Excel (ordem alfabética)

Funções do Excel (por categoria)

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×