Sign in with Microsoft
Sign in or create an account.

Suponha que o design do banco de dados da área de trabalho do Microsoft Access tenha sido alterado (tabelas novas ou modificadas, consultas, propriedades de campo, formulários ou relatórios) e você queira ver um histórico dessas alterações. Você pode usar Comparação de Banco de Dados para comparar a versão de um banco de dados Access área de trabalho com outra. Você verá diferença, como tabelas novas ou alteradas, consultas, campos, propriedades de campo e assim por diante, em um relatório do SQL Server Reporting Services que você pode exportar para Excel ou salvar no formato PDF.

Observação: Você não pode usar o Comparação de Banco de Dados aplicativos Web do Access.

Neste artigo

  1. Abra Comparação de Banco de Dados. Você verá uma caixa de diálogo simples que tem duas guias: Configuração e Resultados.

  2. Na guia Configuração, ao lado da caixa Comparar, use o botão Procurar Botão Procurar para localizar o banco de dados que você deseja usar como a "linha de base" (ou a versão anterior). Quando encontrar o arquivo desejado, selecione Abrir.
    Caixas Comparar e Para, e opções de relatório

  3. Ao lado da caixa Para , selecione o botão Procurar Botão Procurar para localizar o banco de dados que foi "alterado" (ou a versão mais recente).

  4. Na seção Opções de Relatório, escolha os objetos de banco de dados (tabelas, consultas, macros, módulos, relatórios, formulários ou páginas) que você deseja comparar marcando as caixas ao lado deles.

  5. Na seção Valores de Relatório , escolha Completoou Breve para especificar o quão detalhado você deseja que os resultados sejam.

  6. Selecione Comparar para executar a comparação.

Depois que a comparação for concluída, um SQL Server Reporting Services será aberto na tela. Você pode exportar esse relatório para Excel ou salvar o relatório no formato PDF.

Início da Página

Criar versões de backup do banco de dados

A melhor maneira de controlar as alterações de design no banco de dados da área de trabalho é salvando uma ou mais versões de backup. Fazer backup do banco de dados é um processo diferente de apenas salvar uma cópia.

  1. Selecione Arquivo > Salvar como.

  2. Em Salvar Banco de Dados como > Avançado , selecione Fazer Backup do Banco de Dados.

O backup é salvo com o ano, o mês e a data acrescentados ao nome do arquivo. Se você salvar vários backups no mesmo dia, um sublinhado e um número entre parênteses serão adicionados após a data. Vários backups de um banco de dados chamado Inventory.accdb de um dia (13/03/2012) podem ter esta aparência:

  • Inventory _2012_03_13.accdb

  • Inventory _2012_03_13_(1).accdb

  • Inventory _2012_03_13_(2).accdb

Para localizar o comando Fazer Backup do Banco de Dados em versões anteriores do Access:

  • No Access 2010, clique em Arquivo >Salvar & Publicar > Banco de Dados > Backup Avançado.

  • No Access 2007, clique no botão Office para > gerenciar > backup de banco de dados.

  • No Access 2003 e em versões anteriores, clique em Arquivo >Backup de Banco de Dados.

Início da Página

Você receberá uma mensagem de erro "Não é possível abrir o banco de dados do Access"?

Se você receber uma mensagem de erro "Não é possível abrir o banco de dados do Access", provavelmente, pelo menos um dos bancos de dados da área de trabalho está protegido por uma senha. Clique em OK na caixa de diálogo e insira a senha. Caso contrário, a comparação não poderá ser executada.

Para saber mais sobre como armazenar senhas no Comparação de Banco de Dados, consulte Gerenciar senhas usadas para abrir arquivos para comparação.

Início da Página

Você receberá uma mensagem de erro "Exceção sem tratamento"?

Se você receber uma mensagem de erro "Exceção sem tratamento" ao tentar usar o Comparação de Banco de Dados, provavelmente, alguns componentes de pré-requisito não serão instalados no computador. Embora Comparação de Banco de Dados esteja incluído no Access, determinados pré-requisitos necessários para que o Comparação de Banco de Dados funcione corretamente não são instalados automaticamente. Siga este procedimento:

  1. Entre no computador do usuário como administrador.

  2. Baixe e instale o Download .NET Framework 4.0.

  3. Baixe e instale SQLSysClrTypes (64 bits) ou SQLSysClrTypes (32 bits).

  4. Baixe e instale o Microsoft Report Viewer Runtime 2015.

  5. Reinicie o computador do usuário.

Início da Página

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar Microsoft Office Insider

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?

Obrigado pelos seus comentários!

×