Quando você precisar contar os caracteres nas células, use a função LEN. A função conta letras, números, caracteres e todos os espaços. Por exemplo, o comprimento de "Está 98 graus hoje, então eu vou nadar" (excluindo aspas) é de 42 caracteres— 31 letras, 2 números, 8 espaços, uma vírgula e 2 apóstrofos.

  • Para usar a função, insira =NÚM.CARACT(célula) na barra de fórmulas e pressione Enter. Nesses exemplos, célula é a célula que você deseja contar, como B1.

  • Para contar os caracteres em mais de uma célula, insira a fórmula, copie-a e cole-a em outras células.

  • Para contar o número total de caracteres em várias células, use as funções SOMA junto com NÚM.CARACT. Por exemplo, =SOMA((NÚM.CARACT(célula1),NÚM.CARACT(célula2),(NÚM.CARACT(célula3)))). Nesse exemplo, a função NÚM.CARACT conta os caracteres em cada célula e a função SOMA adiciona as contagens.

  • Para contar determinados caracteres específicos dentro das células, use a função NÚM.CARACT com a função SUBSTITUIR. Por exemplo, se você quiser saber quantos Zs minúsculos há dentro de uma célula, use esta fórmula: =NÚM.CARACT(célula1)-NÚM.CARACT(SUBSTITUIR (célula1,"z",""))

Experimente

Digite os dados a seguir em uma nova planilha do Excel. Inicie na célula A1.

Cadeia de Caracteres de Texto

Fórmulas

A rápida raposa marrom

A rápida raposa marrom saltou

A rápida raposa marrom saltou sobre o cachorro preguiçoso

Contar caracteres em uma célula

  1. Clique na célula B2.

  2. Na célula, insira =NÚM.CARACT(A2) e pressione Enter.

A fórmula conta os caracteres na célula A2, e o número é 19, incluindo todos os espaços. Se você tem espaços depois do ponto final, eles também serão contados.

Contar caracteres em várias células

  1. Pressione CONTROL+C para copiar a célula B2.

  2. Pressione CONTROL+V para colar sua fórmula nas células B3:B4

Isso copia a fórmula para as células B3 e B4, e a função conta os caracteres em cada célula (26 e 44).

Contar o número total de caracteres

  1. Clique na célula B6.

  2. Na célula, insira =SOMA(NÚM.CARACT(A2),NÚM.CARACT(A3),NÚM.CARACT(A4)) e pressione Enter.

Isso conta os caracteres em cada uma das três células e os totaliza (89).

Para contar determinados caracteres específicos em células

  1. Clique na célula C4.

  2. Na célula, insira =NÚM.CARACT(A4)-NÚM.CARACT(SUBSTITUIR(A4,"z","")) e pressione Enter.

Em resumo, isso conta todas as letras minúsculas Zs na célula A4, que é 1.

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar Microsoft Office Insider

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?

Obrigado pelos seus comentários!

×