Converter um banco de dados no formato de arquivo .accdb

O Access cria bancos de dados no formato de arquivo .accdb. Esse formato dá suporte a recursos como campos multivalorados, macros de dados e publicação para Serviços do Access.

Você pode converter bancos de dados criados no Microsoft Office Access 2003, Access 2002, Access 2000 ou Access 97 no formato de arquivo .accdb. No entanto, lembre-se de que um banco de dados no formato de arquivo .accdb não pode ser aberto ou vinculado usando versões do Access anteriores ao Access 2007.

Além disso, o formato .accdb não dá suporte à replicação ou à segurança no nível do usuário. Se você precisar compartilhar seu banco de dados com pessoas que usam o Access 2003 ou anteriores ou se precisar usar a replicação ou a segurança no nível do usuário, você deve usar o formato de arquivo .mdb.

Observação: Embora compartilhem o mesmo formato de arquivo, alguns recursos no Access 2010 e versões mais recentes não podem ser usados no Access 2007. Para obter mais informações, consulte a seção Usar o Access 2007para abrir um banco de dados criado ou modificado em versões mais recentes.

Neste artigo

Converter um banco de dados do Access 2000 ou do Access 2002 - 2003 no formato .accdb

Para converter um banco de dados do Access 2000 ou do Access 2002 - 2003 (.mdb) no formato de arquivo .accdb, você deve primeiro abrir o banco de dados usando o Access 2007, o Access 2010, o Access 2013 ou o Access 2016 e salvá-lo no formato de arquivo .accdb.

  1. Clique em Arquivo e em Abrir.

  2. Clique no banco de dados do Access 2000 ou do Access 2002 - 2003 (.mdb) que você deseja converter.

    Observação: Se a caixa de diálogo Aprimoramento do Banco de Dados for exibida, o banco de dados está usando um formato de arquivo anterior ao Access 2000. Para continuar, consulte a seção Converter um banco de dados do Access 97 no formato .accdb.

  3. Clique em Arquivo,clique em Salvar como e clique em Salvar Banco de Dados como.

  4. Escolha o tipo de arquivo do Access e clique em Salvar como.

    Se algum objeto de banco de dados estiver aberto quando você clicar em Salvar como, o Access solicitará que você os feche antes de criar a cópia. Clique em Sim para fazer o Access fechar os objetos ou clique em Não para cancelar todo o processo. Se necessário, o Access também solicitará que você salve quaisquer alterações.

  5. Na caixa de diálogo Salvar como, digite um nome de arquivo na caixa Nome do arquivo e clique em Salvar.

    O Access cria a cópia do banco de dados e abre a cópia. O Access fecha automaticamente o banco de dados original.

Converter um banco de dados do Access 97 no formato .accdb

A partir do Access 2013, não é mais possível converter diretamente um banco de dados do Access 97 (.mdb) no formato de arquivo .accdb. No entanto, você pode abrir um banco de dados do Access 97 em uma versão anterior do Access e salvar o banco de dados em um formato que o Access 2013 possa abrir. Por exemplo, veja como usar o Access 2003 para abrir um banco de dados do Access 97 e convertê-lo em um formato que pode ser aberto pelo Access 2013:

  1. Abra o banco de dados do Access 97 no Access 2003.

  2. Clique em Ferramentas > Utilitários de Banco de Dados > Converter banco de dados > para o formato de arquivo do Access 2002-2003.

  3. Insira um nome para o banco de dados e clique em Salvar.

  4. Feche o Access 2003 e abra o Access 2013.

  5. Abra o banco de dados e clique em Arquivo > Salvar como > Banco de Dados do Access (.accdb) > Salvar como > Salvar.

Você também pode usar o Access 2007 ou o Access 2010 para converter um banco de dados do Access 97 no formato .accdb. Quando você abre um banco de dados do Access 97 em qualquer um desses dois produtos, o assistente de Aprimoramento de Banco de Dados aparece para ajudar a converter o banco de dados em um formato .accdb.

Use o Access 2007 para abrir um banco de dados criado ou modificado em versões mais recentes

Como o Access 2016, Access 2013, Access 2010 e Access 2007 usam o mesmo formato de arquivo, você pode usar o Access 2007 para abrir um banco de dados criado no Access 2010, Access 2013 ou no Access 2016 sem primeiro usar o comando Salvar como. No entanto, o Access 2016, Access 2013 e o Access 2010 incluem alguns recursos que exigem que o Access 2016, Access 2013 e o Access 2010 seja executado. Dependendo do recurso, um dos seguintes pode acontecer quando você tentar usar o banco de dados no Access 2007:

  • Não é possível modificar o objeto que usa o recurso.

  • Não é possível abrir o objeto que usa o recurso.

  • Não é possível abrir o banco de dados no Access 2007.

Início da página

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×