Testar se as condições são verdadeiras ou falsas e fazer comparações lógicas entre expressões é comum a muitas tarefas. Você pode usar as funções AND, OR, NOT e IF para criar fórmulas condicionais.

Por exemplo, a função SE usa os seguintes argumentos.

fórmula com a função se

Fórmula que usa a função SE

Imagem do botão logical_test: a condição que você deseja verificar.

Texto explicativo 2 value_if_true: o valor a ser retornado se a condição for True.

Imagem do botão value_if_false: o valor a ser retornado se a condição for False.

Para obter mais informações sobre como criar fórmulas, consulte Criar ou excluir uma fórmula.

O que você deseja fazer?

Criar uma fórmula condicional que resulta em um valor lógico (VERDADEIRO ou FALSO)

Para realizar essa tarefa, use as funções e operadores AND, OR e NOT , conforme mostrado no exemplo a seguir.

Exemplo

O exemplo pode ser mais fácil de compreender se você copiá-lo para uma planilha vazia.

Como copiar um exemplo?

  1. Selecione o exemplo neste artigo.

    selecionando um exemplo na Ajuda do Excel 2013 para Windows

    Selecionar um exemplo da Ajuda

  2. Pressione Ctrl+C.

  3. Crie uma planilha ou pasta de trabalho em branco no Excel.

  4. Na planilha, selecione a célula A1 e pressione Ctrl+V.

Importante: Para que o exemplo funcione corretamente, você deve colá-lo na célula A1 da planilha.

  1. Para alternar entre visualizar os resultados e as fórmulas que retornam os resultados, pressione CTRL+` (acento grave), ou na guia Fórmulas no grupo Auditoria de Fórmula, clique no botão Exibir Fórmulas.

Após copiar o exemplo em uma planilha em branco, você poderá adaptá-lo conforme as suas necessidades.

Dados

15

9

8

Rodas dentadas

Widgets

Fórmula

Descrição (Resultado)

=AND(A2>A3, A2<A4)

Determina se o valor na célula A2 é maior que o valor em A3 e também se o valor em A2 é menor que o valor em A4. (FALSE)

=OR(A2>A3, A2<A4)

Determina se o valor na célula A2 é maior que o valor em A3 ou se o valor em A2 é menor que o valor em A4. (VERDADEIRO)

=NÃO(A2+A3=24)

Determina se a soma dos valores nas células A2 e A3 não é igual a 24. (FALSE)

=NOT(A5="Sprockets")

Determina se o valor na célula A5 não é igual a "Sprockets". (FALSE)

=OR(A5<>"Sprockets",A6 = "Widgets")

Determina se o valor na célula A5 não é igual a "Sprockets" ou se o valor em A6 é igual a "Widgets". (VERDADEIRO)

Para obter mais informações sobre como usar essas funções, consulte a função AND, a função OR e a função NOT.

Início da Página

Criar uma fórmula condicional que resulta em outro cálculo ou em valores diferentes de TRUE ou FALSE

Para realizar essa tarefa, use as funções SE, AND e OR e operadores, conforme mostrado no exemplo a seguir.

Exemplo

O exemplo pode ser mais fácil de compreender se você copiá-lo para uma planilha vazia.

Como copiar um exemplo?

  1. Selecione o exemplo neste artigo.

    Importante: Não selecione os cabeçalhos de linha ou de coluna.

    selecionando um exemplo na Ajuda do Excel 2013 para Windows

    Selecionar um exemplo da Ajuda

  2. Pressione Ctrl+C.

  3. Crie uma planilha ou pasta de trabalho em branco no Excel.

  4. Na planilha, selecione a célula A1 e pressione Ctrl+V.

Importante: Para que o exemplo funcione corretamente, você deve colá-lo na célula A1 da planilha.

  1. Para alternar entre visualizar os resultados e as fórmulas que retornam os resultados, pressione CTRL+` (acento grave), ou na guia Fórmulas no grupo Auditoria de Fórmula, clique no botão Exibir Fórmulas.

Após copiar o exemplo em uma planilha em branco, você poderá adaptá-lo conforme as suas necessidades.

Dados

15

9

8

Rodas dentadas

Widgets

Fórmula

Descrição (Resultado)

=SE(A2=15, "OK", "Não OK")

Se o valor na célula A2 for igual a 15, retorne "OK". Caso contrário, retorne "Não ok". (OK)

=SE(A2<>15, "OK", "Não OK")

Se o valor na célula A2 não for igual a 15, retorne "OK". Caso contrário, retorne "Não ok". (Não ok)

=SE(NÃO(A2<=15), "OK", "Não OK")

Se o valor na célula A2 não for menor ou igual a 15, retorne "OK". Caso contrário, retorne "Não ok". (Não ok)

=SE(A5<>"SPROCKETS", "OK", "Não OK")

Se o valor na célula A5 não for igual a "SPROCKETS", retorne "OK". Caso contrário, retorne "Não ok". (Não ok)

=SE(AND(A2>A3, A2<A4), "OK", "Não OK")

Se o valor na célula A2 for maior que o valor em A3 e o valor em A2 também for menor que o valor em A4, retornará "OK". Caso contrário, retorne "Não ok". (Não ok)

=SE(AND(A2<>A3, A2<>A4), "OK", "Não OK")

Se o valor na célula A2 não for igual a A3 e o valor em A2 também não for igual ao valor em A4, retornará "OK". Caso contrário, retorne "Não ok". (OK)

=SE(OU(A2>A3, A2<A4), "OK", "Não OK")

Se o valor na célula A2 for maior que o valor em A3 ou se o valor em A2 for menor que o valor em A4, retornará "OK". Caso contrário, retorne "Não ok". (OK)

=SE(OR(A5<>"Sprockets", A6<>"Widgets"), "OK", "Not OK")

Se o valor na célula A5 não for igual a "Sprockets" ou o valor em A6 não for igual a "Widgets", retorne "OK". Caso contrário, retorne "Não ok". (Não ok)

=SE(OU(A2<>A3, A2<>A4), "OK", "Não OK")

Se o valor na célula A2 não for igual ao valor em A3 ou se o valor em A2 não for igual ao valor em A4, retornará "OK". Caso contrário, retorne "Não ok". (OK)

Para obter mais informações sobre como usar essas funções, consulte a função SE, a função AND e a função OR.

Início da Página

Precisa de mais ajuda?

Expanda suas habilidades

Explore o treinamento >

Obtenha novos recursos primeiro

Ingressar no Microsoft Insider >

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?

Obrigado pelos seus comentários!

×