No Word, você pode automatizar tarefas usadas com frequência criando e executando macros. Uma macro é uma série de comandos e instruções que você agrupa como um único comando para realizar uma tarefa automaticamente.

Para poupar tempo em tarefas que você costuma realizar com frequência, compacte as etapas em uma macro. Em primeiro lugar, grave a macro. Em seguida, você poderá executá-la clicando em um botão da Barra de Ferramentas de Acesso Rápido ou pressionando uma combinação de teclas. Isso dependerá de como você a configurar.

  1. Clique em Exibir > Macros > Gravar Macro.

    Comando Gravar Macro

  2. Digite um nome para a macro.

    Caixa de nome da macro

  3. Para usar essa macro em qualquer novo documento que você criar, verifique se a caixa Armazenar macro em exibe Todos os Documentos (Normal.dotm).

    Caixa para escolher onde armazenar uma macro

  4. Para executar uma macro quando você clicar em um botão, clique em Botão.

    Clique para atribuir a macro a um botão

  5. Clique na nova macro (cujo nome é algo do tipo Normal.NovasMacros.<nome da sua macro>) e clique em Adicionar.

    A macro e o botão Adicionar

  6. Clique em Modificar.

    Botão Modificar na caixa Personalizar a Barra de Ferramentas de Acesso Rápido

  7. Escolha uma imagem de botão, digite o nome desejado e clique em OK duas vezes.

    Opções de botão na caixa Modificar Botão

  8. Agora, chegou a hora de gravar as etapas. Clique nos comandos ou pressione as teclas para cada etapa na tarefa. O Word grava seus cliques e pressionamentos de teclas.

    Observação: Use o teclado para selecionar texto enquanto você grava a macro. Macros não gravam seleções feitas com o mouse.

  9. Para parar de gravar, clique em Exibir > Macros > Parar Gravação.

    Comando Parar Gravação

O botão da sua macro aparece na Barra de Ferramentas de Acesso Rápido.

Botão da macro na Barra de Ferramentas de Acesso Rápido

Para executar a macro, clique no botão.

  1. Clique em Exibir > Macros > Gravar Macro.

    Comando Gravar Macro

  2. Digite um nome para a macro.

    Caixa de nome da macro

  3. Para usar essa macro em qualquer novo documento que você criar, verifique se a caixa Armazenar macro em exibe Todos os Documentos (Normal.dotm).

    Caixa para escolher onde armazenar uma macro

  4. Para executar sua macro quando você pressionar um atalho do teclado, clique em Teclado.

    Clique para atribuir a macro a um atalho de teclado

  5. Digite uma combinação de teclas na caixa Pressione a nova tecla de atalho.

  6. Verifique se essa combinação já não está atribuída a outro item. Se estiver, tente uma combinação diferente.

  7. Para usar esse atalho de teclado em qualquer novo documento criado, verifique se a caixa Salvar alterações em indica Normal.dotm.

  8. Clique em Atribuir.

  9. Agora, chegou a hora de gravar as etapas. Clique nos comandos ou pressione as teclas para cada etapa na tarefa. O Word grava seus cliques e pressionamentos de teclas.

    Observação: Use o teclado para selecionar texto enquanto você grava a macro. Macros não gravam seleções feitas com o mouse.

  10. Para parar de gravar, clique em Exibir > Macros > Parar Gravação.

    Comando Parar Gravação

Para executar a macro, pressione as teclas de atalho do teclado.

Para executar uma macro, clique no botão na Barra de Ferramentas de Acesso Rápido, pressione o atalho de teclado ou executar a macro a partir da lista de Macros.

  1. Clique em Exibir > Macros > Exibir Macros.

    Comando Exibir Macros

  2. Na lista em Nome da macro, clique na macro a ser executada.

  3. Clique em Executar.

Para disponibilizar uma macro de um documento em todos os novos documentos, adicione-a ao modelo Normal.dotm.

  1. Abra o documento que contém a macro.

  2. Clique em Exibir > Macros > Exibir Macros.

    Comando Exibir Macros

  3. Clique em Organizador.

    Botão Organizador na caixa Exibir Macros

  4. Clique na macro que você quer adicionar ao modelo Normal.dotm e clique em Copiar.

  1. Clique em Arquivo > Opções > Personalizar Faixa de Opções.

  2. Em Escolher comandos de, clique em Macros.

  3. Clique na macro desejada.

  4. Em Personalizar a faixa de opções, clique na guia e no grupo personalizado onde você quer adicionar a macro.

Se você não tiver um grupo personalizado, clique em Novo Grupo. Em seguida, clique em Renomear e digite um nome para seu grupo personalizado.

  1. Clique em Adicionar.

  2. Clique em Renomear para escolher uma imagem para a macro e digitar o nome desejado.

  3. Clique em OK duas vezes.

  1. Na guia Desenvolvedor, no grupo Código, clique em Macros.

  2. Na caixa Nome da macro, digite um nome para a macro.

    Observação: Se você der a uma nova macro o mesmo nome de uma macro integrada no Word, as novas ações de macro substituirão a macro integrada. Para exibir uma lista de macros criadas, clique em Comandos do Word na lista Macros em.

  3. Na lista Macros, clique no modelo ou documento no qual você deseja armazenar a macro.

    Para disponibilizar sua macro em todos os documentos, clique em Normal.dotm.

  4. Clique em Criar para abrir o Visual Basic Editor.

Depois de abrir o editor Visual Basic, talvez você queira mais informações sobre como trabalhar com Visual Basic for Applications. Para obter mais informações, clique em Microsoft Visual Basic Ajuda no menu Ajuda ou pressione F1.

Você pode gravar uma sequência de ações ou gravar uma macro do zero inserindo Visual Basic for Applications código no Editor do Visual Basic.

Observação: Para trabalhar com macros Office Word 2007, você precisa mostrar a guia Desenvolvedor.

  1. Clique no botão do Microsoft Office imagem do botão office e clique em Opções do Word.

  2. Clique em Popular.

  3. Em Principais opções para trabalhar com o Word,selecione a guia Mostrar Desenvolvedor na caixa de seleção Faixa de Opções.

    Observação: A Faixa de Opções é um componente de Interface de usuário do Microsoft Office Fluent.

  1. Na guia Desenvolvedor, no grupo Código, clique em Gravar Macro.

    Grupo código na guia Desenvolvedor
  2. Na caixa Nome da macro, digite um nome para a macro.

    Observação: Se você der a uma nova macro o mesmo nome de uma macro integrada no Office Word 2007, as novas ações de macro substituirão a macro integrada. Para exibir uma lista de macros incorporados, na guia Desenvolvedor, no grupo Código, clique em Macros. Na lista Macros, clique em Comandos do Word.

  3. Na caixa Macro da Loja, clique no modelo ou documento no qual você deseja armazenar a macro.

    Importante: Para disponibilizar sua macro em todos os documentos, clique em Normal.dotm.

  4. Na caixa Descrição, digite uma descrição da macro.

  5. Siga um destes procedimentos:

    • Iniciar gravação    Para começar a gravar a macro sem atribuí-la a um botão na Barra de Ferramentas de Acesso Rápido ou a uma tecla de atalho, clique em OK.

    • Criar um botão    Para atribuir a macro a um botão na Barra de Ferramentas de Acesso Rápido, faça o seguinte:

      1. Clique em Botão.

      2. Em Personalizar Barra deFerramentas de Acesso Rápido , selecione o documento (ou todos os documentos) para o qual você deseja adicionar a macro à Barra de Ferramentas de Acesso Rápido.

        Importante: Para disponibilizar sua macro em todos os documentos, clique em Normal.dotm.

      3. Em Escolher comandos da caixa de diálogo, clique na macro que você está gravando e clique em Adicionar.

      4. Para personalizar o botão, clique em Modificar.

      5. Em Símbolo, clique no símbolo que você deseja usar para o botão.

      6. Na caixa Nome de exibição, digite o nome da macro que você deseja exibir.

      7. Clique em OK duas vezes para começar a gravar a macro.

        O símbolo escolhido é exibido na Barra de Ferramentas de Acesso Rápido. O nome que você digita é exibido quando você aponta para o símbolo.

    • Atribua um atalho de teclado    Para atribuir a macro a um atalho de teclado, faça o seguinte:

      1. Clique em Teclado.

      2. Na caixa Comandos, clique na macro que você está gravando.

      3. Na caixa Pressionar nova tecla de atalho, digite a sequência de teclas que você deseja e clique em Atribuir.

      4. Clique em Fechar para começar a gravar a macro.

  6. Execute as ações que você deseja incluir na macro.

    Observação: Ao gravar uma macro, você pode usar o mouse para clicar em comandos e opções, mas não para selecionar texto. Você deve usar o teclado para selecionar texto. Para obter mais informações sobre como selecionar texto usando o teclado, consulte Selecionar texto.

  7. Para parar de gravar suas ações, clique em Parar Gravação no grupo Código.

Alterar o atalho do teclado para uma macro

  1. Clique no botão do Microsoft Office imagem do botão office e clique em Opções do Word.

  2. Clique em Personalizar.

  3. Ao lado de Atalhos de teclado,clique em Personalizar.

  4. Na lista Categorias, clique em Macros.

  5. Na lista Macros, clique na macro que você deseja alterar.

  6. Na caixa Pressionar nova tecla de atalho, digite a combinação de teclas que você deseja escolher.

  7. Marque a caixa Chaves atuais para garantir que você não está atribuindo uma combinação de chaves que você já usa para executar uma tarefa diferente.

  8. Na lista Salvar alterações, clique na opção que corresponde ao local onde você deseja executar sua macro.

    Importante: Para disponibilizar sua macro em todos os documentos, clique em Normal.dotm.

  9. Clique em Fechar.

  1. Na guia Desenvolvedor, no grupo Código, clique em Macros.

    Grupo código na guia Desenvolvedor

  2. Na lista em Nome da macro,clique na macro que você deseja executar.

  3. Clique em Executar.

  1. Na guia Desenvolvedor, no grupo Código, clique em Macros.

    Grupo código na guia Desenvolvedor

  2. Na caixa Nome da macro, digite um nome para a macro.

    Observação: Se você der a uma nova macro o mesmo nome de uma macro integrada no Office Word 2007, as novas ações de macro substituirão a macro integrada. Para exibir uma lista de macros criadas, clique em Comandos do Word na lista Macros em.

  3. Na lista Macros em, clique no modelo ou documento no qual você deseja armazenar a macro.

    Para disponibilizar sua macro em todos os documentos, clique em Normal.dotm.

  4. Clique em Criar para abrir o Visual Basic Editor.

Depois de abrir o editor Visual Basic, talvez você queira mais informações sobre como trabalhar com Visual Basic for Applications. Para obter mais informações, clique em Microsoft Visual Basic Ajuda no menu Ajuda ou pressione F1.

Para fazer um trabalho rápido de tarefas que você faz com frequência, na versão da área de trabalho do Word, você pode agrupar as etapas em macros que são executadas com um único clique. Em Word para a Web, você precisa passar por essas tarefas manualmente.

Se você tiver o Word, primeiro clique em Abrir no Word para abrir seu documento no Word.

Imagem do comando Abrir no Aplicativo de Área de Trabalho

Em seguida, siga as instruções para a versão da área de trabalho do Word.

Quando você executar a macro no Word e salvar o documento, você verá os resultados da macro ao reabrir seu documento no Word para a Web.

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade da tradução?
O que afetou sua experiência?

Obrigado por seus comentários!

×