Criar um diagrama de componente UML

Você pode criar um diagrama de componente umL para mostrar componentes, portas, interfaces e as relações entre eles.

Um componente na UML representa uma parte modular de um sistema. O comportamento é definido em termos de interfaces necessárias e fornecidas. Um componente tem uma exibição externa com propriedades e operações públicas e tem uma exibição interna com propriedades privadas e classificadores de realização. A exibição interna mostra como o comportamento externo é realizado internamente.

Um diagrama de componente de UML de exemplo.

Primeiro, você abre o modelo componente de UML e escolhe uma das quatro opções. Em seguida, o estêncil componente de UML é exibido, juntamente com formas que estão em conformidade com o padrão UML 2.5.

Observação: O estêncil componente uml só estará disponível se você for um Visio Plano 2 assinante. Se você tem uma assinatura, verifique se sua versão do Visio é a mais recente.

Iniciar um diagrama de componente

  1. Inicie o Visio. Ou se você já tiver um arquivo aberto, clique em Arquivo > Novo.

  2. Vá para Categorias > Software e Banco de Dados > Componente UML.

  3. Selecione o modelo em branco ou um dos três diagramas de início. Quando você escolher o modelo que deseja, clique em Criar.

  4. Você deve ver a janela Formas ao lado do diagrama. Se você não vê-lo, vá para Exibir > Painéis de Tarefas e certifique-se de que Shapes está selecionado. Se você ainda não vir, clique no botão Expandir formas Botão Expandir Janela de Formas à esquerda.

  5. Na guia Exibir, verifique se a caixa de seleção ao lado de Pontos de Conexão está selecionada. Isso fará com que os pontos de conexão apareçam quando você começar a conectar formas.

  6. Agora, arraste formas que você deseja incluir no diagrama da janela Formas para a página. Para renomear rótulos de texto, clique duas vezes nos rótulos.

Formas de componente

Quando usar

Use formas de componente para cada unidade funcional em seu sistema ou aplicativo.

Forma de componente "Store"

Mostrar ou ocultar estereotipo

Clique com o botão direito do mouse na forma para mostrar ou ocultar o rótulo de estereótipo.

Menu clicar com o botão direito do mouse, mostrar o comando Estereótipo, <<componente>> rótulo de texto

Subsistemas

Você pode usar a forma do componente como uma forma de subsistema que contém outros componentes. Basta ressilá-lo para ser maior e soltar outros componentes em cima dele. Quando você vir o destaque verde, deixe ir. A partir desse ponto, a forma maior atuará como um contêiner, e a forma menor se move com ele.

Dica: Se um componente desaparecer depois de arrastá-lo sobre outro componente, traga-o para a frente pressionando CTRL+SHIFT+F.

Store subsystem shape with Order component dragd on it

Formas de interface

Quando usar

  1. Use a forma Interface Fornecida quando quiser especificar a realização de uma classe/interface.

  2. Use a Interface Necessária quando quiser especificar uma dependência em uma classe/interface.

Duas interfaces conectadas, 1: Forma de interface fornecida terminando com círculo, 2: Forma de interface necessária terminando com soquete

Etapa 1

Arraste uma forma de Interface Fornecida para a página e aborde o quadrado da porta com um ponto de conexão. Você sabe que ele está conectado quando você vê o destaque verde ao redor do ponto de conexão.

Forma de interface fornecida colada à forma Componente

Etapa 2

Arraste uma forma de Interface Necessária para a página e aborde o quadrado da porta com um ponto de conexão também. Você sabe que ele está conectado quando você vê o destaque verde ao redor do ponto de conexão.

Forma de interface necessária colada à forma Componente

Etapa 3

Para conectar uma interface Fornecida e Necessária, primeiro selecione a forma interface necessária. Em seguida, procure a alça amarela.

Alça amarela na forma interface necessária

Etapa 4

Arraste a alça amarela para se conectar à Interface Fornecida.

Forma de interface necessária conectada à Interface Fornecida

Dicas conectores

Corrigir conectores

Se um conector estiver fazendo muitas curvas, clique com o botão direito do mouse nele e clique em Conector Reto.

Mostrar multiplicidade

Se necessário, clique com o botão direito do mouse no conector e selecione Mostrar Multiplicidade. Quando você terminar, quatro caixas de texto aparecerão onde você pode adicionar detalhes. Se você não precisar de todas as caixas de texto, exclua as que não precisam.

Tipo de conector de alteração

Você pode alterar um tipo de conector. Por exemplo, você pode mudar de uma Associação para uma Associação Direcionada. Clique com o botão direito do mouse no conector e clique em Definir Tipo de Conector.

Fazer conexões dinâmicas em vez de conexões de ponto

Se você antecipar muito a movimentação de formas, considere fazer uma conexão dinâmica em vez de uma conexão de ponto.

Mover ou girar texto em conectores

O mais provável é que você precise girar ou mover o texto em suas linhas do conector. Veja como fazer isso:

  1. Clique em uma área vazia da página para desmarcar qualquer coisa que possa ser selecionada.

  2. Na guia Página Principal, no grupo Ferramentas, clique na ferramenta Bloco de Texto Botão Bloco de Texto

  3. Clique no conector que tem texto que você deseja girar ou mover.

  4. Arraste o bloco de texto para movê-lo ou gire-o usando a alça de rotação Alça de rotação

  5. Quando terminar, clique no botão Ferramenta de Ponteiro Botão Ponteiro

    Depois de alternar de volta para o botão Ferramenta de Ponteiro Botão Ponteiro , o texto mantém a mesma posição em relação à forma. Se você usar a Ferramenta de Ponteiro Botão Ponteiro arrastar o texto, a forma também será moveda. Para mover o texto independentemente da forma, volte para a Ferramenta de Bloqueio de Texto Botão Bloco de Texto .

Observação: Criar e editar diagramas de UML no Visio para a Web requer uma licença Visio Plano 1 ou Visio Plano 2, que é comprada separadamente do Microsoft 365. Para obter mais informações, entre em contato com seu Microsoft 365 administrador. Se o administrador tiver ligado a "compra de autoatendamento", você poderá comprar uma licença para Visio si mesmo. Para obter mais detalhes, consulte Perguntas frequentes sobre compra de autoatendores.

Um diagrama de componente de UML de exemplo.

Primeiro, você abre o modelo componente de UML e escolhe uma das quatro opções. Em seguida, o estêncil componente de UML é exibido, juntamente com formas que estão em conformidade com o padrão UML 2.5.

Observação: O estêncil componente uml só estará disponível se você for um Visio Plano 2 assinante. Se você tem uma assinatura, verifique se sua versão do Visio é a mais recente.

Iniciar um diagrama de sequência

  1. Abra Visio para a Web

  2. Próximo ao canto superior direito da página, selecione Mais modelos.

  3. Na Galeria, role para baixo até a linha Componente da UML, sobre o meio caminho para baixo na página.

    O primeiro item na linha representa um modelo em branco mais o estêncil de parceiro. Os outros itens na linha são diagramas de exemplo que já têm algumas formas desenhadas para ajudá-lo a começar rapidamente.

  4. Clique em qualquer item para ver uma visualização maior.

  5. Quando você encontrar o diagrama que deseja usar, clique no botão Criar.

    O novo diagrama, com o estêncil relacionado, é aberto no navegador.

Formas de componente

Quando usar

Use formas de componente para cada unidade funcional em seu sistema ou aplicativo.

Forma de componente "Store"

Mostrar ou ocultar estereotipo

Clique com o botão direito do mouse na forma para mostrar ou ocultar o rótulo de estereótipo.

Menu clicar com o botão direito do mouse, mostrar o comando Estereótipo, <<componente>> rótulo de texto

Subsistemas

Você pode usar a forma do componente como uma forma de subsistema que contém outros componentes. Basta ressilá-lo para ser maior e soltar outros componentes em cima dele. Quando você vir o destaque verde, deixe ir. A partir desse ponto, a forma maior atuará como um contêiner, e a forma menor se move com ele.

Dica: Se um componente desaparecer depois de arrastá-lo sobre outro componente, traga-o para a frente pressionando CTRL+SHIFT+F.

Store subsystem shape with Order component dragd on it

Formas de interface

Quando usar

  1. Use a forma Interface Fornecida quando quiser especificar a realização de uma classe/interface.

  2. Use a Interface Necessária quando quiser especificar uma dependência em uma classe/interface.

Duas interfaces conectadas, 1: Forma de interface fornecida terminando com círculo, 2: Forma de interface necessária terminando com soquete

Etapa 1

Arraste uma forma de Interface Fornecida para a página e aborde o quadrado da porta com um ponto de conexão. Você sabe que ele está conectado quando você vê o destaque verde ao redor do ponto de conexão.

Forma de interface fornecida colada à forma Componente

Etapa 2

Arraste uma forma de Interface Necessária para a página e aborde o quadrado da porta com um ponto de conexão também. Você sabe que ele está conectado quando você vê o destaque verde ao redor do ponto de conexão.

Forma de interface necessária colada à forma Componente

Etapa 3

Para conectar uma interface Fornecida e Necessária, primeiro selecione a forma interface necessária. Em seguida, procure a alça amarela.

Alça amarela na forma interface necessária

Etapa 4

Arraste a alça amarela para se conectar à Interface Fornecida.

Forma de interface necessária conectada à Interface Fornecida

Dicas conectores

Corrigir conectores

Se um conector estiver fazendo muitas curvas, clique com o botão direito do mouse nele e clique em Conector Reto.

Mostrar multiplicidade

Se necessário, clique com o botão direito do mouse no conector e selecione Mostrar Multiplicidade. Quando você terminar, quatro caixas de texto aparecerão onde você pode adicionar detalhes. Se você não precisar de todas as caixas de texto, exclua as que não precisam.

Alterar o tipo de conector

Você pode alterar um tipo de conector. Por exemplo, você pode mudar de uma Associação para uma Associação Direcionada. Clique com o botão direito do mouse no conector e clique em Definir Tipo de Conector.

Fazer conexões dinâmicas em vez de conexões de ponto

Se você antecipar muito a movimentação de formas, considere fazer uma conexão dinâmica em vez de uma conexão de ponto.

Mover ou girar texto em conectores

O mais provável é que você precise girar ou mover o texto em suas linhas do conector. Veja como fazer isso:

  1. Clique em uma área vazia da página para desmarcar qualquer coisa que possa ser selecionada.

  2. Na guia Página Principal, no grupo Ferramentas, clique na ferramenta Bloco de Texto Botão Bloco de Texto

  3. Clique no conector que tem texto que você deseja girar ou mover.

  4. Arraste o bloco de texto para movê-lo ou gire-o usando a alça de rotação Alça de rotação

  5. Quando terminar, clique no botão Ferramenta de Ponteiro Botão Ponteiro

    Depois de alternar de volta para o botão Ferramenta de Ponteiro Botão Ponteiro , o texto mantém a mesma posição em relação à forma. Se você usar a Ferramenta de Ponteiro Botão Ponteiro arrastar o texto, a forma também será moveda. Para mover o texto independentemente da forma, volte para a Ferramenta de Bloqueio de Texto Botão Bloco de Texto .

Component diagram displaying the structure of software code as cohesive components

Texto Explicativo 1 Em um diagrama de componentes, os componentes são tipos genéricos em vez de instâncias. Para mostrar instâncias de componente, use um diagrama de implantação.

Texto Explicativo 2 Dependências indicam que um componente cliente depende de um componente de fornecedor de alguma forma.

  1. Em Visio 2010: Em Categorias de Modelo, clique em Softwaree clique em Diagrama de Modelo de UMLe clique em Criar.

  2. Na modo de exibição em árvore, clique com o botão direito do mouse no pacote ou subsistema no qual você deseja incluir o diagrama de componente e, em seguida, no menu Novo, clique em Diagrama de Componentes.

    Uma página em branco é exibida e o estêncil de Componente de UML se torna o estêncil mais alto. O espaço de trabalho exibe 'Componente' como uma marca d'água. Um ícone que representa o diagrama é adicionado ao exibição de árvore.

    Observação: Se o ponto de exibição de árvore não estiver visível, aponte para Exibir no menu UML e clique em Explorador de Modelos.

  3. Arraste uma forma Component para a página de desenho de cada componente que você deseja representar.

  4. Quando apropriado, arraste uma forma interface para a página de desenho e cole o ponto de extremidade sem o círculo a uma forma de componente.

    Adicionar uma interface a uma classe, componente ou outros elementos

    1. Em uma estrutura estática, componente ou diagrama de implantação, arraste a forma da Interface do lollipop para a página de desenho.

    2. Cole o ponto de extremidade sem o círculo a um ponto de conexão Imagem do ponto de conexão - X azul no componente classe ou outro elemento.

    3. Clique duas vezes na forma Interface para adicionar um nome, operações e outros valores de propriedade.

      Lista de dicas

      Você também pode representar uma interface com uma forma de Interface retangular que se parece com uma classe. Use essa forma quando quiser exibir uma lista das operações da interface.

      Para alterar o tipo de forma que é exibido para uma interface, clique com o botão direito do mouse na forma interface e clique em Mostrar como Interface de Classe ou Mostrar como Interface do Lollipop.

  5. Use formas de dependência para indicar as relações entre componentes ou entre um componente e a interface de outro componente.

    Indicar uma relação de dependência entre elementos UML

    1. Arraste uma forma de Dependência da Estrutura Estática de UML,Implantação de UMLou Estêncil de Componente de UML para a página de desenho e coloque-a perto dos elementos que você deseja relacionar.

    2. Cole o ponto de extremidade com uma ponta de seta a um ponto de conexão Imagem do ponto de conexão - X azul o elemento do outro elemento depende. Cole o ponto de extremidade sem uma ponta de seta a um ponto de conexão no elemento que depende do outro elemento.

    3. Clique duas vezes na dependência para adicionar um nome, um estereótipo e outras propriedades.

      Dica: Se você quiser indicar uma dependência rastrear, refinamento, uso ou associação, você pode usar as formas Trace,Refinamento,Usoou Associação do estêncil da Estrutura Estática de UML.

  6. Clique duas vezes em qualquer forma para abrir sua caixa de diálogo Propriedades de UML onde você pode adicionar um nome, atributos, operações e outras propriedades.

  7. Salve o diagrama.

Confira também

Diagramas UML no Visio

Criar um diagrama de comunicação UML

Criar um diagrama de implantação UML

Criar um diagrama de sequência UML

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

×