Criar um diagrama de modelo de fluxo de dados de Gane-Sarson

Você pode projetar modelos de fluxo de dados usando o modelo de diagrama de modelo Flow dados, que inclui formas para todos os símbolos usados na notação Gane-Sarson dados.

O modelo Flow modelo de dados usa uma estratégia de design de cima para baixo para criar diagramas de fluxo de dados. Você começa criando processos de nível superior. Em seguida, você decompõe cada processo em subprocessos para obter mais detalhes.

Observação: Para obter informações sobre o método Gane-Sarson, consulte "Análise de Sistemas Estruturados: Ferramentas e Técnicas", por C. Gane e T. Sarson (Nova York: IST, Inc., 1977). Consulte também "Design conceitual do banco de dados", por Carlo Batini, Stefano Ceri e Shamkant B. Navathe (Redwood City, Ca.: The Benjamin/Cummings Publishing Company, Inc., 1992).

"Data flow model diagram detailing certification process, including subprocesses and interfaces"

  1. Inicie o Visio.

  2. Em Visio 2016 e versões mais recentes: Clique em Modelos > Software e Banco de Dados > Dados Flow Diagrama de Modelo.

    Em Visio 2013: Clique em Categorias > Software e Banco de Dados > Dados Flow Diagrama de Modelo.

    Em Visio 2010: Em Categorias deModelo, clique em Software e Banco de Dados e clique em Dados Flow Diagrama de Modelo.

    Em Visio 2007: no menu Arquivo, aponte para Novo, aponte para Software e Bancode Dados e clique em Diagrama de Modelo Flow Dados.

  3. Crie a página de detalhes de nível superior do diagrama arrastando formas de Interface e Processo de Gane-Sarson para a página de desenho.

    Observação: Neste modelo, você deve usar uma estratégia de design de cima para baixo para o diagrama do modelo de fluxo de dados. Inicie o modelo no nível superior e faça uma sonda até níveis inferiores.

  4. Conexão interface,processoe formas de armazenamento de dados entre si usando conectores Flow dados.

  5. Adicione uma página de detalhes para cada processo. Suas páginas detalhadas podem incluir subprocessos que exigem páginas de detalhes adicionais.

  6. Continue adicionando páginas detalhadas para cada processo (incluindo formas de interface, processo e armazenamento de dados, conforme necessário, conectadas por fluxos de dados) até que você tenha descrito todo o sistema de modelo de fluxo de dados em detalhes suficientes.

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade da tradução?
O que afetou sua experiência?

Obrigado por seus comentários!

×