Criar um novo banco de dados

Este artigo aborda o processo básico de início Access e a criação de um banco de dados que será usado em computadores de área de trabalho, e não pela Web. Ele explica como criar um banco de dados de área de trabalho usando um modelo e como criar um banco de dados do zero, criando suas próprias tabelas, formulários, relatórios e outros objetos de banco de dados. Ele também explica algumas técnicas que você pode usar para obter dados existentes no novo banco de dados.

Neste artigo

Visão geral

Criar um banco de dados usando um modelo

Criar um banco de dados sem usar um modelo

Copiar dados de outra fonte para uma tabela do Access

Importar, acrescentar ou vincular a dados de outra fonte

Adicionar uma parte do aplicativo

Abrir um banco de dados existente do Access

Visão geral

Quando você inicia o Access pela primeira vez, ou se fechar um banco de dados sem fechar o Access, o modo de exibição Backstage do Microsoft Office será exibido.

O modo de exibição Backstage é um ponto de partida do qual você pode criar um novo banco de dados, abrir um banco de dados existente, exibir conteúdo em destaque de Office.com — qualquer que seja possível usar o Access para fazer com um arquivo de banco de dados ou fora de um banco de dados , em oposição a um banco de dados.

Criando um banco de dados

Quando você abre o Access, o modo de exibição Backstage exibe a nova guia. A nova guia oferece várias maneiras de criar um novo banco de dados:

  • Um banco de dados em branco    Se desejar, você pode começar do zero. Esta é uma boa opção se você tiver requisitos de design muito específicos ou se tiver dados existentes que precise acomodar ou incorporar.

  • Um modelo que é instalado com o Access    Considere o uso de um modelo se você estiver iniciando um novo projeto e quiser um início. O Access vem com vários modelos instalados por padrão.

  • Um modelo de Office.com    Além dos modelos que vêm com o Access, você pode encontrar muitos outros modelos em Office.com. Você nem mesmo precisa abrir um navegador, os modelos estão disponíveis na guia novo .

Adicionar a um banco de dados

Depois de trabalhar em um banco de dados, você pode adicionar campos, tabelas ou partes do aplicativo.

Partes do aplicativo são um recurso que permite que você use vários objetos de banco de dados relacionados, como se fossem um. Por exemplo, uma parte de aplicativo pode consistir em uma tabela e um formulário que se baseia na tabela. Você pode adicionar a tabela e o formulário ao mesmo tempo usando a parte do aplicativo.

Você também pode criar consultas, formulários, relatórios, macros-todos os objetos de banco de dados com os quais você está acostumado a trabalhar.

Criar um banco de dados usando um modelo

O Access vem com uma variedade de modelos que você pode usar como, seja ou como ponto de partida. Um modelo é um banco de dados pronto para ser usado que contém todas as tabelas, consultas, formulários, macros e relatórios necessários para realizar uma tarefa específica. Por exemplo, há modelos que você pode usar para controlar problemas, gerenciar contatos ou manter um registro de despesas. Alguns modelos contêm alguns exemplos de registros para ajudar a demonstrar o seu uso.

Se um desses modelos atender às suas necessidades, o uso é geralmente a maneira mais rápida de iniciar um banco de dados. No entanto, se você tiver dados em outro programa que deseja importar para o Access, pode decidir que é melhor criar um banco de dados sem usar um modelo. Os modelos têm uma estrutura de dados já definida e podem exigir muito trabalho para adaptar seus dados existentes à estrutura do modelo.

  1. Se você tiver um banco de dados aberto, na guia arquivo , clique em fechar. O modo de exibição Backstage exibe a nova guia.

  2. Vários conjuntos de modelos estão disponíveis na nova guia, alguns dos quais são criados no Access. Você pode baixar modelos adicionais em Office.com. Consulte a próxima seção deste artigo para obter detalhes.

  3. Selecione o modelo que você deseja usar.

  4. O Access sugere um nome de arquivo para o seu banco de dados na caixa nome do arquivo — você pode alterar o nome do arquivo, se desejar. Para salvar o banco de dados em uma pasta diferente da exibida abaixo da caixa nome do arquivo, clique em Imagem do botão , navegue até a pasta na qual você deseja salvá-lo e clique em OK. Opcionalmente, você pode criar e vincular seu banco de dados a um site do SharePoint.

  5. Clique em Criar.

    O Access cria um banco de dados do modelo que você escolheu e abre o banco de dados. Para muitos modelos, um formulário é exibido no qual você pode começar a inserir dados. Se o modelo contém dados de exemplo, você pode excluir cada registro clicando no seletor de registro (a caixa ou barra sombreada à esquerda do registro) e, em seguida, fazendo o seguinte:

    Na guia Página Inicial, no grupo Registros, clique em Excluir. Imagem do botão

  6. Para começar a inserir dados, clique na primeira célula vazia no formulário e comece a digitar. Use o Painel de Navegação para procurar outros formulários ou relatórios que você queira usar. Alguns modelos incluem um formulário de navegação que permite que você se movimente entre os diferentes objetos do banco de dados.

Para obter mais informações sobre como trabalhar com modelos, consulte o artigo usar um modelo para criar um banco de dados de área de trabalho do Access.

Início da Página

Criar um banco de dados sem usar um modelo

Se não estiver interessado em usar um modelo, você pode criar um banco de dados criando suas próprias tabelas, formulários, relatórios e outros objetos de banco de dados. Na maioria dos casos, isso envolve um ou ambos dos seguintes:

  • Inserir, colar ou importar dados para a tabela que é criada quando você cria um novo banco de dados e, em seguida, repetir o processo com novas tabelas que você cria usando o comando tabela na guia criar .

  • Importar dados de outras fontes e criar novas tabelas no processo.

Criar um banco de dados em branco

  1. Na guia arquivo , clique em novoe, em seguida, clique em banco de dados em branco.

  2. Digite um nome de arquivo na caixa nome do arquivo . Para alterar o local do arquivo do padrão, clique em procurar um local para colocar o seu banco de dados Imagem do botão (ao lado da caixa nome do arquivo ), navegue até o novo local e clique em OK.

  3. Clique em Criar.

    O Access cria o banco de dados com uma tabela vazia chamada tabela1 e, em seguida, abre tabela1 no modo folha de dados. O cursor é colocado na primeira célula vazia na coluna clique para adicionar .

  4. Comece a digitar para adicionar dados, ou você pode colar dados de outra fonte, conforme descrito na seção copiar dados de outra fonte para uma tabela do Access.

Inserir dados no modo folha de dados foi projetado para ser muito semelhante a trabalhar em uma planilha do Excel. A estrutura da tabela é criada durante a inserção de dados. Quando você adiciona uma nova coluna à folha de dados, um novo campo é definido na tabela. O Access define automaticamente o tipo de dados de cada campo, com base nos dados que você inserir.

Se você não quiser inserir dados em tabela1 no momento, clique em fechar Imagem do botão . Se tiver feito alterações na tabela, o Access solicitará que você salve as alterações. Clique em Sim para salvar as alterações, clique em não para descartá-las ou clique em Cancelar para deixar a tabela aberta.

Dica:  O Access procura um arquivo chamado Blank. accdb na pasta localizada em [unidade de instalação]: \Arquivos de Programas\Microsoft Office\Templates\1033\Access\. Se existir, Blank. accdb é o modelo para todos os novos bancos de dados em branco. Qualquer conteúdo que ele contém é herdado por todos os novos bancos de dados em branco. Essa é uma boa maneira de distribuir conteúdo padrão, como números de peças ou isenções e políticas da empresa.

Importante: Se você fechar tabela1 sem salvá-la ao menos uma vez, o Access excluirá a tabela inteira, mesmo que você tenha inserido dados nela.

Adicionar uma tabela

Você pode adicionar novas tabelas a um banco de dados existente usando os comandos do grupo tabelas na guia criar .

Imagem da Faixa de Opções do Access

Criar uma tabela, começando no modo folha de dados    No modo de exibição folha de dados, você pode inserir dados imediatamente e permitir que o Access Construa a estrutura de tabelas em segundo plano. Os nomes de campo são atribuídos numericamente (campo1, Campo2 e assim por diante), e o Access define automaticamente o tipo de dados de cada campo, com base nos dados inseridos.

  1. Na guia Criar, no grupo Tabelas, clique em Tabela. Imagem do botão

    O Access cria a tabela e seleciona a primeira célula vazia na coluna clique para adicionar .

  2. Na guia campos , no grupo Adicionar & excluir , clique no tipo de campo que você deseja adicionar. Se você não vir o tipo desejado, clique em mais campos Imagem do botão .

  3. O Access exibe uma lista de tipos de campos comumente usados. Clique no tipo de campo desejado e o Access adicionará o novo campo à folha de dados no ponto de inserção.

    Você pode mover o campo arrastando-o. Quando você arrasta um campo em uma folha de dados, uma barra de inserção vertical aparece onde o campo será colocado.

  4. Para adicionar dados, comece a digitar na primeira célula vazia ou cole dados de outra fonte, conforme descrito na seção copiar dados de outra fonte para uma tabela do Access.

  5. Para renomear uma coluna (campo), clique duas vezes no título da coluna e digite o novo nome.

    Você deve fornecer um nome significativo a cada campo para poder informar o que ele contém quando você vê-lo no painel lista de campos .

  6. Para mover uma coluna, clique em seu título para selecionar a coluna e, em seguida, arraste a coluna para o local desejado. Você também pode selecionar várias colunas contíguas e, em seguida, arrastá-las para um novo local ao mesmo tempo. Para selecionar várias colunas contíguas, clique no cabeçalho da coluna da primeira coluna e, mantendo pressionada a tecla SHIFT, clique no cabeçalho da coluna da última coluna.

Criar uma tabela, começando no modo Design    No modo Design, primeiro você cria a estrutura da tabela. Em seguida, alterne para o modo folha de dados para inserir dados ou inserir dados usando outro método, como colar ou importar.

  1. Na guia criar , no grupo tabelas , clique em design de tabela. Texto explicativo 4

  2. Para cada campo da tabela, digite um nome na coluna nome do campo e selecione um tipo de dados na lista tipo de dados .

  3. Se desejar, você pode digitar uma descrição para cada campo da coluna Descrição . A descrição será exibida na barra de status quando o cursor estiver localizado nesse campo no modo folha de dados. A descrição também é usada como o texto da barra de status para os controles em um formulário ou relatório que você cria arrastando o campo do painel lista de campos e para todos os controles criados para esse campo quando você usa o assistente de formulário ou o assistente de relatório.

  4. Depois de adicionar todos os campos, salve a tabela:

    • Na guia Arquivo, clique em Salvar.

  5. Você pode começar a digitar dados na tabela a qualquer momento, alternando para o modo folha de dados e clicando na primeira célula vazia. Você também pode colar dados de outra fonte, conforme descrito na seção copiar dados de outra fonte para uma tabela do Access.

Definir propriedades de campo no modo Design    Independentemente de como você criou sua tabela, é uma boa ideia examinar e definir propriedades de campo. Enquanto algumas propriedades estão disponíveis no modo folha de dados, algumas propriedades só podem ser definidas no modo Design. Para alternar para o modo Design, clique com o botão direito do mouse na tabela no painel de navegação e clique em modo Design. Para ver as propriedades de um campo, clique no campo na grade de design. As propriedades são exibidas abaixo da grade de design, em Propriedades do campo.

Para ver uma descrição de cada propriedade de campo, clique na propriedade e leia a descrição na caixa ao lado da lista de propriedades em Propriedades do campo. Você pode obter informações mais detalhadas clicando no botão ajuda.

A tabela a seguir descreve algumas das propriedades de campo que normalmente são ajustadas.

Propriedade

Descrição

Tamanho do Campo

Para campos de texto, essa propriedade define o número máximo de caracteres que podem ser armazenados no campo. O máximo é 255. Para campos número, essa propriedade define o tipo de número que será armazenado (inteiro longo, duplo e assim por diante). Para o armazenamento de dados mais eficiente, é recomendável que você atribua a quantidade mínima de espaço que você acha que vai precisar dos dados. Você pode ajustar o valor mais tarde, se as suas necessidades forem alteradas.

Formatar

Essa propriedade define como os dados são exibidos. Isso não afeta os dados reais conforme são armazenados no campo. Você pode selecionar um formato predefinido ou inserir um formato personalizado.

Máscara de entrada

Use essa propriedade para especificar um padrão para todos os dados que serão inseridos nesse campo. Isso ajuda a garantir que todos os dados sejam inseridos corretamente e que contenham o número necessário de caracteres. Para obter ajuda sobre como criar uma máscara de entrada, clique em Botão Construtor no lado direito da caixa de propriedade.

Valor Padrão

Use essa propriedade para especificar o valor padrão que será exibido nesse campo toda vez que um novo registro for adicionado. Por exemplo, se você tiver um campo data/hora no qual você sempre deseja registrar a data em que o registro foi adicionado, é possível inserir "data ()" (sem as aspas) como o valor padrão.

Obrigatório

Essa propriedade define se um valor é obrigatório neste campo. Se você definir essa propriedade como Sim, o Access não permitirá que você adicione um novo registro, a menos que um valor seja inserido para esse campo.

Início da Página

Copiar dados de outra fonte para uma tabela do Access

Se os seus dados estão armazenados em outro programa, como o Excel, você pode copiá-los e colá-los em uma tabela do Access. Em geral, isso funciona melhor se seus dados já estiverem separados em colunas, como se estivessem em uma planilha do Excel. Se seus dados estiverem em um programa de processamento de texto, é melhor separar as colunas dos dados usando guias ou converter os dados em uma tabela no programa de processamento de texto antes de copiar os dados. Se seus dados precisarem de edição ou manipulação (por exemplo, separando nomes completos em nomes e sobrenomes), convém fazer isso antes de copiar os dados, especialmente se você não estiver familiarizado com o Access.

Quando você cola dados em uma tabela vazia, o Access define o tipo de dados de cada campo de acordo com o tipo de dados que ele encontra. Por exemplo, se um campo colado não contém nada, mas os valores de data, o Access aplica o tipo de dados data/hora a esse campo. Se o campo colado contém apenas as palavras "Sim" e "não", o Access aplica o tipo de dados sim/não ao campo.

O Access nomeia os campos de acordo com o que encontrar na primeira linha de dados colados. Se a primeira linha de dados colados for semelhante em tipo às linhas que acompanham, o Access determinará que a primeira linha faz parte dos dados e atribuirá nomes genéricos de campos (F1, F2, etc.). Se a primeira linha de dados colados não for semelhante às linhas que acompanham, o Access determinará que a primeira linha consiste em nomes de campo. O Access nomeia os campos de forma adequada e não inclui a primeira linha nos dados.

Se o Access atribuir nomes de campos genéricos, você deverá renomear os campos assim que possível para evitar confusão. Use o seguinte procedimento:

  1. Pressione CTRL + S para salvar a tabela.

  2. No modo folha de dados, clique duas vezes em cada título de coluna e digite um nome de campo descritivo para cada coluna.

  3. Salve a tabela novamente.

Observação: Você também pode renomear os campos alternando para o modo Design e editando os nomes dos campos ali. Para alternar para o modo Design, clique com o botão direito do mouse na tabela no painel de navegação e clique em modo Design. Para voltar para o modo de exibição folha de dados, clique duas vezes na tabela no painel de navegação.

Início da Página

Importar, acrescentar ou vincular a dados de outra fonte

Você pode ter dados armazenados em outro programa e deseja importá-los para uma nova tabela ou acrescentá-los a uma tabela existente no Access. Ou você pode trabalhar com as pessoas que mantêm seus dados em outros programas e deseja trabalhar com ela no Access vinculando-a. De qualquer forma, o Access torna mais fácil trabalhar com dados de outras fontes. Você pode importar dados de uma planilha do Excel, de uma tabela em outro banco de dados do Access, de uma lista do SharePoint ou de uma variedade de outras fontes. O processo usado é levemente diferente, dependendo da fonte, mas o procedimento a seguir o ajudará a começar.

  1. No Access, na guia dados externos , no grupo importar & link , clique no comando do tipo de arquivo que você está importando.

    Grupo Importar e Vincular na guia Dados Externos

    Por exemplo, se você estiver importando dados de uma planilha do Excel, clique em Excel. Se você não vir o tipo de programa que precisa, clique em mais.

    Observação: Se não conseguir encontrar o tipo de formato correto no grupo importar & link , talvez seja necessário iniciar o programa no qual você originalmente criou os dados e usar esse programa para salvar os dados em um formato de arquivo comum (como um arquivo de texto delimitado ) antes de importar esses dados para o Access.

  2. Na caixa de diálogo obter dados externos , clique em procurar para localizar o arquivo de dados de origem ou digite o caminho completo do arquivo de dados de origem na caixa nome do arquivo .

  3. Clique na opção desejada (todos os programas permitem que você importe e alguns permitem que você acrescente ou vincule) em especificar como e onde você deseja armazenar os dados no banco de dados atual. Você pode criar uma nova tabela que use os dados importados ou (com alguns programas) você pode acrescentar os dados a uma tabela existente ou criar uma tabela vinculada que mantenha um link para os dados no programa de origem.

  4. Se um assistente for iniciado, siga as instruções nas próximas páginas do assistente. Na última página do assistente, clique em Concluir.

    Se você importar objetos ou vincular tabelas de um banco de dados do Access, a caixa de diálogo importar objetos ou vincular tabelas será exibida. Escolha os itens desejados e clique em OK.

    O processo exato depende se você opta por importar, acrescentar ou vincular dados.

  5. O Access pergunta se você deseja salvar os detalhes da operação de importação que acabou de concluir. Se você acha que vai executar essa mesma operação de importação novamente no futuro, clique em salvar etapas de importaçãoe insira os detalhes. Em seguida, você pode repetir facilmente a operação no futuro clicando em importações salvas Imagem do botão no grupo importar & link na guia dados externos . Se não quiser salvar os detalhes da operação, clique em fechar.

Se você optou por importar uma tabela, o Access importa os dados para uma nova tabela e, em seguida, exibe a tabela no grupo tabelas no painel de navegação. Se você optou por acrescentar dados a uma tabela existente, os dados serão adicionados a essa tabela. Se você optou por vincular aos dados, o Access cria uma tabela vinculada sob o grupo tabelas no painel de navegação.

Início da Página

Adicionar uma parte do aplicativo

Você pode usar uma parte do aplicativo para adicionar funcionalidades a um banco de dados existente. Uma parte do aplicativo pode ser tão simples quanto uma única tabela ou pode incluir vários objetos relacionados, como uma tabela e um formulário acoplado.

Por exemplo, a parte do aplicativo comentários consiste em uma tabela com um campo de identificação automática, um campo de data e um campo memorando. Você pode adicioná-lo a qualquer banco de dados e usá-lo como está ou com a personalização mínima.

  1. Abra o banco de dados ao qual você deseja adicionar uma parte do aplicativo.

  2. Clique na guia criar .

  3. No grupo modelos , clique em partes do aplicativo. Uma lista de peças disponíveis será aberta.

  4. Clique na parte do aplicativo que você deseja adicionar.

Início da Página

Abrir um banco de dados existente do Access

  1. Na guia Arquivo, clique em Abrir.

  2. Na caixa de diálogo abrir , navegue até o banco de dados que deseja abrir.

  3. Siga um destes procedimentos:

    • Clique duas vezes no banco de dados para abri-lo no modo padrão especificado na caixa de diálogo Opções do Access ou no modo definido por uma política administrativa.

    • Clique em abrir para abrir o banco de dados para acesso compartilhado em um ambiente multiusuário para que você e outros usuários possam ler e gravar no banco de dados.

    • Clique na seta ao lado do botão abrir e, em seguida, clique em abrir como somente leitura para abrir o banco de dados para acesso somente leitura para que você possa exibir mas não editá-lo. Outros usuários ainda podem ler e gravar no banco de dados.

    • Clique na seta ao lado do botão abrir e clique em abrir exclusivo para abrir o banco de dados usando o acesso exclusivo. Quando você tiver um banco de dados aberto com acesso exclusivo, qualquer pessoa que tentar abrir o banco de dados receberá uma mensagem "arquivo que está sendo usado".

    • Clique na seta ao lado do botão abrir e, em seguida, clique em abrir como somente leitura exclusivo para abrir o banco de dados para acesso somente leitura. Outros usuários ainda podem abrir o banco de dados, mas estão limitados ao modo somente leitura.

Observação: Você pode abrir diretamente um arquivo de dados em um formato de arquivo externo, como dBASE, Microsoft Exchange ou Excel. Você também pode abrir diretamente qualquer fonte de dados ODBC, como o Microsoft SQL Server. O Access cria automaticamente um novo banco de dados do Access na mesma pasta que o arquivo de dados e adiciona links a cada tabela do banco de dados externo.

Dicas

  • Para abrir um dos bancos de dados abertos mais recentemente, na guia arquivo , clique em recentese, em seguida, clique no nome do arquivo desse banco de dados. O Access abre o banco de dados usando as mesmas configurações de opção que tinha na última vez que você o abriu. Se a lista de arquivos usados recentemente não for exibida, na guia arquivo , clique em Opções. Na caixa de diálogo Opções do Access , clique em configurações do cliente. Em Exibir, digite o número de documentos a serem exibidos na lista de documentos recentes, até o máximo de 50.

    Você também pode mostrar bancos de dados recentes na barra de navegação do modo de exibição Backstage, para acesso de dois cliques: 1) guia arquivo , 2) o banco de dados recente que você deseja abrir. Próximo à parte inferior da guia recentes , marque a caixa de seleção acesso rápido a este número de bancos de dados recentes e ajuste o número de bancos de dados a serem exibidos.

  • Se você estiver abrindo um banco de dados clicando no comando abrir na guia arquivo , poderá exibir uma lista de atalhos para bancos de dados abertos anteriormente clicando em documentos recentes na caixa de diálogo abrir .

Início da Página

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×