Você pode usar o OLE (Linking and Inbedding) de objeto para incluir conteúdo de outros programas, como o Word ou o Excel.

O OLE é suportado por vários programas diferentes, e o OLE é usado para disponibilizar conteúdo criado em um programa em outro programa. Por exemplo, você pode inserir um documento do Office Word em uma planilha do Office Excel. Para ver quais tipos de conteúdo você pode inserir, clique em Objeto no grupo Texto na guia Inserir. Somente os programas instalados no computador e que suportam objetos OLE aparecem na caixa Tipo de objeto.

Se você copiar informações entre o Excel ou qualquer programa que suporte o OLE, como o Word, poderá copiar as informações como um objeto vinculado ou um objeto inserido. As principais diferenças entre objetos vinculados e objetos incorporados são onde os dados são armazenados e como o objeto é atualizado depois que você os coloca no arquivo de destino. Os objetos incorporados são armazenados na lista de trabalho em que estão inseridos e não são atualizados. Os objetos vinculados permanecem como arquivos separados e podem ser atualizados.

Objetos vinculados e incorporados em um documento

Objetos vinculados e inseridos em um documento do Office para Windows

1. Um objeto incorporado não tem conexão com o arquivo de origem.

2. Um objeto vinculado é vinculado ao arquivo de origem.

3. O arquivo de origem atualiza o objeto vinculado.

Quando usar objetos vinculados

Se você quiser que as informações em seu arquivo de destino sejam atualizadas quando os dados no arquivo de origem mudarem, use objetos vinculados.

Com um objeto vinculado, as informações originais permanecem armazenadas no arquivo de origem. O arquivo de destino exibe uma representação das informações vinculadas, mas armazena apenas o local dos dados originais (e o tamanho se o objeto for um objeto gráfico do Excel). O arquivo de origem deve permanecer disponível em seu computador ou rede para manter o link para os dados originais.

As informações vinculadas podem ser atualizadas automaticamente se você alterar os dados originais no arquivo de origem. Por exemplo, se você selecionar um parágrafo em um documento do Word e colar o parágrafo como um objeto vinculado em uma pasta de trabalho do Excel, as informações poderão ser atualizadas no Excel se você alterar as informações no documento do Word.

Quando usar objetos incorporados

Se você não quiser atualizar os dados copiados quando eles mudarem no arquivo de origem, use um objeto incorporado. A versão da origem é incorporada inteiramente à workbook. Se você copiar informações como um objeto incorporado, o arquivo de destino exigirá mais espaço em disco do que se você vincular as informações.

Quando um usuário abre o arquivo em outro computador, ele pode exibir o objeto incorporado sem ter acesso aos dados originais. Como um objeto incorporado não tem links para o arquivo de origem, o objeto não será atualizado se você alterar os dados originais. Para alterar um objeto incorporado, clique duas vezes no objeto para abri-lo e editá-lo no programa de origem. O programa de origem (ou outro programa capaz de editar o objeto) deve ser instalado em seu computador.

Alterando a maneira como um objeto OLE é exibido

Você pode exibir um objeto vinculado ou objeto inserido em uma workbook exatamente como ela aparece no programa de origem ou como um ícone. Se a agenda de trabalho for exibida online e você não pretende imprimir a guia de trabalho, você poderá exibir o objeto como um ícone. Isso minimiza a quantidade de espaço de exibição que o objeto ocupa. Os visualizadores que quiserem exibir as informações podem clicar duas vezes no ícone.

Inserir um objeto em uma planilha

  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo Texto, clique em Objeto Ícone de objeto na faixa de opções .
    Inserir Objeto

  3. Na caixa de diálogo Objeto, clique na guia Criar de Arquivo.

  4. Clique em Procurar e selecione o arquivo que você deseja inserir.

  5. Se quiser inserir um ícone na planilha em vez de mostrar o conteúdo do arquivo, marque a caixa de seleção Exibir como ícone. Se você não selecionar as caixas de seleção, o Excel mostrará a primeira página do arquivo. Em ambos os casos, o arquivo completo será aberto com um clique duplo. Clique em OK.

    Observação: Depois de adicionar o ícone ou arquivo, você poderá arrastá-lo e soltá-lo em qualquer lugar na planilha. Também é possível redimensionar o ícone ou arquivo usando as alças de redimensionamento. Para localizar as alças, clique no arquivo ou ícone uma vez.

Inserir um link em um arquivo

Você talvez queira apenas adicionar um link ao objeto em vez de inseri-lo totalmente. Você pode fazer isso se sua pasta de trabalho e o objeto que deseja adicionar estiverem armazenados em um site do SharePoint, uma unidade de rede compartilhada ou um local semelhante e se o local dos arquivos permanecerá o mesmo. Isso será prático se o objeto vinculado passar por alterações porque o link sempre abrirá o documento mais atualizado.

Observação: Se você mover o arquivo vinculado para outro local, o link não funcionará mais.

  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo Texto, clique em Objeto Ícone de objeto na faixa de opções .
    Inserir Objeto

  3. Clique na guia Criar de Arquivo.

  4. Clique em Procurar e selecione o arquivo que você deseja vincular.

  5. Marque a caixa de seleção Vincular ao arquivo e clique em OK.

Criar um novo objeto de dentro do Excel

Você pode criar um objeto inteiramente novo com base em outro programa sem sair da sua pasta de trabalho. Por exemplo, se você quiser adicionar uma explicação mais detalhada a seu gráfico ou tabela, poderá criar um documento inserido, como um arquivo Word ou PowerPoint, no Excel. Você pode definir o objeto a ser exibido à direita em uma planilha ou adicionar um ícone que abre o arquivo.

Esse objeto inserido é um documento do Word.
  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo Texto, clique em Objeto Ícone de objeto na faixa de opções .
    Inserir Objeto

  3. Na guia Criar Novo, selecione o tipo de objeto que você deseja inserir na lista exibida. Se quiser inserir um ícone na planilha em vez do próprio objeto, marque a caixa de seleção Exibir como ícone.

  4. Clique em OK. Dependendo do tipo de arquivo que estiver sendo inserido, será aberta uma nova janela de programa ou uma janela de edição aparece dentro do Excel.

  5. Crie um novo objeto que você deseja inserir.

    Quando terminar, se o Excel tiver aberto uma nova janela do programa no qual você criou o objeto, você poderá trabalhar diretamente nele.

    Você pode editar o documento do Word inserido diretamente no Excel.

    Quando você terminar seu trabalho na janela, poderá fazer outras tarefas sem salvar o objeto inserido. Quando você fechar a pasta de trabalho, seus novos objetos serão salvos automaticamente.

    Observação: Depois de adicionar o objeto, você poderá arrastá-lo e soltá-lo em qualquer lugar na planilha do Excel. Também é possível redimensionar o objeto usando as alças de redimensionamento. Para localizar as alças, clique no objeto uma vez.

Inserir um objeto em uma planilha

  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo Texto, clique em Objeto.

    A opção Objeto está na guia Inserir.
  3. Clique na guia Criar do Arquivo.

    A guia "Criar do Arquivo" na caixa de diálogo Objeto.
  4. Clique em Procurar e selecione o arquivo que você deseja inserir.

  5. Se quiser inserir um ícone na planilha em vez de mostrar o conteúdo do arquivo, marque a caixa de seleção Exibir como ícone. Se você não selecionar as caixas de seleção, o Excel mostrará a primeira página do arquivo. Em ambos os casos, o arquivo completo será aberto com um clique duplo. Clique em OK.

    Observação: Depois de adicionar o ícone ou arquivo, você poderá arrastá-lo e soltá-lo em qualquer lugar na planilha. Também é possível redimensionar o ícone ou arquivo usando as alças de redimensionamento. Para localizar as alças, clique no arquivo ou ícone uma vez.

Inserir um link em um arquivo

Você talvez queira apenas adicionar um link ao objeto em vez de inseri-lo totalmente. Você pode fazer isso se sua pasta de trabalho e o objeto que deseja adicionar estiverem armazenados em um site do SharePoint, uma unidade de rede compartilhada ou um local semelhante e se o local dos arquivos permanecerá o mesmo. Isso será prático se o objeto vinculado passar por alterações porque o link sempre abrirá o documento mais atualizado.

Observação: Se você mover o arquivo vinculado para outro local, o link não funcionará mais.

  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo Texto, clique em Objeto.

    A opção Objeto está na guia Inserir.
  3. Clique na guia Criar do Arquivo.

  4. Clique em Procurar e selecione o arquivo que você deseja vincular.

  5. Marque a caixa de seleção Vincular ao arquivo e clique em OK.

    Na guia "Criar do Arquivo", selecione "Vincular ao arquivo".

Criar um novo objeto de dentro do Excel

Você pode criar um objeto inteiramente novo com base em outro programa sem sair da sua pasta de trabalho. Por exemplo, se você quiser adicionar uma explicação mais detalhada a seu gráfico ou tabela, poderá criar um documento inserido, como um arquivo Word ou PowerPoint, no Excel. Você pode definir o objeto a ser exibido à direita em uma planilha ou adicionar um ícone que abre o arquivo.

Esse objeto inserido é um documento do Word.
  1. Clique dentro da célula da planilha onde você deseja inserir o objeto.

  2. Na guia Inserir, no grupo Texto, clique em Objeto.

    A opção Objeto está na guia Inserir.
  3. Na guia Criar Novo, selecione o tipo de objeto que você deseja inserir na lista exibida. Se quiser inserir um ícone na planilha em vez do próprio objeto, marque a caixa de seleção Exibir como ícone.

    A guia Criar Novo na caixa de diálogo Objeto.
  4. Clique em OK. Dependendo do tipo de arquivo que estiver sendo inserido, será aberta uma nova janela de programa ou uma janela de edição aparece dentro do Excel.

  5. Crie um novo objeto que você deseja inserir.

    Quando terminar, se o Excel tiver aberto uma nova janela do programa no qual você criou o objeto, você poderá trabalhar diretamente nele.

    Você pode editar o documento do Word inserido diretamente no Excel.

    Quando você terminar seu trabalho na janela, poderá fazer outras tarefas sem salvar o objeto inserido. Quando você fechar a pasta de trabalho, seus novos objetos serão salvos automaticamente.

    Observação: Depois de adicionar o objeto, você poderá arrastá-lo e soltá-lo em qualquer lugar na planilha do Excel. Também é possível redimensionar o objeto usando as alças de redimensionamento. Para localizar as alças, clique no objeto uma vez.

Alterar a maneira como um objeto OLE é exibido

  1. Clique com o botão direito do mouse no ícone ou objeto, aponte para o tipo de objetoObject (por exemplo, Objeto Document) e clique em Converter.

  2. Siga um destes procedimentos:

    • Para exibir o conteúdo, desempure a caixa de seleção Exibir como ícone.

    • Para exibir um ícone, marque a caixa de seleção Exibir como ícone. Opcionalmente, você pode alterar a imagem ou o rótulo do ícone padrão. Para fazer isso, clique em Alterar Íconee clique no ícone que você deseja na lista Ícone ou digite um rótulo na caixa Legenda.

Editar conteúdo de um programa OLE

Enquanto estiver no Excel, você pode alterar o conteúdo vinculado ou incorporado de outro programa.

Editar um objeto vinculado no programa de origem

  1. Na guia Dados, no grupo Conexões, clique em Editar Vínculos.

    Imagem da Faixa de Opções do Excel

    Observação: O comando Editar Vínculos não estará disponível se o arquivo não contiver informações vinculadas.

  2. Na lista Arquivo de origem, clique na origem do objeto vinculado e clique em Abrir Fonte.

  3. Faça as alterações que você deseja para o objeto vinculado.

  4. Saia da programa de origem para retornar ao arquivo de destino.

Editar um objeto incorporado no programa de origem

  1. Clique duas vezes no objeto inserido para abri-lo.

  2. Faça as alterações que você deseja para o objeto.

  3. Se você estiver editando o objeto no local dentro do programa aberto, clique em qualquer lugar fora do objeto para retornar ao arquivo de destino.

    Se você editar o objeto incorporado no programa de origem em uma janela separada, saia do programa de origem para retornar ao arquivo de destino.

Observação: Clicar duas vezes em determinados objetos incorporados, como vídeos e clipes de som, reproduz o objeto em vez de abrir um programa. Para editar um desses objetos incorporados, clique com o botão direito do mouse no ícone ou objeto, aponte para o tipo de objetoObject (por exemplo, Objeto Media Clip) e clique em Editar.

Editar um objeto incorporado em um programa diferente do programa de origem

  1. Selecione a objeto inserido que você deseja editar.

  2. Clique com o botão direito do mouse no ícone ou objeto, aponte para o tipo de objetoObject (por exemplo, Objeto Document) e clique em Converter.

  3. Siga um destes procedimentos:

    • Para converter o objeto incorporado no tipo especificado na lista, clique em Converter em.

    • Para abrir o objeto incorporado como o tipo que você especificar na lista sem alterar o tipo de objeto incorporado, clique em Ativar.

Selecione um objeto OLE usando o teclado

  1. Pressione CTRL+G para exibir a caixa de diálogo Ir para.

  2. Clique em Especial,selecione Objetose clique em OK.

  3. Pressione TAB até que o objeto que você deseja seja selecionado.

  4. Pressione SHIFT+F10.

  5. Aponte para Objeto ouObjeto Charte clique em Editar.

Problema: quando eu clicar duas vezes em um objeto vinculado ou incorporado, uma mensagem "não pode editar" é exibida

Essa mensagem é exibida quando o arquivo de origem ou programa de origem não pode ser aberto.

Certifique-se de que o programa de origem está disponível     Se o programa de origem não estiver instalado no computador, converta o objeto no formato de arquivo de um programa que você instalou.

Certifique-se de que a memória seja adequada     Certifique-se de que você tenha memória suficiente para executar o programa de origem. Feche outros programas para liberar memória, se necessário.

Fechar todas as caixas de diálogo     Se o programa de origem estiver em execução, certifique-se de que ele não tenha nenhuma caixa de diálogo aberta. Alternar para o programa de origem e fechar todas as caixas de diálogo abertas.

Fechar o arquivo de origem     Se o arquivo de origem for um objeto vinculado, certifique-se de que outro usuário não o tenha aberto.

Verifique se o nome do arquivo de origem não foi alterado     Se o arquivo de origem que você deseja editar for um objeto vinculado, certifique-se de que ele tenha o mesmo nome que tinha quando você criou o link e se ele não foi movido. Selecione o objeto vinculado e clique no comando Editar Links no grupo Conexões na guia Dados para ver o nome do arquivo de origem. Se o arquivo de origem tiver sido renomeado ou movido, use o botão Alterar Fonte na caixa de diálogo Editar Links para localizar o arquivo de origem e reconectar o link.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community ou obter suporte na Comunidade de respostas.

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar Microsoft Office Insider

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?

Obrigado pelos seus comentários!

×