Inserir um seletor de data

Aplica-se a
InfoPath 2010 InfoPath 2013

Importante

O suporte para o Microsoft InfoPath 2013 terminou em 14 de julho de 2026. Recomendamos migrar formulários e fluxos de trabalho existentes do InfoPath para soluções compatíveis do Microsoft 365. Saiba mais sobre a desativação do InfoPath.

Um seletor de data é um controle que permite que os usuários insiram datas rapidamente em um formulário do Microsoft Office InfoPath clicando em um pequeno calendário pop-up. Por exemplo, você pode usar um seletor de data para coletar datas de nascimento de pessoas em um formulário de seguro. Você também pode usar um seletor de data para exibir datas predefinidas, como a data atual.

Neste artigo

Quando usar um seletor de data

Use um seletor de data quando quiser:

  • Permita que os usuários insiram datas de sua escolha em um formulário, como datas de início e término para um projeto específico.
  • Use as funções hoje e agora para mostrar a data e a hora de hoje em um formulário.
  • Exibe datas de uma fonte de dados externa, como datas de cobrança e remessa de um banco de dados de pedidos de clientes.

Na ilustração a seguir, um seletor de data é usado em um modelo de formulário de solicitação de viagem para coletar a data de partida de um voo.

Campo de data de partida com um botão seletor de data

Você pode personalizar o seletor de data para atender às suas necessidades clicando duas vezes no controle no modelo de formulário e alterando suas propriedades. Por exemplo, você pode especificar uma data padrão ou alterar a forma como a data é exibida no formulário.

Início da Página

A experiência do usuário

Os seletores de data parecem caixas de texto, exceto que um pequeno ícone de calendário aparece no lado direito da caixa. Para abrir o calendário pop-up, os usuários clicam no ícone do calendário. Quando o calendário aparece, os usuários podem clicar na data que desejam no calendário ou usar os botões de seta para a direita e para a esquerda para percorrer os meses. Se os usuários quiserem inserir a data atual, eles podem clicar no botão Hoje na parte inferior do calendário.

Abra o calendário do seletor de data com navegação mensal e o botão Hoje

Início da Página

Considerações de compatibilidade

Ao criar um modelo de formulário no InfoPath, você pode escolher um modo de compatibilidade específico para criar um modelo de formulário compatível com o navegador. Quando um modelo de formulário compatível com o navegador é publicado em um servidor que executa o InfoPath Forms Services e, em seguida, habilitado para navegador, os formulários baseados no modelo de formulário podem ser exibidos em um navegador da Web. Quando você cria um modelo de formulário compatível com o navegador, alguns controles ficam indisponíveis no painel de tarefas Controles porque não podem ser exibidos em um navegador da Web.

Embora os seletores de data estejam disponíveis quando você cria um modelo de formulário compatível com o navegador, lembre-se das seguintes limitações:

  • Os seletores de data têm suporte total apenas em navegadores Windows Internet Explorer. Em outros navegadores da Web, o seletor de data aparece como uma caixa de texto, embora haja suporte para opções de formatação de data na caixa de texto.
  • Texto de espaço reservado é o texto que aparece dentro de um controle em um modelo de formulário. Um exemplo de texto de espaço reservado é "Clique aqui e digite". Embora você possa deixar as configurações de texto do espaço reservado para modelos de formulário compatíveis com o navegador, esse texto não aparece nos navegadores da Web.

Início da Página

Inserir um selecionador de data

O procedimento para inserir um seletor de data difere um pouco, dependendo se você está criando um novo modelo de formulário em branco ou baseando o design do modelo de formulário em um banco de dados ou em outra fonte de dados externa.

A ilustração a seguir mostra a aparência de um seletor de data quando ele é selecionado no modo de design.

Seletor de data selecionado no modo de design do InfoPath

Os controles podem ser associados ou não associados. Quando um controle é associado, ele é conectado a um campo ou grupo na fonte de dados para que os dados inseridos no controle sejam salvos no arquivo de formulário subjacente (.xml). Quando um controle não é associado, ele não é conectado a um campo ou grupo, e os dados inseridos no controle não serão salvos. Quando você seleciona ou move o ponteiro sobre um controle, o texto e um ícone de associação aparecem no canto superior direito do controle. O texto indica o grupo ou campo ao qual o controle está associado na fonte de dados. O ícone indica se o controle está vinculado corretamente a esse grupo ou campo. O ícone é exibido em verde quando a vinculação está correta. Se houver algo errado com a associação, você verá um ícone azul ou vermelho em vez disso.

A fonte de dados do modelo de formulário consiste em campos e grupos que aparecem em um modo de exibição hierárquico no painel de tarefas Fonte de Dados. Os controles do seletor de data estão sempre associados a campos. No exemplo a seguir, o seletor de data de partida no modelo de formulário está vinculado ao campo datadepartida no painel de tarefas Fonte de dados .

Seletor de data de partida vinculado ao campo da fonte de dados dataData de Partida

Inserir um seletor de data em um novo modelo de formulário em branco

Quando você cria um modelo de formulário novo e em branco, a caixa de seleção Criar fonte de dados automaticamente, no painel de tarefas Controles, é selecionada por padrão. Isso permite que o InfoPath crie campos e grupos automaticamente na fonte de dados conforme você adiciona controles ao modelo de formulário. Esses campos e grupos são representados por ícones de pasta e arquivo no painel de tarefas Fonte de Dados.

  1. No modelo de formulário, coloque o cursor onde você deseja inserir o controle.

  2. Se o painel de tarefas Controles não estiver visível, clique em Mais Controles no menu Inserir, ou pressione ALT+I, C.

  3. Em Inserir controles, clique em Seletor de Data.

  4. Para adicionar um rótulo ao controle, digite o texto acima ou à esquerda do controle, seguido de dois-pontos (:).

  5. Para especificar a forma como a data é exibida no formulário, clique duas vezes no seletor de data inserido no modelo de formulário.

  6. Clique na guia Dados e em Formato.

  7. Na lista Exibir a data como esta , na caixa de diálogo Formato de data , clique no formato de exibição desejado.

    Observação

    Você só poderá alterar o formato de exibição da data se o tipo de dados for texto, data ou data e hora.

Inserir um seletor de data em um modelo de formulário com base em uma fonte de dados existente

Se você basear o design do seu modelo de formulário em um serviço da Web, banco de dados ou arquivo em linguagem XML existente, o InfoPath deriva os campos e grupos no painel de tarefas Fonte de Dados utilizando essa fonte de dados existente. Nesse cenário, você pode adicionar um seletor de data arrastando um campo do seletor de data do painel de tarefas Fonte de Dados para o modelo de formulário ou inserindo o seletor de data usando o painel de tarefas Controles , conforme descrito no procedimento a seguir:

  1. No modelo de formulário, coloque o cursor onde você deseja inserir o controle.

  2. Se o painel de tarefas Controles não estiver visível, clique em Mais Controles no menu Inserir, ou pressione ALT+I, C.

  3. Em Inserir controles, clique em Seletor de Data.

  4. Na caixa de diálogo Associação do Seletor de Datas, selecione o campo no qual você deseja armazenar os dados do seletor de datas e clique em OK.

  5. O InfoPath usa o nome do campo ou do grupo como o rótulo do controle. Se necessário, altere o texto do rótulo.

  6. Para especificar a forma como a data é exibida no formulário, clique duas vezes no seletor de data inserido no modelo de formulário.

  7. Na guia Dados , clique em Formato.

  8. Na caixa de listagem Exibir a data como esta , na caixa de diálogo Formato de data , clique no formato de exibição desejado.

    Observação

    Você só poderá alterar o formato de exibição da data se o tipo de dados for texto, data ou data e hora.

Dica

Você também pode usar o painel de tarefas Fonte de Dados para inserir os controles. No painel de tarefas Fonte de Dados , clique com o botão direito do mouse no campo ao qual você deseja associar o seletor de data e clique em Seletor de Data no menu de atalho.

Início da Página

Exibir a data atual em um seletor de data

Para inserir automaticamente a data atual em um formulário quando os usuários o abrirem, você pode usar a função hoje com um controle seletor de data.

  1. Insira um seletor de data no modelo de formulário.

  2. Clique duas vezes no seletor de data que você inseriu no modelo de formulário.

  3. Clique na guia Dados.

  4. Em Valor Padrão, clique em Inserir Fórmula .

  5. Na caixa de diálogo Inserir Fórmula , clique em Inserir Função.

  6. Na lista Categorias na caixa de diálogo Inserir Função , clique em Data e Hora.

  7. Na lista Funções , clique hoje e em OK duas vezes para retornar à caixa de diálogo Propriedades do Seletor de Data .
    Observe que today() aparece na caixa Valor .

  8. Em Valor Padrão, desmarque a caixa de marca Atualizar este valor quando o resultado da fórmula for recalculado.

    Observação

    Se você desmarcar essa caixa de marcação, a data não será atualizada automaticamente toda vez que um usuário abrir um formulário baseado nesse modelo de formulário. Isso é ideal em situações em que você deseja que os usuários vejam a data em que o formulário foi criado. Você pode deixar a caixa de marca marcada em situações em que você tem um campo Última atualização em ou Última abertura em, onde deseja que a data seja alterada sempre que o formulário for aberto.

  9. Clique em OK para retornar ao modelo de formulário.

  10. Para testar as alterações, clique Visualizar na barra de ferramentas Padrão ou pressione CTRL+SHIFT+B.

  11. Verifique se a data que aparece no seletor de data tem a aparência desejada. Caso contrário, você pode alterar a forma como a data ou a hora é exibida clicando no botão Formatar na caixa de diálogo Propriedades do Seletor de Data .

Início da Página

Exibir a data e a hora atuais em um seletor de data

Para inserir automaticamente a data e a hora atuais em um formulário quando os usuários o abrirem, você pode usar a função agora com um controle seletor de data.

  1. Insira um seletor de data no modelo de formulário.

  2. Clique duas vezes no seletor de data que você inseriu no modelo de formulário.

  3. Clique na guia Dados.

  4. Na caixa Tipo de dados, clique em Data e Hora (dateTime).

  5. Clique em Formatar.

  6. Na caixa de diálogo Formato de Data e Hora, na lista Exibir a hora como esta, clique na opção desejada e clique em OK.

  7. Na caixa de diálogo Propriedades do Seletor de Data , em Valor Padrão, clique em Inserir Fórmula .

  8. Na caixa de diálogo Inserir Fórmula , clique em Inserir Função.

  9. Na lista Categorias na caixa de diálogo Inserir Função , clique em Data e Hora.

  10. Na lista Funções , clique agora e em OK duas vezes para retornar à caixa de diálogo Propriedades do Seletor de Data .
    Observe que now() aparece na caixa Valor .

  11. Em Valor Padrão, desmarque a caixa de marca Atualizar este valor quando o resultado da fórmula for recalculado.

    Observação

    Se você desmarcar essa caixa de marcação, a data não será atualizada automaticamente toda vez que um usuário abrir um formulário baseado nesse modelo de formulário. Isso é ideal em situações em que você deseja que os usuários vejam a data em que o formulário foi criado. Você pode deixar a caixa de marca marcada em situações em que você tem um campo Última atualização em ou Última abertura em, onde deseja que a data seja alterada sempre que o formulário for aberto.

  12. Clique em OK para retornar ao modelo de formulário.

  13. Para testar as alterações, clique Visualizar na barra de ferramentas Padrão ou pressione CTRL+SHIFT+B.

  14. Verifique se a data que aparece no seletor de data tem a aparência desejada. Caso contrário, você pode alterar a forma como a data ou a hora é exibida clicando no botão Formatar na caixa de diálogo Propriedades do Seletor de Data .

Início da Página

Dicas de layout

Use as dicas a seguir para refinar a aparência, o tamanho e outros aspectos de um selecionador de data:

  • Para alterar o tamanho de vários seletores de data de uma só vez, selecione os seletores de data cujo tamanho você deseja alterar, no menu Formato , clique em Propriedades e, na guia Tamanho , faça os ajustes necessários.
  • Para alterar a borda ou a cor de um seletor de data, selecione o seletor de data, no menu Formatar , clique em Bordas e Sombreamento e faça os ajustes necessários.
  • Para personalizar o texto que aparece em um seletor de data, use as caixas Fonte e Tamanho da Fonte na barra de ferramentas Formatação . Para alterar a fonte e o tamanho da fonte de todos os seletores de data no modelo de formulário de uma só vez, clique com o botão direito do mouse no seletor de data que contém a formatação desejada e, em seguida, clique em Aplicar Fonte a Todos os Controles do Seletor de Data no menu de atalho.
  • Para ver como seu seletor de data ficará com o texto real, clique em Dados de Exemplo no menu Exibir . Isso ajuda você a ter uma noção de como será a aparência do formulário quando os usuários o preencherem.
  • Às vezes, o texto dentro de um seletor de data e o rótulo à esquerda do seletor de data podem parecer estar ligeiramente desalinhados. Para realinhá-los rapidamente, clique duas vezes no seletor de data, clique em Alinhar na guia Tamanho e clique em Aplicar. Se o rótulo e o seletor de data estiverem em células diferentes em uma tabela de layout, clique com o botão direito do mouse na célula que contém o rótulo, clique em Propriedades da Tabela no menu de atalho e clique em Centralizar em Alinhamento vertical na guia Célula .
  • Para alterar a forma como a data é exibida, clique duas vezes no seletor de data, clique na guia Dados e clique no botão Formatar . Escolha um formato de exibição na caixa de diálogo Formato de Data .

Início da Página