Modificar, editar ou alterar um relatório

Este tópico descreve as técnicas que você pode usar para modificar um relatório do Access existente. Access fornece duas exibições que você pode usar para fazer alterações no relatório: exibição de layout e exibição de design. Sua escolha de qual exibição usar depende de qual tarefa específica você está tentando realizar. Você pode acabar usando ambos os pontos de exibição para fazer suas alterações.

O que você deseja fazer?

Compreender o exibição layout

O layout é a exibição mais intuitiva a ser usada para modificação de relatório e pode ser usada para quase todas as alterações que você deseja fazer em um relatório em Access. No modo layout, o relatório está realmente em execução, para que você possa ver seus dados da mesma forma que serão exibidos quando impressos. No entanto, você também pode fazer alterações no design do relatório neste exibição. Como você pode ver os dados durante a modificação do relatório, é uma exibição muito útil para definir larguras de coluna, adicionar níveis de agrupação ou executar quase qualquer outra tarefa que afete a aparência e a capacidade de leitura do relatório. A ilustração a seguir mostra um relatório do Livro de Telefonia do Cliente no layout.

Relatório no modo Layout

O relatório que você vê no modo layout não é exatamente igual ao relatório impresso. Por exemplo, não há quebras de página no layout. Além disso, se você tiver usado a Configuração de Página para formatar seu relatório com colunas, as colunas não serão exibidas no layout. No entanto, o layout oferece uma aproximação muito próxima do relatório impresso. Se você quiser ver como o relatório ficará quando impresso, use Print Preview.

Determinadas tarefas não podem ser executadas no layout e exigem que você alternar para o design. Em determinadas situações, o Access exibirá uma mensagem avisando que você deve alternar para Design para fazer uma alteração específica.

Entender o visual design

A exibição de design oferece uma exibição mais detalhada da estrutura do relatório. Você pode ver o header e as faixas de rodapé do relatório, da página e dos grupos. O relatório não está realmente em execução no modo design, portanto, você não pode ver os dados subjacentes durante o trabalho; no entanto, há certas tarefas que você pode executar com mais facilidade no design do que no layout. Você pode:

  • Adicione uma variedade mais ampla de controles ao seu relatório, como rótulos, imagens, linhas e retângulos.

  • Editar fontes de controle de caixa de texto nas caixas de texto, sem usar a folha de propriedades.

  • Alterar determinadas propriedades que não estão disponíveis no layout.

A ilustração a seguir mostra um relatório do Livro de Telefonia do Cliente no design.

Relatório no modo Design

Alternar entre modos de exibição

O Access fornece uma variedade de métodos para alternar entre exibições. Se o relatório já estiver aberto, você poderá alternar para outro ponto de exibição fazendo um dos seguintes:

  • Clique com o botão direito do mouse no relatório no Painel de Navegação e clique no modo de exibição desejado no menu de atalho.

  • Clique com o botão direito do mouse na guia de documento ou na barra de título do relatório e clique no exibição desejado no menu de atalho.

  • Na guia Início, no grupo Exibir, clique no botão Exibir para alternar entre os exibições disponíveis. Como alternativa, você pode clicar na seta em Exibire selecionar um dos exibições disponíveis no menu.

  • Clique com o botão direito do mouse em uma área em branco do próprio relatório e clique na exibição que você deseja. Se o relatório estiver aberto no design, clique com o botão direito do mouse fora da grade de design.

  • Clique em um dos ícones de exibição pequeno na barra de status do Access.

Se o relatório não estiver aberto, clique duas vezes no relatório no Painel de Navegação para abri-lo no modo Relatório. Para abrir o relatório em outro modo de exibição, clique com o botão direito do mouse no relatório no Painel de Navegação e clique no modo de exibição desejado no menu de atalho.

Observação: Se você estiver modificando um relatório no qual tenha usado a Instalação de Página para criar várias colunas (por exemplo, um relatório de rótulo de email), você só poderá exibir as colunas na Visualização de Impressão. Quando você exibe o relatório no exibição Relatório ou layout, o Access exibe os dados em uma única coluna.

Modificar seu relatório no layout

Esta seção descreve algumas das modificações comuns de relatório que você pode executar no layout.

Alterar a largura da coluna ou do campo no layout

  1. Clique em um item na coluna que você deseja ajustar.

    Uma borda é desenhada ao redor do item para indicar que o campo está selecionado.

  2. Arraste a borda direita ou esquerda da borda até que a coluna seja a largura que você deseja.

Alterar a altura da linha ou do campo no layout

  1. Clique em um item na linha que você deseja ajustar.

    Uma borda é desenhada ao redor do item para indicar que o campo está selecionado.

  2. Arraste a borda superior ou inferior da borda até que a linha seja a altura que você deseja.

Adicionar um campo no exibição Layout

  • Na guia Design, no grupo Ferramentas, clique em Adicionar Campos Existentes.

    A lista de campos disponíveis é exibida. Se houver campos disponíveis em outras tabelas, eles serão exibidos em Campos disponíveis em outras tabelas:.

  • Arraste um campo da Lista de Campos para o relatório. Ao mover o campo, uma área realçada indicará onde o campo será colocado quando você liberar o botão do mouse.

    Observação: Para adicionar vários campos de uma só vez, segure a tecla CTRL e clique em cada campo na Lista de Campos que você deseja. Em seguida, solte a tecla CTRL e arraste os campos para o relatório. Os campos serão colocados adjacentes uns aos outros.

Início da página

Compreender layouts de controle

Layouts de controle são guias que alinham seus controles horizontal e verticalmente para dar ao relatório uma aparência uniforme. Você pode pensar em um layout de controle como uma tabela, onde cada célula da tabela contém um controle. Os procedimentos a seguir mostram como adicionar, remover ou reorganizar controles em layouts de controle.

Os layouts de controle vêm em duas variedades: tabular e empilhado.

  • Em layouts de controle tabular, os controles são organizados em linhas e colunas como uma planilha, com rótulos na parte superior. Layouts de controle tabular sempre abrangem duas seções de um relatório; qualquer seção em que os controles estão, os rótulos estão na seção acima deles. A ilustração a seguir mostra um layout de controle tabular básico.

    Layout básico de controle tabular

  • Em layouts empilhados, os controles são organizados verticalmente, como você pode ver em um formulário de papel, com um rótulo à esquerda de cada controle. Layouts empilhados estão sempre contidos em uma única seção de relatório. A ilustração a seguir mostra um layout de controle empilhado básico.

    Layout de controle empilhado básico

Você pode ter vários layouts de controle de qualquer tipo em um relatório. Por exemplo, você pode ter um layout tabular para criar uma linha de dados para cada registro e, em seguida, um ou mais layouts empilhados abaixo, contendo mais dados do mesmo registro.

Criar um novo layout de controle

O Access cria automaticamente layouts de controle colunar nas seguintes circunstâncias:

  • Você cria um novo relatório clicando em Relatório Imagem do botão no grupo Relatórios na guia Criar.

  • Você cria um novo relatório clicando em Relatório em Branco Texto explicativo 4 no grupo Relatórios na guia Criar e arrastando um campo do painel Lista de Campos para o relatório.

Em um relatório existente, você pode criar um novo layout de controle fazendo o seguinte:

  1. Selecione um controle que você deseja adicionar ao layout.

  2. Se você quiser adicionar outros controles ao mesmo layout, segure a tecla SHIFT e selecione também esses controles.

  3. Siga um destes procedimentos:

    • Na guia Organizar, no grupo Tabela, clique em Tabular ou Empilhado.

    • Clique com o botão direito do mouse no controle ou controle selecionado, aponte para Layoute clique em Tabular ou Empilhado .

O Access cria o layout de controle e adiciona os controles selecionados a ele.

Alternar um layout de controle de tabular para empilhado ou empilhado para tabular

Para alternar um layout inteiro de um tipo de layout para o outro:

  • Selecione o layout de controle clicando no seletor de layout laranja no canto superior esquerdo do layout.

    Todas as células no layout estão selecionadas.

  • Siga um destes procedimentos:

    • Na guia Organizar, no grupo Tabela, clique no tipo de layout que você deseja (Tabular ou Empilhado).

    • Clique com o botão direito do mouse no layout do controle, aponte para Layoute clique no tipo de layout que você deseja.

O Access reorganiza os controles para o tipo de layout selecionado.

Dividir um layout de controle em dois layouts

Você pode dividir um layout de controle em dois layouts usando o seguinte procedimento:

  1. Segure a tecla SHIFT e clique nos controles que você deseja mover para o novo layout de controle.

  2. Siga um destes procedimentos:

    • Na guia Organizar, no grupo Tabela, clique no tipo de layout que você deseja para o novo layout (Tabular ou Empilhado).

    • Clique com o botão direito do mouse nos controles selecionados, aponte para Layoute clique no tipo de layout que você deseja para o novo layout.

O Access cria um novo layout de controle e adiciona os controles selecionados a ele.

Reorganizar controles em um layout de controle

  • Você pode mover um controle dentro de um layout de controle arrastando-o para o local desejado. À medida que você arrasta o campo, uma barra horizontal ou vertical indica onde ele será colocado quando você liberar o botão do mouse.

  • Você pode mover um controle de um layout de controle para outro layout de controle do mesmo tipo. Por exemplo, você pode arrastar um controle de um layout empilhado para outro layout empilhado, mas não para um layout tabular.

Adicionar controles a um layout de controle

Para adicionar um novo campo do painel Lista de Campos a um layout de controle existente    

  • Basta arrastar o campo do painel Lista de Campos para o layout. Uma barra horizontal ou vertical indica onde o campo será colocado quando você liberar o botão do mouse.

Para adicionar controles existentes a um layout de controle existente    

  1. Selecione o primeiro controle que você deseja adicionar ao layout de controle.

  2. Se você quiser adicionar outros controles ao mesmo layout, segure a tecla SHIFT e selecione também esses controles. Você pode selecionar controles em outros layouts de controle.

  3. Siga um destes procedimentos:

    • Se o relatório estiver aberto no formato Design, arraste os campos selecionados para o layout. Uma barra horizontal ou vertical indica onde os campos serão colocados quando você liberar o botão do mouse.

    • Se o relatório estiver aberto no layout:

      1. Na guia Organizar, no grupo Tabela, clique no tipo de layout ao qual você está adicionando. Se você estiver adicionando a um layout tabular, clique emTabular. Se você estiver adicionando a um layout empilhado, clique emEmpilhado.

        O Access cria um novo layout e adiciona os controles selecionados a ele.

      2. Arraste o novo layout para o layout existente. Uma barra horizontal ou vertical indica onde os campos serão colocados quando você liberar o botão do mouse.

Remover controles de um layout de controle

Remover um controle de um layout de controle permite que você o coloque em qualquer lugar no relatório sem afetar o posicionamento de quaisquer outros controles.

  1. Selecione o controle que você deseja remover do layout. Para selecionar vários controles, segure a tecla SHIFT e clique nos controles que você deseja remover. Para selecionar todos os controles no layout, clique na caixa seletor de layout no canto superior esquerdo do layout.

  2. Clique com o botão direito do mouse em um dos controles selecionados, aponte para Layoute clique em Remover Layout.

    O Access remove os controles selecionados do layout.

Dica: Para impedir que um controle seja inserido em um layout de controle à medida que você o move, pressione e segure a tecla CTRL e arraste o controle para onde você deseja.

Início da página

Excluir um campo ou coluna

  1. Clique no campo ou coluna a ser excluído ou clique em seu rótulo ou título de coluna.

    O Access desenha uma borda ao redor do item para indicar que ele está selecionado.

  2. Pressione Delete.

Alterar a configuração da página

Use os grupos Tamanho da Página e Layout de Página na guia Configuração da Página para alterar tamanho, orientação, margens e assim por diante.

  1. Clique na guia Configuração da Página.

  2. No grupo Tamanho da Página, clique em Tamanho para selecionar um tamanho de papel diferente.

  3. No grupo Tamanho da Página, clique em Margens para fazer ajustes às margens do relatório.

  4. No grupo Layout de Página, clique em Retrato ou Paisagem para alterar a orientação do papel.

Alterar a formatação de um campo

  1. Selecione o campo que você deseja formatar.

  2. Na guia Formatar, use as ferramentas no grupo Fonte para aplicar a formatação que você deseja.

Vincular uma caixa de texto a um campo diferente (alterar a fonte de controle de um controle)

  1. Clique na coluna ou no campo para o qual você deseja alterar a fonte de controle.

    Uma borda é desenhada ao redor do item para indicar que o campo está selecionado.

  2. Se a folha de propriedades não for exibida no momento, pressione F4 para exibi-la.

  3. Na guia Dados da folha de propriedades, de definir a propriedade ControlSource como o novo campo. Você pode selecionar um campo na listada ou digitar uma expressão na caixa.

Alterar a fonte de registro do relatório

  1. Se a folha de propriedades não for exibida, pressione F4 para exibi-la.

  2. Na lista lista listada na parte superior da folha de propriedades, clique em Relatório.

  3. Na folha de propriedades, clique na guia Dados.

  4. Na listada Fonte de Registros, selecione a tabela ou consulta que você deseja usar para uma fonte de registro ou clique em Botão Construtor para exibir o Construtor de Consultas.

    Observação: Se o relatório estiver baseado em uma tabela, o Access perguntará se você deseja criar uma consulta com base na tabela. Clique em Sim para exibir o Construtor de Consultas e criar a consulta ou clique em Não para cancelar a operação. Se você optar por criar uma consulta, a nova consulta se tornará a fonte de registro do relatório. Ele será criado como uma consulta "incorporada", ou seja, uma consulta armazenada na propriedade RecordSource do relatório, em vez de como um objeto de consulta separado.

Wrap text in a field

  1. Se a folha de propriedades não for exibida, clique com o botão direito do mouse no campo no qual você deseja que o texto seja wrap e clique em Propriedades. Caso contrário, basta clicar no campo para selecioná-lo.

  2. Na guia Formatar da folha de propriedades, de definir a propriedade CanGrow comoSim.

Adicionar linhas de grade

Se os controles estão contidos em um layout de controle, você pode adicionar linhas de grade para fornecer mais separação visual entre os controles.

  1. Clique em qualquer campo em um layout de controle.

    Uma borda é desenhada ao redor do campo para indicar que ela está selecionada.

  2. Na guia Organizar, no grupo Tabela, clique em Gridlines.

  3. Selecione o estilo das linhas de grade que você deseja na lista lista listada.

Observação: Você também pode adicionar linhas de grade clicando com o botão direito do mouse em qualquer campo em um layout de controle, apontando para Layout,apontando para linhas de grade e selecionando o tipo de linhas de grade que você deseja.

Início da página

Adicionar ou modificar um logotipo ou outra imagem

Os procedimentos a seguir mostram como adicionar um logotipo a um relatório usando a ferramenta Logo e como ressarmar um controle de imagem ou uma imagem dentro de um controle de imagem.

Adicionar um logotipo

  • Na guia Design, no grupo Header/Footer, clique em Logotipo.

    A caixa de diálogo Inserir Imagem é exibida.

  • Navegue até a pasta onde seu arquivo de logotipo está armazenado e clique duas vezes no arquivo.

    O Access adiciona o logotipo ao canto superior esquerdo do relatório.

Resize um controle que contém um logotipo ou outra imagem

  1. Clique no controle que contém a imagem.

    Uma borda é desenhada ao redor do controle para indicar que ela está selecionada.

  2. Coloque o ponteiro na borda. Quando o ponteiro se torna uma seta de duas cabeças, você pode arrastá-lo nas direções indicadas pelas setas para tornar o controle de imagem maior ou menor.

Observe que o valor padrão para a propriedade Modo de Tamanho de uma imagem é Clip, o que significa que a imagem manterá o mesmo tamanho, independentemente de quão grande ou pequena você faça o controle de imagem. Se você quiser que a imagem fique maior ou menor à medida que ressize o controle, faça o seguinte:

Resize o logotipo ou a imagem dentro do controle

  1. Selecione a imagem.

  2. Se a Folha de Propriedades não for exibida, pressione F4 para exibi-la.

  3. Na guia Formatar da folha de propriedades, de definir a propriedade Modo de Tamanho como a opção que você deseja:

Configuração

Descrição

Clip

A imagem permanece com o mesmo tamanho, independentemente de quão grande ou pequeno você faça o controle de imagem. Se você tornar o controle de imagem menor que a imagem, a imagem será cortada.

Alongar

A imagem é estendida verticalmente e horizontalmente para corresponder ao tamanho do controle de imagem. A taxa de proporção original da imagem não é preservada, portanto, essa configuração pode resultar em uma imagem distorcida, a menos que você desem conjunto preciso da altura e largura do controle de imagem.

Zoom

À medida que o controle de imagem é resized, a imagem se ajusta para ser o maior possível sem afetar a taxa de proporção original da imagem.

Início da página

Adicionar ou editar um título de relatório

Os procedimentos a seguir mostram como adicionar ou editar um rótulo que contém o título do relatório.

Adicionar um título a um relatório

  • Na guia Design, no grupo Header/Footer, clique em Título.

    Um novo rótulo é adicionado ao header do relatório e o nome do relatório é inserido para você como o título do relatório.

  • Quando o rótulo é criado, o texto no rótulo é selecionado para você para que, se você quiser alterar o texto, você pode apenas começar a digitar o título que deseja.

  • Pressione ENTER quando terminar.

Editar o título do relatório

  1. Clique duas vezes no rótulo que contém o título do relatório para colocar o cursor no rótulo.

  2. Digite o texto que você deseja usar como título do relatório e pressione ENTER quando terminar.

Adicionar números de página, a data atual ou a hora atual

Os procedimentos a seguir mostram como adicionar números de página a um relatório e como adicionar a data atual ou a hora atual.

Adicionar números de página

  • Na guia Design, no grupo Header/Footer, clique em Números de Página.

    A caixa de diálogo Números de Página é exibida.

  • Escolha o formato, a posição e o alinhamento que você deseja para os números de página.

  • Desarmem a caixa de seleção Mostrar Número de Primeira Página se você não quiser um número na primeira página.

  • Clique em OK.

    Os números de página são adicionados ao relatório. Alternar para Visualizar Impressão para ver como os números serão quando você imprimir o relatório.

Adicionar a data ou a hora

  • Na guia Design, no grupo Header/Footer, clique em Data e Hora.

    A caixa de diálogo Data e Hora é exibida.

  • Desmarque a caixa de seleção Incluir data se não quiser incluir a data.

  • Se você quiser incluir a data, clique no formato de data que deseja.

  • Desmarque a caixa de seleção Incluir Hora se não quiser incluir a hora.

  • Se você quiser incluir a hora, clique no formato de hora que deseja.

    Um exemplo da data e hora, nos formatos escolhidos, aparece na área Exemplo da caixa de diálogo.

  • Clique em OK.

Modificar seu relatório no visual Design

Em alguns casos, você não pode realizar determinadas modificações no relatório no layout e, em vez disso, deve usar o design.

Adicionar números de linha

  1. Na guia Design, no grupo Controles, clique em Caixa de Texto.

  2. Clique em uma área aberta da seção onde você deseja que os números de linha apareçam. Na maioria dos casos, esta será a seção Detalhes. Você moverá a caixa de texto para seu local final mais tarde.

    Quando você clica no relatório, o Access cria uma nova caixa de texto desabotado.

  3. Clique no rótulo (apenas à esquerda da nova caixa de texto) e pressione DELETE.

  4. Clique uma vez na nova caixa de texto para selecioná-la e clique novamente para posicionar o cursor na caixa de texto.

  5. Digite =1 e pressione ENTER.

  6. Se a Folha de Propriedades não for exibida, pressione F4 para exibi-la.

  7. Na guia Dados da folha de propriedades, de definir a propriedade Running Sum como Over All.

    Observação: Se este for um relatório agrupado e você quiser que a numeração comece em 1 para cada grupo, de definir a propriedade como Over Group.

  8. Resize a caixa de texto para uma largura menor posicionando o ponteiro sobre a alça de tamanho na borda direita da caixa de texto e arrastando-a para a esquerda. Deixe espaço suficiente para o maior número de linha que você espera ver neste relatório.

  9. Se necessário, faça espaço para a caixa de texto na borda extrema esquerda da seção Detalhes arrastando os controles existentes nessa seção para a direita ou reizing o controle mais à esquerda nessa seção.

  10. Arraste a nova caixa de texto para o local desejado no relatório.

  11. Alternar para a exibição Relatório, Visualização de Impressão ou Layout para ver os números de linha.

Fazer um header de grupo aparecer na parte superior de cada página

Para grupos que abrangem várias páginas, é útil que o header de grupo apareça na parte superior de cada página para que você possa ver facilmente em qual grupo os dados estão. Você pode selecionar um header de grupo no layout, mas é mais fácil fazer isso no design.

  1. Clique duas vezes no seletor de seção de header do grupo (a barra horizontal acima da seção de header do grupo).

  2. Na guia Formatar da folha de propriedades, de definir a propriedade Repeat Section como Sim.

Abrir um sub-requisito em sua própria janela de exibição design

Quando você abre um relatório no design, todos os sub-relatório contidos no relatório também são abertos no design. No entanto, cada sub-requisito é exibido dentro de seu controle de sub-reporte, não como uma janela separada. Como o controle de sub-reportação geralmente é muito pequeno para trabalhar facilmente, geralmente é mais conveniente abrir o sub-requisito em sua própria janela e editá-lo. Para abrir um sub-requisito em uma nova janela, faça um dos seguintes:

  • Selecione o sub-lista e, em seguida, na guia Design, no grupo Ferramentas, clique em Sub-lista em Nova Janela.

  • Clique uma vez fora do controle de sub-noteporto para certificar-se de que ele não está selecionado e clique com o botão direito do mouse dentro do controle de sub-reporte e clique em Sub-reporteem Nova Janela .

Início da página

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×