Reduzir o tamanho do arquivo de suas planilhas do Excel

Aplica-se a
Excel para Microsoft 365 Excel 2024 Excel 2021 Excel 2019 Excel 2016

Se o tamanho do arquivo da planilha for muito grande, tente as dicas a seguir para torná-lo mais gerenciável.

 

Salvar a planilha no formato binário (.xslb)

Você pode reduzir o tamanho do arquivo salvando a planilha como uma pasta de trabalho binária (.xslb) em vez do formato padrão (.xslx). O formato padrão é baseado em XML, o que é importante se você estiver usando seus dados com programas de terceiros porque o XML é um padrão aberto. No entanto, para a maioria das finalidades, o formato binário é suficiente e salva em um arquivo menor.

  1. Vá paraSalvar Opções>de Arquivo>.

  2. Em Salvar pastas de trabalho, na lista Salvar arquivos neste formato , selecione Pasta de Trabalho Binária do Excel.

    Salvar em formato binário

Essa opção define o formato binário como padrão. Se você quiser manter o padrão para Pasta de Trabalho do Excel (.xlsx), mas salvar o arquivo atual como binário, selecione a opção na caixa de diálogo Salvar como. 

Observação

Se o arquivo estiver localizado em uma biblioteca do SharePoint, talvez você não veja a opção Salvar como. Se esse for o caso, você poderá salvar uma cópia em sua unidade local, salvar essa cópia como um binário e, em seguida, substituir o arquivo original pelo novo binário.

  1. Vá para Arquivo>Salvar como e, se esta for a primeira vez que você está salvando o arquivo, selecione um local.

  2. Na lista de tipos de arquivo, selecione Pasta de Trabalho Binária do Excel (*.xlsb).

    Salvar como pasta de trabalho binária do Excel

Reduzir o número de planilhas

Se você tiver planilhas com dados que não está usando e que não contêm fórmulas que está usando, exclua-as da planilha. 

Quanto mais pontos de dados você tiver na pasta de trabalho, maior será o tamanho do arquivo. A remoção de dados não utilizados reduzirá o tamanho do arquivo.

Salvar imagens em resoluções mais baixas

  1. Acesse Arquivo>Opções>Avançado.

  2. Em Tamanho e Qualidade da Imagem, faça o seguinte:

    • Selecione Descartar edição de dados. Essa opção remove os dados armazenados usados para restaurar a imagem ao seu estado original depois de editada. Observe que, se você descartar os dados de edição, não conseguirá restaurar a imagem.
    • Certifique-se de que a opção Não compactar imagens em arquivo não esteja selecionada.
    • Na lista Resolução padrão , selecione uma resolução de 150ppi ou inferior. Na maioria dos casos, você não precisará que a resolução seja maior do que isso.

Opções de tamanho e qualidade da imagem

Compactar imagens

  1. Selecione uma imagem no documento. A guia Formato da Imagem é exibida na faixa de opções.

  2. Na guia Formato da Imagem , no grupo Ajustar , selecione Compactar Imagens.

  3. Em Opções de compactação, faça o seguinte:

    • Para compactar todas as imagens do arquivo, desmarque Aplicar somente a esta imagem. Se essa opção estiver selecionada, as alterações feitas aqui afetarão apenas a imagem selecionada.
    • Selecione Excluir áreas cortadas de imagens. Esta opção remove os dados da imagem cortada, mas observe que você não poderá restaurá-los.
  4. Em Resolução, faça o seguinte:

    • Selecione Usar resolução padrão.

      Opções de Compactar Imagens

Não salve o cache dinâmico com o arquivo

Se sua planilha contiver uma tabela dinâmica, você poderá reduzir o tamanho do arquivo não salvando o cache de dados de origem da tabela dinâmica com o arquivo e, em vez disso, atualizando o cache de dados ao abrir a planilha.

  1. Selecione qualquer célula na tabela dinâmica.

  2. Na guia Analisar Tabela Dinâmica , no grupo Tabela Dinâmica , selecione Opções.

  3. Na caixa de diálogo Opções da Tabela Dinâmica , selecione a guia Dados e faça o seguinte:

    • Desmarque Salvar dados de origem com arquivo.

    • Selecione Atualizar dados ao abrir o arquivo.

      Opções de tabela dinâmica para não salvar o cache dinâmico

Veja Também

Reduzir o tamanho do arquivo de suas apresentações do PowerPoint

Reduzir o tamanho dos arquivos de arquivos do Word