Saiba mais sobre a SOMA

Saiba mais sobre a função SUM

Se você deseja obter rapidamente a soma de um intervalo de células, basta selecionar o intervalo e olhar na parte inferior direita da janela do Excel.

Captura de tela da seleção de um intervalo de células e da procura na Barra de Status


Esta é a Barra de Status e exibe informações sobre o que você selecionou, se é uma única célula ou várias células. Se você clicar com o botão direito do mouse na Barra de status, uma caixa de diálogo destacada será exibida com todas as opções que podem ser selecionadas. Observe que ela também exibe os valores do intervalo selecionado, caso tenha esses atributos marcados. 

A maneira mais fácil de adicionar uma fórmula de SOMA à planilha é usar o Assistente de AutoSoma. Selecione uma célula vazia diretamente acima ou abaixo do intervalo que você deseja somar e, nas guias Página Inicial ou Fórmula da Faixa de Opções, pressione AutoSoma > Soma. O Assistente de AutoSoma detectará automaticamente o intervalo a ser somado e criará a fórmula para você. Ele também pode trabalhar horizontalmente se você selecionar uma célula à esquerda ou à direita do intervalo a ser somado. Observe que isso não funcionará em intervalos não contíguos, mas abordaremos o tema na próxima seção.

Você pode usar o Assistente de AutoSoma para criar uma fórmula de soma automaticamente.  Selecione um intervalo acima/abaixo ou à esquerda/à direita do intervalo a ser somado e vá para a guia Fórmula na Faixa de Opções, selecione AutoSoma e SOMA.


A caixa de diálogo AutoSum também permite selecionar outras funções comuns, como:

AutoSoma verticalmente

A célula B6 mostra a fórmula Soma AutoSoma: =SOMA(B2:B5)

O Assistente de AutoSoma detectou automaticamente as células B2:B5 como o intervalo a ser somado. Tudo o que você precisa fazer é pressionar Enter para confirmá-lo. Se você precisar adicionar/excluir mais células, poderá manter a tecla Shift > Tecla de direção de sua escolha até que a seleção corresponda ao que deseja e pressionar Enter quando terminar.

Guia de função intellisense: o SUM(number1,[number2], ...) a marca flutuante abaixo da função é o guia Intellisense. Se você clicar no NOME DA SOMA ou da função, ele se transformará em um hiperlink azul, o que o levará ao tópico Ajuda para essa função. Se você clicar nos elementos de função individuais, suas partes representativas na fórmula serão realçadas. Nesse caso, apenas B2:B5 seria realçado, pois há apenas uma referência de número nesta fórmula. A marca Intellisense aparecerá para qualquer função.

AutoSoma horizontalmente

A célula D2 mostra a fórmula de Soma AutoSoma: =SOMA(B2:C2)

Usando SOMA com intervalos não contíguos.  A fórmula da célula C8 é =SOMA(C2:C3;C5:C6). Você também poderia usar Intervalos Nomeados, e a fórmula seria =SOMA(Semana1;Semana2).

O Assistente de AutoSum geralmente só funcionará para intervalos contíguos, portanto, se você tiver linhas ou colunas em branco no intervalo de somas, o Excel irá parar no primeiro intervalo. Nesse caso, você precisa resumir por seleção, onde você adiciona os intervalos individuais um a um. Neste exemplo, se você tivesse dados na célula B4, o Excel geraria =SUM(C2:C6) já que reconheceria um intervalo contíguo.

É possível selecionar vários intervalos não contíguos rapidamente clicando com o botão esquerdo do mouse enquanto mantém pressionada a tecla Ctrl. Primeiro, insira "=SOMA(", selecione intervalos diferentes e o Excel adicionará automaticamente a vírgula entre os intervalos para você. Pressione Enter quando terminar.

Dica: você pode usar ALT+= para adicionar a função SOMA a uma célula rapidamente. Depois é só selecionar os intervalos.

Observação: você pode notar como o Excel realça os diferentes intervalos de função por cor, e eles combinam dentro da própria fórmula, então C2:C3 é uma cor, e C5:C6 é outra. O Excel fará isso para todas as funções, a menos que o intervalo referenciado esteja em uma planilha diferente ou em uma pasta de trabalho diferente. Para acessibilidade aprimorada com tecnologia assistida, você pode usar Intervalos Nomeados, como "Week1", "Week2", etc. e, em seguida, fazer referência a eles em sua fórmula:

=SOMA(Semana1;Semana2)

  1. Você pode usar SOMA com outras funções. Aqui está um exemplo que cria um cálculo da média mensal:

    Usando SOMA com outras funções.  A fórmula na célula M2 é =SOMA(A2:L2)/CONT.VALORES(A2:L2).  Observação: as colunas de maio a novembro estão ocultas para maior clareza.
    • =SOMA(A2:L2)/CONT.VALORES(A2:L2)

  2. Que usa a SOMA de A2:L2 dividida pela contagem de células não vazias em A2:L2 (maio a dezembro estão em branco).

  1. Às vezes, você precisa somar determinada célula em várias planilhas. Pode ser tentador clicar nas planilhas e células desejadas e usar o "+" para adicionar os valores da célula, mas é entediante e pode causar erros.

    • =Plan1!A1+Plan2!A1+Plan3!A1

    Você pode fazer isso muito mais facilmente com uma SOMA 3D ou tridimensional:

    Soma 3D - a fórmula na célula D2 é =SOMA(Plan1:Plan3!A2)
    • =SOMA(Plan1:Plan3!A1)

    Que somará a célula A1 em todas as planilhas, da Planilha 1 à Planilha 3.

    Isso será particularmente útil quando você tiver uma única folha para cada mês (janeiro a dezembro) e precisar totalizá-las em uma planilha de resumo.

    SOMA 3D entre Planilhas Nomeadas.  A fórmula em D2 é =SOMA(Janeiro:Dezembro!A2)
    • =SOMA(Janeiro:Dezembro!A2)

    Que somará a célula A2 em cada planilha de janeiro a dezembro.

    Observações: Caso as planilhas incluam espaços nos nomes, como "Vendas Janeiro", será necessário usar um apóstrofo quando fizer referência aos nomes das planilhas em uma fórmula. Observe o apóstrofo ANTES do primeiro nome e APÓS o último nome da planilha.

    • =SOMA(‘Vendas Janeiro:Vendas dezembro’!A2)

    O método 3D também funciona com outras funções, como MÉDIA, MÍN, MÁX etc.:

    • =MÉDIA(Plan1:Plan3!A1)

    • =MÍNIMO(Plan1:Plan3!A1)

    • =MÁXIMO(Plan1:Plan3!A1)

Você pode realizar operações matemáticas com facilidade usando somente o Excel ou em conjunto com funções do Excel como SOMA. A tabela a seguir lista os operadores que você pode usar, além de algumas funções reacionadas. Você pode introduzir os operadores da linha de números do seu teclado ou do teclado numérico, caso tenha um. Por exemplo, se você pressionar Shift+8, o asterisco (*) será exibido para multiplicação.

Operador

Operação

Exemplos

+

Adição

=1+1

=A1+B1

=SOMA(A1:A10)+10

=SOMA(A1:A10)+B1

-

Subtração

=1-1

=A1-B1

=SOMA(A1:A10)-10

=SOMA(A1:A10)-B1

*

Multiplicação

=1*1

=A1*B1

=SOMA(A1:A10)*10

=SOMA(A1:A10)*B1

=PRODUTO(1;1) – Função PRODUTO

/

Divisão

=1/1

=A1/B1

=SOMA(A1:A10)/10

=SOMA(A1:A10)/B1

=QUOCIENTE (1;1) – Função QUOCIENTE

^

Exponenciação

=1^1

=A1^B1

=SOMA(A1:A10)^10

=SOMA(A1:A10)^B1

=POTÊNCIA(1;1) – Função POTÊNCIA

Para saber mais, confira Use o Excel como sua calculadora.

Outros Exemplos

  1. Digamos que você queira aplicar um desconto de porcentagem em um intervalo de células que você somou.

    Usando operadores com SOMA.  A fórmula na célula B16 é =SOMA(A2:A14)*-25%.  A fórmula seria construída corretamente se, em vez disso, -25% fosse uma referência de célula, como =SOMA(A2:A14)*E2
    • =SOMA(A2:A14)*-25%

    Daria a você 25% do intervalo resumido, no entanto, os códigos rígidos de 25% na fórmula, e pode ser difícil encontrar mais tarde se você precisar alterá-lo. É muito melhor colocar os 25% em uma célula e fazer referência a isso, onde ele está aberto e facilmente alterado, assim:

    • =SOMA(A2:A14)*E2

    Para dividir em vez de multiplicar, basta substituir "*" por "/": =SOMA(A2:A14)/E2

  2. Adicionando ou subtraindo de uma SOMA

    i. Você pode facilmente adicionar ou subtrair de uma Soma usando + ou -, por exemplo:

    • =SOMA(A1:A10)+E2

    • =SOMA(A1:A10)-E2

Consulte Também

Função SOMA

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×