Tarefas básicas no Access 2010

O suporte para o Office 2010 terminou em 13 de outubro de 2020

Atualize para o Microsoft 365 para trabalhar em qualquer lugar em qualquer dispositivo e continuar a receber suporte.

Atualizar agora

Aqui estão algumas tarefas básicas de banco de dados que você pode fazer para ajudá-lo a aprender a usar o Microsoft Access 2010.

 

Neste artigo

O que é o Access?

O Access 2010 é uma ferramenta de design e implantação de aplicativos de banco de dados que você pode usar para acompanhar informações importantes. Você pode manter seus dados no computador ou publicá-los na Web, para que outras pessoas possam usar seu banco de dados com um navegador da Web.

Muitas pessoas começam a usar o Access quando o programa que estão usando para acompanhar algo gradualmente se torna menos adequado para a tarefa. Por exemplo, suponha que você seja um planejador de eventos e queira acompanhar todos os detalhes necessários para tornar seus eventos bem-sucedidos. Se você usar um processador de palavras ou um programa de planilha para fazer isso, poderá facilmente ter problemas com dados duplicados e inconsistentes. Você pode usar o software de calendário, mas rastrear informações financeiras em um calendário não é um bom ajuste.

Bancos de dados relacionais no Access

Às vezes, você precisa de um banco de dados relacional para rastrear essas informações — um armazenamento de dados que foi separado em coleções menores de dados (chamadas tabelas) para eliminar a redundância e, em seguida, relacionadas em conjunto com base em bits comuns de informações (chamados campos). Por exemplo, um banco de dados relacional de planejamento de eventos pode conter uma tabela com informações do cliente, uma tabela com informações do fornecedor e uma tabela com informações de evento. A tabela com informações de evento pode ter um campo para relacioná-la à tabela do cliente e um campo para relacioná-la à tabela do fornecedor. Dessa forma, por exemplo, se o número de telefone de um fornecedor for alterado, as informações poderão ser alteradas uma vez na tabela do fornecedor, em vez de em todos os eventos que envolveram o fornecedor.

O Access é uma ferramenta que você pode usar para desenvolver rapidamente e facilmente aplicativos de banco de dados relacionais que ajudam você a gerenciar informações. Você pode criar um banco de dados para ajudá-lo a acompanhar qualquer tipo de informação, como inventário, contatos profissionais ou processos comerciais. Na verdade, o Access vem com modelos que você pode usar imediatamente para rastrear uma variedade de informações, facilitando as coisas até mesmo para um iniciante.

Quando você abre o Access

Quando você começa a Access 2010, você vê o Microsoft Office backstage, onde você pode obter informações sobre o banco de dados atual, criar um novo banco de dados, abrir um banco de dados existente e exibir o conteúdo em destaque do Office.com.

Modo de exibição Backstage do Access 2010

O exibição Backstage também contém muitos outros comandos que você pode usar para ajustar, manter ou compartilhar seus bancos de dados. Comandos no modo de exibição Backstage geralmente se aplicam a bancos de dados inteiros, não a objetos dentro de um banco de dados.

Observação: Você pode acessar a exibição Backstage a qualquer momento clicando na guia Arquivo.

Início da Página

Encontrar e aplicar um modelo

O Access fornece uma ampla variedade de modelos que você pode usar para acelerar seu processo de criação de banco de dados. Um modelo é um banco de dados pronto para uso que contém todas as tabelas, consultas, formulários e relatórios necessários para a execução de uma tarefa específica. Por exemplo, há modelos que podem ser usados para rastrear problemas, gerenciar contatos ou manter um registro de despesas. Alguns modelos contêm alguns registros de exemplo para ajudar a demonstrar seu uso. Os bancos de dados de modelo podem ser usados como estão ou você pode personalizá-los para melhor se ajustar às suas necessidades.

Para encontrar e aplicar um modelo ao banco de dados, faça o seguinte:

  1. Na guia Arquivo, clique em Novo.

  2. Em Modelos Disponíveis, siga um destes procedimentos:

    • Para reutilizar um modelo que você usou recentemente, clique em Modelos Recentes eselecione o modelo que deseja.

    • Para usar um modelo que você já instalou, clique em Meus Modelose selecione o modelo que deseja.

    • Para encontrar um modelo em Office.com, em Office.com Modelos,clique em uma categoria de modelo, selecione o modelo que você deseja e clique em Baixar para baixar o modelo do Office .com para seu computador.

      Você também pode pesquisar modelos no Office.com de dentro do Access. Na caixa Pesquisar modelos no Office.com, digite um ou mais termos de pesquisa e, em seguida, clique no botão de seta para pesquisar.

  3. Opcionalmente, clique no ícone de pasta ao lado da caixa Nome do Arquivo para navegar até um local onde você deseja criar o banco de dados. Se você não indicar um local específico, o Access criará o banco de dados no local padrão exibido abaixo da caixa Nome do Arquivo.

  4. Clique em Criar.

O Access cria o banco de dados e o abre para uso.

Início da Página

Criar um banco de dados a partir do zero

Se você quiser uma introdução mais detalhada aos conceitos por trás do uso do Access para criar um banco de dados, consulte o artigo Noções básicasde design de banco de dados.

Se nenhum dos modelos se adequar às suas necessidades ou se você tiver dados em outro programa que deseja usar no Access, você poderá decidir que é melhor criar um banco de dados do zero. No Access 2010, você tem uma opção: um banco de dados de área de trabalho padrão ou um banco de dados da Web.

Para obter mais informações sobre bancos de dados da Web, consulte o artigo Criar um banco de dados para compartilhar na Web.

Para criar um novo banco de dados, faça o seguinte:

  1. Inicie o Access.

  2. Na guia Novo no exibição Backstage, clique em Banco de Dados Em Branco ou Banco de Dados Da Web em Branco.

    Importante: A escolha que você faz aqui determinará quais recursos estão disponíveis no banco de dados. Os bancos de dados de área de trabalho não podem ser publicados na Web, e os bancos de dados da Web não dão suporte a alguns recursos da área de trabalho, como consultas totais.

  3. À direita, digite um nome para seu banco de dados na caixa Nome do Arquivo.

    Para alterar o local em que você cria o arquivo, clique em Procurar texto alternativo ao lado da caixa Nome do Arquivo, navegue até e selecione o novo local e clique em OK.

  4. Clique em Criar.

    O Access cria o banco de dados e abre uma tabela vazia (chamada Table1) em modo Folha de Dados.

  5. O Access coloca o cursor na primeira célula vazia na coluna Clique para Adicionar da nova tabela.

    Para adicionar dados, comece a digitar — ou você pode colar dados de outra fonte, conforme descrito na seção Colar dados de outra fonte em uma tabela do Access, posteriormente neste artigo.

    Observações: 

    • A inserção de dados no modo folha de dados foi projetada para ser muito semelhante à inserção de dados em uma planilha do Excel. A principal restrição é que os dados devem ser inseridos em linhas e colunas contíguas, começando no canto superior esquerdo da folha de dados. Você não deve tentar formatar seus dados incluindo linhas ou colunas em branco, como você pode fazer em uma planilha do Excel, pois isso desperdiçará espaço em sua tabela. A tabela contém apenas seus dados. Toda a apresentação visual desses dados será feita nos formulários e relatórios que você projetará posteriormente.

    • A estrutura da tabela é criada enquanto você inspeções de dados. Sempre que você adiciona uma nova coluna à folha de dados, um novo campo é definido na tabela. O Access define a tipo de dados do campo com base no tipo de dados que você insalu. Por exemplo, se você tiver uma coluna na qual tenha inserido apenas valores de data, o Access definirá o tipo de dados desse campo como Data/Hora. Se você tentar inserir posteriormente um valor não-data (como um nome ou um número de telefone) nesse campo, o Access exibirá uma mensagem informando que o valor não corresponderá ao tipo de dados da coluna. Quando possível, você deve planejar sua tabela para que cada coluna contenha o mesmo tipo de dados, seja texto, datas, números ou algum outro tipo. Isso torna muito mais fácil criar consultas, formulários e relatórios que selecionam apenas os dados que você deseja.

Se você ainda não quiser inserir dados, clique em Fechar Imagem do botão .

Observação: O Access excluirá Table1 se você o fechar sem salvar.

Início da Página

Abrir um banco de dados existente do Access

Dica: Para abrir rapidamente um dos últimos bancos de dados que você tinha aberto, na guia Arquivo, clique em Recentee clique no nome do arquivo.

  1. Na guia Arquivo, clique em Abrir.

  2. Clique em um atalho na caixa de diálogo Abrir ou, na caixa Procurar, clique na unidade ou pasta que contém o banco de dados desejado.

  3. Na lista de pastas, clique duas vezes em pastas até abrir a pasta que contém o banco de dados.

  4. Ao encontrar o banco de dados, faça um dos seguintes:

    • Para abrir o banco de dados no modo aberto padrão, clique duas vezes nele.

    • Para abrir o banco de dados para acesso compartilhado em um ambiente multiusuário, para que você e outros usuários possam ler e gravar no banco de dados ao mesmo tempo, clique em Abrir.

    • Para abrir o banco de dados para acesso somente leitura, para que você possa exibi-lo, mas não pode editá-lo, clique na seta ao lado do botão Abrir e clique em Abrir Somente Leitura.

    • Para abrir o banco de dados para acesso exclusivo, para que ninguém mais possa abri-lo enquanto você abri-lo, clique na seta ao lado do botão Abrir e clique em Abrir Exclusivo.

    • Para abrir o banco de dados para acesso somente leitura, clique na seta ao lado do botão Abrir e clique em Abrir Somente Leitura Exclusiva Outros usuários ainda podem abrir o banco de dados, mas eles só têm acesso somente leitura.

Se você não conseguir encontrar o banco de dados que deseja abrir    

  1. Na caixa de diálogo Abrir, clique no atalho Meu Computador ou, na caixa Procurar, clique em Meu Computador.

  2. Na lista de unidades, clique com o botão direito do mouse na unidade que você acha que pode conter o banco de dados e clique em Pesquisar.

  3. Insira seus critérios de pesquisa e pressione ENTER para pesquisar o banco de dados.

  4. Se o banco de dados for encontrado, abra-o clicando duas vezes nele na caixa de diálogo Resultados da Pesquisa.

    Como a pesquisa foi iniciada na caixa de diálogo Abrir, você deve clicar em Cancelar nessa caixa de diálogo antes que o banco de dados seja aberto.

Você pode abrir diretamente um arquivo de dados em um formato de arquivo externo (como dBASE, Paradox, Microsoft Exchange ou Excel). Você também pode abrir diretamente qualquer fonte de dados ODBC, como Microsoft SQL Server ou Microsoft FoxPro. O Access cria automaticamente um novo banco de dados do Access na mesma pasta que o arquivo de dados e adiciona links a cada tabela no banco de dados externo.

Início da Página

Começar a usar seu novo banco de dados

Dependendo do modelo usado, talvez seja necessário fazer um ou mais dos seguintes para começar com o novo banco de dados:

  • Se o Access exibir uma caixa de diálogo Logon com uma lista vazia de usuários, use o procedimento a seguir para começar:

    1. Clique em Novo Usuário.

    2. Preencha o formulário Detalhes do Usuário.

    3. Clique em Salvar e Fechar.

    4. Selecione o nome de usuário que você acabou de entrar e clique em Logon.

  • Se o Access exibir uma folha de dados vazia, você poderá começar a digitar dados diretamente nessa folha de dados ou clicar em outros botões e guias para explorar o banco de dados.

  • Se o Access exibir uma página De início, você poderá clicar em links nessa página para saber mais sobre o banco de dados ou clicar em outros botões e guias para explorar o banco de dados.

  • Se o Access exibir uma mensagem aviso de segurança na barra de mensagens e você confiar na origem do modelo, clique em Habilitar Conteúdo. Se o banco de dados exigir um logon, você precisará fazer logon novamente.

Para bancos de dados da área de trabalho e da Web, você também deseja começar com uma destas etapas:

Início da Página

Adicionar uma tabela

Você pode adicionar uma nova tabela a um banco de dados existente usando as ferramentas no grupo Tabelas na guia Criar.

Grupo Tabelas na guia Criar

Observação: Em um banco de dados da Web, somente o comando Table está disponível no grupo Tabelas.

Independentemente de qual exibição você iniciar, você sempre pode alternar para o outro exibição usando os botões de exibição na barra de status da janela do Access.

Criar uma tabela em branco no exibição Folha de Dados    No exibição Folha de Dados, você pode inserir dados imediatamente e permitir que o Access crie a estrutura da tabela nos bastidores. Os nomes de campo são atribuídos numericamente (Field1, Field2 e assim por diante) e Access define o tipo de dados de campo, com base no tipo de dados que você insinuou.

  1. Na guia Criar, no grupo Tabelas, clique em Tabela Imagem do botão .

  2. O Access cria a tabela e coloca o cursor na primeira célula vazia na coluna Clique para Adicionar.

  3. Para adicionar dados, comece a digitar na primeira célula vazia — ou você pode colar dados de outra fonte, conforme descrito posteriormente neste artigo.

    • Para renomear uma coluna (campo), clique duas vezes no título da coluna e digite o novo nome.

      Dica: Dê um nome significativo a cada campo, para que você possa dizer o que ele contém sem precisar olhar para os dados.

    • Para mover uma coluna, selecione-a clicando em seu título de coluna e arraste-a para onde você deseja. Você também pode selecionar várias colunas contíguas e arrastá-las para um novo local.

      Para adicionar mais campos à sua tabela, você pode começar a digitar na coluna Clique para Adicionar no exibição Folha de Dados ou adicionar novos campos usando os comandos no grupo Adicionar & Excluir na guia Campos.

Criar uma tabela começando no visual Design    No ponto de exibição Design, primeiro você cria a nova estrutura da tabela. Em seguida, alternar para o modo folha de dados para inserir dados ou inserir seus dados usando algum outro método, como com um formulário.

A exibição de design não está disponível para tabelas em um banco de dados da Web.

  1. Na guia Criar, no grupo Tabelas, clique em Design de Tabela. Imagem do botão

  2. Para cada campo em sua tabela, digite um nome na coluna Nome do Campo e selecione um tipo de dados na lista Tipo de Dados.

  3. Você pode inserir informações adicionais para cada campo na coluna Descrição. A descrição inserida é exibida na barra de status quando o ponto de inserção está nesse campo e é usada como o texto da barra de status para todos os controles criados arrastando o campo do painel Lista de Campos para um formulário ou relatório e para quaisquer controles criados para esse campo pelo Assistente de Formulário ou Assistente de Relatório.

  4. Depois de adicionar todos os campos, salve a tabela:

    • Na guia Arquivo, clique em Salvar.

  5. Você pode começar a inserir dados na tabela a qualquer momento alternando para o exibição Folha de Dados, clicando na primeira célula vazia e digitando. Você também pode colar dados de outra fonte, conforme descrito na próxima seção.

Criar uma tabela com base em uma lista do SharePoint    Com uma lista do SharePoint, seus dados podem ser usados por pessoas que não têm o Access. Além disso, os dados de lista são armazenados em um servidor, o que geralmente oferece melhor proteção contra perda de dados do que arquivos armazenados em um computador desktop. Você pode começar com uma nova lista ou vincular a uma lista existente. Você deve ter permissões suficientes no site do SharePoint onde deseja criar a lista; isso pode variar de acordo com o site para entrar em contato com o administrador do SharePoint para obter detalhes sobre suas opções.

Esse recurso não está disponível em um banco de dados da Web.

  1. Na guia Criar, no grupo Tabelas, clique em Listas do SharePoint.

  2. Você pode usar um dos modelos de lista para criar uma lista padrão do SharePoint, como Contatos ou Eventos.

    Você também pode optar por criar uma lista personalizada ou vincular ou importar uma lista existente. Clique na opção desejada.

  3. Se você escolher qualquer um dos modelos de lista ou criar uma lista personalizada, a caixa de diálogo Criar Nova Lista será aberta para orientá-lo durante o processo. Se você optar por usar uma lista existente, a caixa de diálogo Obter Dados Externos será aberta para ajudá-lo.

Para mais informações sobre tabelas, confira Introdução às tabelas.

Início da Página

Colar dados de outra fonte em uma tabela do Access

Se seus dados estão armazenados no momento em outro programa, como o Excel, você pode copiar e colar seus dados em uma tabela do Access. Em geral, isso funciona melhor se seus dados já estão separados em colunas, como estão em uma planilha do Excel. Se seus dados estão em um programa de processamento de palavras, você deve primeiro separar as colunas de dados usando guias ou converter os dados em uma tabela no programa de processamento de palavras e, em seguida, copiar os dados. Se os dados precisarem de qualquer edição ou manipulação (por exemplo, separando nomes completos em nomes de nome e sobrenome), talvez você queira fazer isso antes de copiar os dados, especialmente se você não estiver familiarizado com o Access.

Quando você colar dados em uma tabela vazia, o Access define o tipo de dados de cada campo de acordo com o tipo de dados que ele encontra lá. Por exemplo, se um campo pastado contiver apenas valores de data, o Access aplicará o tipo de dados Data/Hora a esse campo. Se o campo pastado contiver apenas as palavras "sim" e "não", o Access aplicará o tipo de dados Sim/Não ao campo.

O Access nomeia os campos dependendo do que ele encontra na primeira linha de dados passados. Se a primeira linha de dados pastados for semelhante ao tipo das linhas a seguir, o Access determinará que a primeira linha faz parte dos dados e atribui os campos nomes genéricos (Field1, Field2 e assim por diante). Se a primeira linha de dados pastados não for semelhante às linhas a seguir, o Access usará a primeira linha como nomes de campo e excluirá a primeira linha nos dados reais.

Se o Access atribuir nomes de campo genéricos, você deverá renomear os campos assim que possível para evitar confusão. Use o seguinte procedimento:

  1. Na guia Arquivo, clique em Salvar para salvar a tabela.

  2. No exibição Folha de Dados, clique duas vezes em cada título de coluna e digite um nome para a coluna.

  3. Salve a tabela novamente.

Início da Página

Importar ou vincular a dados de outra fonte

Você pode ter dados que você está coletando em outro programa que gostaria de usar no Access. Talvez você trabalhe com pessoas que armazenam seus dados em outros programas e queira trabalhar com seus dados no Access. Ou talvez você tenha várias fontes diferentes de dados e precise de um "landing pad" onde você pode reuni-los para uma análise mais profunda.

O Access facilita a importação ou vinculação de dados de outros programas. Você pode trazer dados de uma planilha do Excel, de uma tabela em outro banco de dados do Access, de uma lista do SharePoint ou de uma variedade de outras fontes. O processo difere ligeiramente dependendo da fonte de dados, mas essas instruções o iniciarão:

  1. Na guia Dados Externos, no grupo Importar & Link, clique no comando do tipo de arquivo do qual você está importando.

    Por exemplo, se você estiver importando dados de uma planilha do Excel, clique em Excel. Se você não vir o tipo de programa correto, clique em Mais.

    Observação: Se você não conseguir encontrar o tipo de formato correto no grupo Importar & Link, talvez seja necessário iniciar o programa no qual você criou originalmente os dados e, em seguida, usar esse programa para salvar os dados em um formato de arquivo compatível com o Access (como um arquivo de texto delimitado ) e, em seguida, importar ou vincular aos dados.

  2. Na caixa de diálogo Obter Dados Externos, clique em Procurar para navegar até o arquivo de dados de origem ou digite o caminho completo do arquivo de dados de origem na caixa Nome do arquivo.

  3. Clique na opção que você deseja em Especificar como e onde deseja armazenar os dados no banco de dados atual. Você pode criar uma nova tabela usando os dados importados ou criar uma tabela vinculada que mantenha um link para a fonte de dados.

  4. Clique em OK.

    Dependendo da sua escolha, a caixa de diálogo Objetos de Link ou a caixa de diálogo Importar Objetos será aberta.

  5. Use a caixa de diálogo para concluir o processo. O procedimento exato que você segue depende da opção de importação ou link escolhida.

  6. Na última página do assistente, clique em Concluir.

    Se você optou por importar, o Access perguntará se deseja salvar os detalhes da operação de importação que você concluiu.

  7. Se você acha que executará essa mesma operação de importação novamente, clique em Salvaretapas de importação e insira os detalhes.

    Em seguida, você pode reproduzir facilmente a operação de importação clicando em Importações Salvas no grupo Importar na guia Dados Externos, clicando na especificação de importação e clicando em Executar.

  8. Se você não quiser salvar os detalhes da operação, clique em Fechar.

O Access importa os dados para uma nova tabela e exibe a tabela em Tabelas no Painel de Navegação.

Para saber mais sobre como importar dados para o Access, siga os links na seção Consulte Também deste artigo.

Início da Página

Próximas etapas

O restante do processo de design varia com base em suas metas, mas você provavelmente deseja considerar a criação de consultas, formulários, relatórios e macros. Este artigo não fornece informações sobre como criar objetos de banco de dados adicionais.

Para obter mais informações, consulte estes artigos:

Início da Página

Importar dados de uma planilha ou outro programa

Se você estiver familiarizado com outros programas de banco de dados ou planilha, provavelmente conhecerá as noções básicas de como esses aplicativos funcionam e para que bancos de dados são usados. O Access difere de muitos outros aplicativos de banco de dados, permitindo que você crie bancos de dados relacionais e ele difere ainda mais da maioria dos programas de planilha, oferecendo ferramentas para desenvolver consultas, formulários e relatórios sofisticados. O Access também fornece muitas opções para trabalhar com outros programas de banco de dados, como SQL Server.

Importar uma planilha do Excel para o Access

Muitas pessoas começam a explorar o Access após a primeira criação de uma lista no Excel. O Excel é um ótimo lugar para iniciar uma lista, mas à medida que a lista aumenta, torna-se mais difícil organizar e manter-se atualizado. Mover a lista para o Access geralmente é a próxima etapa lógica.

Uma tabela de banco de dados é semelhante à estrutura de uma planilha, já que os dados são armazenados em linhas e colunas. Como resultado, geralmente é fácil importar uma planilha para uma tabela de banco de dados. A principal diferença entre armazenar seus dados em uma planilha e armazenar em um banco de dados está na forma como os dados são organizados. Simplesmente importar sua planilha inteira como uma nova tabela em um banco de dados não resolverá os problemas associados à organização e atualização de seus dados, especialmente se sua planilha contiver dados redundantes. Para resolver esses problemas, você deve dividir os dados da planilha em tabelas separadas, cada uma contendo dados relacionados. Para obter mais informações sobre como organizar os dados em suas tabelas, consulte o artigo Noções básicasde design de banco de dados.

Recursos do Access o Assistente do Analisador de Tabelas, que pode ajudá-lo a concluir esse processo. Depois de importar seus dados para uma tabela, o assistente ajuda você a dividir a tabela em tabelas separadas, cada uma delas contém dados que não são duplicados em nenhuma das outras tabelas. O assistente também cria as relações necessárias entre as tabelas.

Início da Página

Importar uma planilha do Excel como uma tabela em um novo banco de dados

  1. Na guia Arquivo, clique em Novoe em Banco de Dados em Branco.

  2. Digite um nome para o novo banco de dados na caixa Nome do Arquivo e clique em Criar.

    O novo banco de dados é aberto e o Access cria uma nova tabela vazia, Table1.

  3. Feche Table1.

    Quando perguntado se deseja salvar alterações no design de Table1, clique em Não.

  4. Na guia Dados Externos, no grupo Importar & Link, clique em Excel. Imagem do botão

  5. Na caixa de diálogo Obter Dados Externos, clique em Procurar.

  6. Use a caixa de diálogo Abrir Arquivo para localizar seu arquivo.

  7. Selecione o arquivo e clique em Abrir.

  8. Na caixa de diálogo Obter Dados Externos, verifique se a opção Importar os dados de origem para uma nova tabela na opção banco de dados atual está selecionada.

  9. Clique em OK.

    O Assistente de Importação de Planilha é iniciado e faz algumas perguntas sobre seus dados.

  10. Siga as instruções, clicando em Próximo ou Voltar para navegar pelas páginas. Na última página do assistente, clique em Concluir.

    Observação: O Access pergunta se você deseja salvar os detalhes da operação de importação que você acabou de concluir. Se você acha que executará essa mesma operação de importação novamente, clique em Sime insira os detalhes. Em seguida, você pode reproduzir facilmente a operação no futuro clicando em Importações Salvas no grupo Importar na guia Dados Externos. Se você não quiser salvar os detalhes da operação, clique em Fechar.

O Access importa os dados para uma nova tabela e os exibe em Todas as Tabelas no Painel de Navegação.

Início da Página

Use o Assistente do Analisador de Tabelas para organizar seus dados

Depois que seus dados foram importados para uma tabela do Access, você pode usar o Assistente do Analisador de Tabelas para identificar rapidamente dados redundantes. Em seguida, o assistente fornece uma maneira simples de organizar os dados em tabelas separadas, para que sejam armazenados da maneira mais eficiente. O Access preserva a tabela original como backup e cria novas tabelas que você pode usar como base para seu aplicativo de banco de dados.

  1. Abra o banco de dados do Access que contém a tabela que você deseja analisar.

  2. Na guia Ferramentas de Banco de Dados, no grupo Analisar, clique em Analisar Tabela.

    O Assistente do Analisador de Tabelas é iniciado.

    As duas primeiras páginas do assistente contêm um tutorial curto , completo com botões que você pode clicar para ver exemplos. Se você não vir as páginas introdutórios, mas, em vez disso, ver uma caixa de seleção rotulada Mostrar páginas introdutórios?, selecione a caixa de seleção e clique em Voltar duas vezes para ver a introdução. Se você não quiser ver as páginas introdutórios novamente após ler a introdução, poderá desempurar a caixa de seleção Mostrar páginas introdutórios?

  3. Na página Qual tabela contém campos com valores repetidos em muitos registros? Selecione a tabela que você deseja analisar e clique em Próximo.

  4. Você pode permitir que o assistente decida quais campos ir em quais tabelas ou você mesmo pode tomar essa decisão. Se você seguir as sugestões do assistente, ainda poderá fazer alterações no layout da tabela na próxima página do assistente.

    Observação: Se você permitir que o assistente decida quais campos colocar em quais tabelas, suas escolhas nem sempre serão apropriadas para seus dados, especialmente se não houver muitos dados para trabalhar. Você deve verificar cuidadosamente os resultados do assistente. Por outro lado, o assistente pode sugerir uma organização mais eficiente do que a que você está pensando, portanto, é uma boa ideia tentar pelo menos as decisões do assistente uma vez. Se você não gosta das sugestões, ainda pode reorganizar os campos manualmente e sempre pode clicar em Voltar e organizar todos os campos sozinho.

  5. Clique em Avançar. Nesta página, você especifica quais tabelas contêm quais campos. Se você optou por permitir que o assistente decida, você deverá ver várias tabelas conectadas por linhas de relacionamento. Caso contrário, o Access cria apenas uma tabela contendo todos os campos. Em ambos os casos, você pode fazer alterações nesta página.

    • Você pode arrastar campos de uma tabela para uma área em branco da página para criar uma nova tabela que contenha esses campos. O Access solicita um nome de tabela.

    • Você pode arrastar campos de uma tabela para outra se achar que eles serão armazenados de forma mais eficiente lá.

    • A maioria das tabelas receberá uma ID ou um campo ID Exclusivo Gerado. Para saber mais sobre os campos de ID, clique em Dicas no canto superior direito do assistente.

    • Para desfazer uma alteração, clique no botão Desfazer.

    • Para renomear uma tabela, clique duas vezes em sua barra de título, digite o novo nome e clique em OK.

  6. Depois de organizar os campos da maneira que você deseja, clique em Próximo.

  7. Se o assistente encontrar registros com valores muito semelhantes, ele identificará esses valores como possíveis erros tipográficos e apresentará uma tela onde você pode confirmar o que fazer sobre eles. Role pela lista para encontrar qualquer um que tenha valores na coluna Correção e clique no item apropriado na listada. Selecione (Deixar como está) para impedir que o assistente mude o valor. Quando terminar, clique em Próximo.

  8. O assistente pergunta se você deseja criar uma consulta que se pareça com sua tabela original. Se você já criou formulários e relatórios baseados na tabela original, criar essa consulta é uma boa ideia. Se você escolher Sim,crie a consulta , o assistente renomeia a tabela original, _OLD "_OLD" para o nome da tabela e nomeia a nova consulta usando o nome da tabela original. Os formulários e relatórios baseados na tabela agora usam a consulta para seus dados e continuam a funcionar como antes.

  9. Clique em Concluir.

    O assistente cria as novas tabelas conforme especificado e as abre. Feche-os quando terminar de inspecionar os resultados.

Início da Página

Trabalhar com dados de outros programas

O Access 2010 fornece recursos para trabalhar com dados armazenados em outros programas.

Criar um novo banco de dados do Access que vincula dados em outro formato de arquivo    Você pode usar o Access para abrir um arquivo em outro formato de arquivo, como texto, dBASE ou uma planilha. O Access cria automaticamente um banco de dados do Access e vincula o arquivo para você.

  1. Inicie o Access.

  2. Na guia Arquivo, clique em Abrir.

  3. Na caixa de diálogo Abrir, clique no tipo de arquivo que você deseja abrir na lista. Se você não tiver certeza do tipo de arquivo, clique em Todos os Arquivos (*.*).

  4. Se necessário, navegue até a pasta que contém o arquivo que você deseja abrir. Quando você encontrar o arquivo, clique duas vezes nele para abri-lo.

  5. Siga as instruções do assistente. Na última página do assistente, clique em Concluir.

Importar ou vincular dados a um banco de dados do Access existente    Você pode importar dados de outras fontes e programas para tabelas do Access para que os dados estejam contidos no arquivo do Access ou você pode vincular aos dados do Access para que os dados permaneçam no arquivo original (fora do arquivo do Access).

  1. Na guia Dados Externos, no grupo Importar & Link, clique no formato no qual os dados são armazenados.

    Você pode importar ou vincular aos dados das seguintes fontes:

    • Excel    Você pode trazer dados de uma planilha ou de um intervalo nomeado em uma pasta de trabalho do Excel. Cada planilha ou intervalo nomeado deve ser importado ou vinculado separadamente.

    • Access    Isso é muito útil para separar seu processo de seus dados, criar um banco de dados dividido. Ou seja, você pode usar um banco de dados para conter todos os formulários, relatórios e macros e manter seus dados em outro banco de dados. Em seguida, você pode desenvolver melhorias sem interromper o trabalho de ninguém. Você também pode combinar dados de vários bancos de dados do Access diferentes em um, facilitando a resumição de dados entre departamentos ou entre parceiros comerciais.

    • banco de dados ODBC    Muitos programas suportam esse formato, incluindo muitos produtos de servidor de banco de dados. Isso ajuda a criar bancos de dados "landing pad", onde você combina dados de sistemas diferentes.

    • Arquivo de texto    Você pode se conectar a um arquivo de texto simples e até mesmo usar o Access para alterar o conteúdo desse arquivo. Isso pode ajudar a facilitar o consumo de dados do Access por uma ampla variedade de programas.

    • Arquivo XML    Esse formato também oferece compatibilidade com vários outros programas, incluindo alguns servidores Web.

    • Lista do SharePoint    Isso torna seus dados usáveis com um navegador da Web, a maneira padrão de usar uma lista do SharePoint.

    • Serviços de Dados    Você pode se conectar aos serviços de dados da Web dentro da sua empresa.

    • Documento HTML    

    • Pasta do Outlook    Você pode se conectar às pastas do Outlook, para integrar mais facilmente suas informações de contato com o restante dos seus dados.

    • Arquivo dBase    dBase é um sistema de banco de dados alternativo popular com suporte do Access

      A caixa de diálogo Obter Dados Externos é exibida.

  2. Siga as instruções na caixa de diálogo.

    O Access importará ou vincula os dados ao banco de dados. Para a maioria dos formatos, você deve especificar o local dos dados e, em seguida, escolher como deseja que os dados sejam armazenados em seu banco de dados.

Início da Página

Usar um banco de dados de versão anterior em várias versões do Access

Se o banco de dados do Access ou o projeto do Access tiver sido criado no Access 2000 ou posterior, você poderá usar o banco de dados ou o projeto na versão do Access na qual ele foi criado ou em qualquer versão posterior, mesmo se o arquivo estiver habilitado para segurança. Por exemplo, arquivos do Access 2000 podem ser usados no Access 2000, Access 2002, Access 2003, Access 2007 e Access 2010.

Você pode ter uma situação em que deseja manter seus dados em uma versão anterior do Access, mas você tem usuários com uma versão posterior do Access que deseja vincular a esses dados, mas ainda tirar proveito de alguns dos recursos da versão posterior. A solução é criar um novo banco de dados "front-end" na versão posterior (contendo formulários, relatórios, consultas, macros, mas sem tabelas) e vinculá-lo às tabelas no arquivo de versão anterior. Use um dos procedimentos a seguir, dependendo se seu banco de dados está contido em um arquivo ou já está dividido em um aplicativo front-end/back-end.

Usar um arquivo de banco de dados do Access em várias versões do Access

Se todas as tabelas, formulários e outros objetos do banco de dados do Access de versão anterior estão contidos em um arquivo e você deseja usar o banco de dados em várias versões do Access, você pode criar um novo banco de dados front-end em uma versão posterior e vinculá-lo ao arquivo original. Os usuários que têm a versão anterior do Access ainda podem usar o banco de dados original. Os usuários que têm a versão posterior podem usar o novo banco de dados front-end para vincular aos mesmos dados. Você pode criar várias versões front-end se precisar acomodar várias versões do Access.

Início da Página

Etapa 1: Fazer uma cópia do banco de dados existente e salvá-lo em um novo formato

Use o procedimento a seguir para converter o banco de dados em qualquer um dos três formatos mais recentes: Access 2000, Access 2002-2003 ou Access 2007. Esse comando preserva o banco de dados original em seu formato original e cria uma cópia no formato especificado.

  1. Feche o arquivo do Access. Se o arquivo for um banco de dados do Access multiusuário localizado em um servidor ou em uma pasta compartilhada, certifique-se de que ninguém mais o tenha aberto.

  2. Inicie o Access 2010.

  3. Na guia Arquivo, clique em Abrir.

  4. Navegue até o local do arquivo que você deseja converter e clique duas vezes nele para abri-lo.

    Se a caixa de diálogo Aprimoramento do Banco de Dados for exibida, perguntando se você deseja aprimorar o banco de dados, clique em Não.

  5. Se um formulário for aberto quando você iniciar o banco de dados, feche o formulário.

  6. Na guia Arquivo, clique em Salvar Banco de Dados como.

  7. Na caixa de diálogo Salvar como, digite um nome para o novo banco de dados.

    Observação: A menos que você salve o novo banco de dados em um local diferente, seu nome deve ser diferente do banco de dados original. Em ambos os casos, geralmente é melhor usar um nome diferente, para que você possa distinguir facilmente entre o banco de dados front-end e o banco de dados back-end. No entanto, se você estiver convertendo para o formato do Access 2007, a extensão de nome de arquivo muda de .mdb para .accdb, para que você possa usar o mesmo nome de arquivo.

  8. Clique em Salvar.

Início da Página

Etapa 2: dividir o banco de dados de cópia e usar o arquivo original como o banco de dados back-end

Divida o banco de dados convertido usando o seguinte procedimento:

  • Na guia Ferramentas de Banco de Dados, no grupo Mover Dados, clique em Acessar Banco de Dados. Imagem do botão

  • Na caixa de diálogo Divisor de Banco de Dados, clique em Dividir Banco de Dados.

    Você pode fazer um backup se quiser, mas também pode apenas re-criar a cópia usando o banco de dados original.

  • Digite um nome para o banco de dados back-end e clique em Dividir.

Início da Página

Etapa 3: Conectar o novo front-end ao banco de dados original

  1. Exclua o banco de dados back-end criado pela ferramenta Divisor de Banco de Dados , sendo cuidadoso para não excluir seu banco de dados original.

  2. Vincule o novo banco de dados front-end às tabelas no banco de dados original: Na guia Dados Externos, no grupo Importar & Link, clique em Gerenciador de Tabela Vinculada. Imagem do botão

  3. Clique em Selecionar Tudoe selecione a caixa de seleção Sempre solicitar novo local.

  4. Clique em OK,navegue até o banco de dados de versão anterior e clique duas vezes nele.

    Se tudo correr bem, o Access exibirá uma mensagem informando que todas as tabelas vinculadas selecionadas foram atualizadas com êxito.

Agora você pode aprimorar o novo banco de dados front-end para dar suporte a novos recursos para usuários que têm versões mais recentes do Access. Os usuários que têm versões anteriores podem continuar a usar o banco de dados de versão anterior.

Início da Página

Usar um aplicativo front-end/back-end em várias versões do Access

Se o banco de dados do Access já aplicativo front-end/back-end, você poderá converter o front-end no novo formato de arquivo. Nenhuma alteração é necessária para o banco de dados back-end.

O procedimento a seguir mostra como usar o comando Salvar Banco de Dados Como para converter o banco de dados front-end em qualquer um dos três formatos mais recentes: Access 2000, Access 2002-2003 ou Access 2007. Esse comando preserva o banco de dados original em seu formato original e cria uma cópia no formato especificado.

  1. Feche o banco de dados front-end. Se o arquivo for um banco de dados do Access multiusuário localizado em um servidor ou em uma pasta compartilhada, certifique-se de que ninguém mais o tenha aberto.

  2. Inicie o Access 2010.

  3. Na guia Arquivo, clique em Abrir.

  4. Navegue até o local do banco de dados front-end e clique duas vezes nele para abri-lo.

    Se a caixa de diálogo Aprimoramento do Banco de Dados for exibida, perguntando se você deseja aprimorar o banco de dados, clique em Não.

  5. Se um formulário aparecer quando você abrir o banco de dados, feche o formulário.

  6. Na guia Arquivo, clique em Salvar Banco de Dados como.

  7. Na caixa de diálogo Salvar como, digite um nome para o novo banco de dados.

  8. Clique em Salvar.

Agora você pode aprimorar o novo banco de dados front-end para dar suporte a novos recursos.

Início da Página

Precisa de mais ajuda?

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×