Não pode determinar que campos estão disponíveis e que campos estão indisponíveis quando abre uma caixa de diálogo no Microsoft Dynamics NAV

O Microsoft Business Solutions-Navision 4.0 e o Microsoft Navision 4.0 fazem agora parte do Microsoft Dynamics NAV 4.0. Todas as referências ao Microsoft Business Solutions-Navision ou ao Microsoft Navision 4.0 estão relacionadas com o Microsoft Dynamics NAV.

Este artigo aplica-se ao Microsoft Dynamics NAV 4.0 para todas as regiões.

Sintomas

Quando abre uma caixa de diálogo no Microsoft Dynamics NAV, não pode determinar que campos estão disponíveis e que campos estão indisponíveis porque todos os campos parecem estar disponíveis. Esse problema ocorrerá se as seguintes condições forem verdadeiras:

  • Está a utilizar o Microsoft Dynamics NAV num computador baseado no Windows Vista.
  • O esquema de cores do Windows Aero está ativado no computador.

Por exemplo, este problema ocorre quando abre a caixa de diálogo Cartão de Cliente no Microsoft Dynamics NAV. Ao fazê-lo, o campo Saldo e o campo Limite de Crédito têm a mesma cor. No entanto, o campo Saldo deve aparecer desativado porque não está disponível.

Causa

Este problema ocorre porque o Microsoft Dynamics NAV utiliza controlos do Windows que têm um aspeto diferente quando o computador está a executar o Windows Vista.

Resolução

Informações sobre o hotfix

Uma correção suportada está agora disponível na Microsoft. A correção corrige o problema descrito neste artigo. Aplique a correção apenas aos sistemas que estão a ter este problema específico.

Para resolve este problema imediatamente, contacte o Suporte Técnico do Microsoft Dynamics e os produtos relacionados para obter a correção. Pode iniciar sessão no site do Microsoft Dynamics e criar um novo pedido de suporte. Para fazer isso, acesse o seguinte site da Microsoft:

https://mbs.microsoft.com/support/newstart.aspx Também pode contactar o Suporte Técnico do Microsoft Dynamics e produtos relacionados por telefone através do (888) 477-7877.

Nota Em casos especiais, os custos normalmente incorridos para chamadas de suporte poderão ser cancelados se um Profissional de Suporte Técnico do Microsoft Dynamics e produtos relacionados determinar que uma atualização específica irá resolve o seu problema. Os custos de suporte habituais serão aplicados a quaisquer questões e problemas de suporte adicionais que não sejam elegíveis para a atualização específica em questão.

Como obter a correção do Microsoft Dynamics NAV ou atualizar ficheiros

Depois de pedir uma correção do Microsoft Dynamics NAV ou um ficheiro de atualização do Suporte Técnico para o Microsoft Dynamics, será enviada uma hiperligação para si num e-mail.

O e-mail conterá uma hiperligação e uma palavra-passe. Pode utilizar a hiperligação para transferir a correção do Microsoft Dynamics NAV ou os ficheiros de atualização. Quando clica na hiperligação, é aberta a caixa de diálogo Transferência de Ficheiros – Aviso de Segurança . Em seguida, é-lhe pedido para executar, guardar ou cancelar a transferência.

Se clicar em Executar, os ficheiros iniciam a transferência e o processo de extração. Tem de especificar uma pasta para os novos ficheiros e, em seguida, fornecer a palavra-passe.

Se clicar em Guardar, tem de especificar um caminho para guardar o ficheiro comprimido. Quando abrir o ficheiro que guardou, ser-lhe-á pedido que especifique um caminho para os ficheiros. Em seguida, tem de fornecer a palavra-passe fornecida no e-mail.

Se clicar em Cancelar, o processo de transferência para.

Como instalar uma correção ou um ficheiro de atualização do Microsoft Dynamics NAV

As correções e atualizações da plataforma Microsoft Dynamics NAV são disponibilizadas como ficheiros únicos. Para instalar uma correção do Microsoft Dynamics NAV ou uma atualização, tem de substituir os ficheiros de instalação existentes do Microsoft Dynamics NAV pela correção ou pelos ficheiros de atualização. Para fazer isso, siga estas etapas:

Microsoft Dynamics NAV 4.0 SP3

Passo 1: Substituir o ficheiro de instalação do Cliente Microsoft Dynamics NAV

Na instalação do cliente Microsoft Dynamics NAV, substitua os seguintes ficheiros com a correção ou o ficheiro de atualização.

Nome do arquivo Versão do arquivo Tamanho do arquivo Data Hora Plataforma
Dbm.dll 4.0.3.25206 345,208 13-Set-2007 18:20 x86
Fin.exe 4.0.3.25206 8,119,416 13-Set-2007 18:20 x86
Fin.exe.manifest Não aplicável 711 11-Set-2007 2,113 Não aplicável
Finhlink.exe 4.0.3.25206 119,928 13-Set-2007 20:17 x86
Finsql.exe 4.0.3.25206 8,168,568 13-Set-2007 18:20 x86
Finsql.exe.manifest Não aplicável 714 14-Dez-2006 16:41 Não aplicável
Nc_netb.dll 4.0.3.25206 78,968 13-Set-2007 20:17 x86
Nc_tcp.dll 4.0.3.25206 83,064 13-Set-2007 20:17 x86
Nc_tcps.dll 4.0.3.25206 91,256 13-Set-2007 20:17 x86

Para substituir os ficheiros existentes do Microsoft Dynamics NAV, siga estes passos:

  1. Feche o Cliente Microsoft Dynamics NAV.

  2. Localize o diretório de instalação do Cliente Microsoft Dynamics NAV.

    Nota Normalmente, o Cliente Microsoft Dynamics NAV é instalado no seguinte diretório:
    C:\Program Files\Microsoft Business Solutions-Navision\Client\

  3. Copie os ficheiros que transferiu.

  4. Cole os ficheiros que transferiu para o diretório de instalação do Cliente Microsoft Dynamics NAV.

  5. Na caixa
    Caixa de diálogo Confirmar Substituição de Ficheiro, clique em Sim para substituir os ficheiros no diretório de instalação.

Microsoft Dynamics NAV 2009

Passo 1: Substituir os ficheiros de instalação do Cliente Clássico do Microsoft Dynamics NAV

Na instalação do Cliente Clássico do Microsoft Dynamics NAV, substitua os seguintes ficheiros com a correção ou o ficheiro de atualização.

Nome do arquivo Versão do arquivo Tamanho do arquivo Data Hora Plataforma
Dbm.dll 6.0.29415.0 444,232 1-Julho-2009 9:19 x86
Fin.exe 6.0.29415.0 12,244,792 1-Julho-2009 9:19 x86
Finhlink.exe 6.0.29415.0 452,432 1-Julho-2009 9:19 x86
Finsql.exe 6.0.29415.0 12,330,832 1-Julho-2009 9:19 x86
Nc_netb.dll 6.0.29415.0 108,352 1-Julho-2009 9:19 x86
Nc_tcp.dll 6.0.29415.0 108,368 1-Julho-2009 9:19 x86
Nc_tcps.dll 6.0.29415.0 153,408 1-Julho-2009 9:19 x86
Ndbcs.dll 6.0.29415.0 1,333,072 1-Julho-2009 9:19 x86
Slave.exe 6.0.29415.0 161,616 1-Julho-2009 9:19 x86

Para substituir os ficheiros existentes do Microsoft Dynamics NAV, siga estes passos:

  1. Feche o Cliente Microsoft Dynamics NAV.

  2. Localize o diretório de instalação microsoft Dynamics NAV Classic Client.

    Nota Normalmente, o Cliente Clássico do Microsoft Dynamics NAV é instalado no seguinte diretório:
    C:\Program Files\Microsoft Dynamics NAV\60\CSIDE Client\

  3. Copie os ficheiros que transferiu.

  4. Cole os ficheiros que transferiu para o diretório de instalação do Cliente Clássico do Microsoft Dynamics NAV.

  5. Na caixa
    Caixa de diálogo Confirmar Substituição de Ficheiro, clique em Sim para substituir os ficheiros no diretório de instalação.

Passo 2: Substituir os ficheiros de instalação do Cliente RoleTailored do Microsoft Dynamics NAV

Na instalação do Cliente RoleTailored do Microsoft Dynamics NAV, substitua os seguintes ficheiros com a correção ou o ficheiro de atualização.

Nome do arquivo Versão do arquivo Tamanho do arquivo Data Hora Plataforma
Dundaswinchart.dll 5.0.0.1692 2,733,904 1-Jul-2009 9:19 x86
Microsoft.dynamics.framework.patterns.dll 1.2.10579.173 71,648 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.dll 1.2.10579.173 654,280 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.mapping.dll 1.2.10579.173 101,336 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.navigation.dll 1.2.10579.173 22,496 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.ux2006.dll 1.2.10579.173 93,064 1-Jul-2009 9:08 x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll 1.2.10579.173 39,840 1-Jul-2009 9:08 x86
Microsoft.dynamics.framework.ui.windows.dll 1.2.10579.173 84,952 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.winforms.controls.dll 1.2.10579.173 2,067,440 30-Jun-2009 7:21 x86
Microsoft.dynamics.framework.ui.winforms.dll 1.2.10579.173 633,824 30-Jun-2009 7:21 x86
Microsoft.dynamics.nav.client.builder.dll 1.2.10579.173 166,792 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.exe 6.0.29415.0 142,200 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.interop.communicator.dll 6.0.29415.0 76,704 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.serviceconnection.dll 6.0.29415.0 76,704 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.ui.dll 6.0.29415.0 428,920 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.winforms.dll 6.0.29415.0 277,384 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.client.winforms.tlb 6.0.29415.0 2,652 1-Jul-2009 4:37 Não se aplica
Microsoft.dynamics.nav.language.dll Não se aplica 1,866,616 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.types.dll 6.0.29415.0 383,856 1-Jul-2009 9:08 x86
Microsoft.office.interop.outlook.dll 10.0.4504.0 396,152 1-Jul-2009 9:08 x86

Para substituir os arquivos existentes, siga estas etapas:

  1. Feche o cliente RoleTailored do Microsoft Dynamics NAV.
  2. Localize o diretório de instalação do Cliente RoleTailored do Microsoft Dynamics NAV. Normalmente, o Microsoft Dynamics NAV RoleTailored Client é instalado no seguinte diretório:
    Cliente C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored
  3. Copie os arquivos que você baixou.
  4. Cole os arquivos baixados no diretório de instalação do Cliente RoleTailored do Microsoft Dynamics NAV.
  5. Quando solicitado, clique em Sim para substituir os arquivos no diretório de instalação.

Etapa 3: substituir os arquivos de instalação do Microsoft Dynamics NAV Server

Na instalação do Microsoft Dynamics NAV Server, substitua os arquivos a seguir usando o hotfix ou o arquivo de atualização.

Nome do arquivo Versão do arquivo Tamanho do arquivo Data Hora Plataforma
Httpcfg.exe 5.2.3790.0 22,352 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.language.dll 6.0.29415.0 1,865,600 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.ncl.dll 6.0.29415.0 489,336 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.server.exe 6.0.29415.0 137,088 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.server.exe.config Não se aplica 211 17-Jun-2009 3:29 Não se aplica
Microsoft.dynamics.nav.service.dll 6.0.29415.0 120,704 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.service.runtime.dll 6.0.29415.0 63,376 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.service.webservices.dll 6.0.29415.0 128,920 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.types.dll 6.0.29415.0 382,840 1-Jul-2009 9:08 x86
Microsoft.dynamics.nav.watson.dll 6.0.29415.0 38,784 1-Jul-2009 9:08 x86
Nclcsrt.etx Não se aplica 87,279 1-Jul-2009 12:52 Não se aplica
Nclcsrt.stx Não se aplica 81,083 1-Jul-2009 12:52 Não se aplica
Nclcsrts.dll Não se aplica 1,394,512 1-Jul-2009 9:19 x86
Ndbcs.dll 6.0.29415.0 1,333,072 1-Jul-2009 9:19 x86

Para substituir os arquivos, siga estas etapas:

  1. Pare o serviço de servidor NAV do Microsoft Dynamics.

  2. Localize o diretório de instalação do serviço de servidor do Microsoft Dynamics NAV.

    Observação Normalmente, o serviço de servidor NAV do Microsoft Dynamics é instalado no seguinte diretório:

    C:\arquivos de programa\Microsoft Dynamics NAV\60\Service

  3. Copie os arquivos que você baixou.

  4. Cole os arquivos baixados no diretório de instalação do serviço de servidor do Microsoft Dynamics NAV.

  5. Clique em Sim para substituir os arquivos no diretório.

  6. Inicie o serviço de servidor NAV do Microsoft Dynamics.

Etapa 4: substituir arquivos de Files comuns

Na pasta Common Files, substitua os arquivos a seguir.

Nome do arquivo Versão do arquivo Tamanho do arquivo Data Hora Plataforma
Customization.xml Não se aplica 1,115 17-Jun-2009 3:24 Não se aplica
Msoutl.olb 11.0.5510.0 200,248 17-Jun-2009 3:24 Não se aplica

Para substituir os arquivos existentes, siga estas etapas:

  1. Localize o diretório common Files:

    C:\Program Files\Common Files\Microsoft Dynamics NAV\OLSync

  2. Copie os arquivos que você baixou.

  3. Cole os arquivos que você baixou no diretório common Files.

  4. Quando solicitado, clique em Sim para substituir os arquivos no diretório de instalação.

Etapa 5: substituir arquivos Windows\System32

Na pasta Windows\System32, substitua os arquivos a seguir.

Nome do arquivo Versão do arquivo Tamanho do arquivo Data Hora Plataforma
Cdo.dll 6.5.7940.0 775,480 1-Jul-2009 9:19 x86
Gapi32.dll 6.5.7940.0 71,488 1-Jul-2009 9:19 x86

Para substituir os arquivos existentes, siga estas etapas:

  1. Localize o diretório Windows\System32:

    C:\Windows\System32

  2. Copie os arquivos que você baixou.

  3. Cole os arquivos que você baixou no diretório common Files.

  4. Quando solicitado, clique em Sim para substituir os arquivos no diretório de instalação.

Pré-requisitos

Você deve ter um dos seguintes produtos instalados para aplicar este hotfix:

  • Microsoft Dynamics NAV 4.0 SP3 com hotfix KB 940718

  • Microsoft Dynamics NAV 2009

Informações sobre remoção

Você não pode remover esse hotfix.

Necessidade de reinicialização

Se for solicitado que você reinicie o computador, você deve reiniciar o computador depois de aplicar esse hotfix.

Status

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais informações

Para obter informações adicionais sobre a terminologia da atualização de segurança, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):

824684 Descrição da terminologia padrão usada para descrever atualizações de software da Microsoft