Artigos publicados rapidamente fornecem informações diretamente de dentro da organização de suporte da Microsoft. As informações contidas aqui são criadas em resposta a tópicos emergentes ou exclusivos ou destinam-se a complementar outras informações da Base de Dados de Conhecimento.
Este artigo se aplica ao Microsoft Dynamics NAV para todos os países e todas as localidades de idioma.
Sintomas
Depois de usar a função Obter Linhas de Remessa duas vezes para dividir uma fatura de vendas em duas linhas para um item muito rastreado no Microsoft Dynamics NAV, você postará a fatura de vendas. No entanto, você recebe a seguinte mensagem de erro:
Observação
A entrada de especificação de acompanhamento de nenhum número já existe.
O Número de Observação é um espaço reservado para o número de entrada de especificação de rastreamento real.
Esse problema ocorre nos seguintes produtos:
- Microsoft Dynamics NAV 2009
- Microsoft Dynamics NAV 2009 Service Pack 1 (SP1)
- Microsoft Dynamics NAV 5.0 SP1
- Microsoft Dynamics NAV 5,0
Causa
Esse problema ocorre porque duas linhas de especificação de acompanhamento de item com o mesmo número de entrada são inseridas durante a postagem da fatura de vendas.
Resolução
Informações sobre o hotfix
Um hotfix com suporte agora está disponível na Microsoft. No entanto, ele destina-se apenas a corrigir o problema descrito neste artigo. Aplique-o somente a sistemas que estão enfrentando esse problema específico. Esse hotfix pode receber testes adicionais. Portanto, se você não for severamente afetado por esse problema, é recomendável aguardar o próximo service pack do Microsoft Dynamics NAV ou a próxima versão que contém esse hotfix.
Observação Em casos especiais, os encargos que normalmente são incorridos para chamadas de suporte podem ser cancelados se um profissional de suporte técnico do Microsoft Dynamics e produtos relacionados determinar que uma atualização específica resolve seu problema. Os custos de suporte em geral aplicam-se a questões e problemas de suporte adicionais que não se enquadrem na atualização específica em questão.
Informações de instalação
A Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita. Isso inclui, mas não se limita a, as garantias implícitas de comercialização ou adequação a uma finalidade específica. Este artigo pressupõe que você esteja familiarizado com a linguagem de programação que está sendo demonstrada e com as ferramentas usadas para criar e depurar procedimentos. Os engenheiros de suporte da Microsoft podem ajudá-lo, fornecendo a explicação da funcionalidade de determinado procedimento, mas não modificarão estes exemplos para fornecer funcionalidade adicional nem criarão procedimentos específicos para atender às suas necessidades específicas.
Observação Antes de instalar esse hotfix, verifique se todos os usuários cliente do Microsoft Navision estão conectados ao sistema. Isso inclui usuários cliente do NAS (Microsoft Navision Application Services). Você deve ser o único usuário cliente que está conectado ao implementar esse hotfix.
Para implementar esse hotfix, você deve ter uma licença de desenvolvedor.
Recomendamos que a conta de usuário na janela Logons do Windows ou na janela Logons de Banco de Dados seja atribuída à ID da função "SUPER". Se a conta de usuário não puder ser atribuída à ID da função "SUPER", você deverá verificar se a conta de usuário tem as seguintes permissões:
- A permissão Modificar para o objeto que você estará alterando.
- A permissão Executar para o objeto System Object ID 5210 e para o objeto System Object ID 9015.
Observação Você não precisa ter direitos para os armazenamentos de dados, a menos que precise executar o reparo de dados.
Alterações de código
Observação Sempre teste correções de código em um ambiente controlado antes de aplicar as correções aos computadores de produção.
Para instalar esse hotfix, altere o código na função SaveInvoiceSpecification no Sales-Post codeunit (80) da seguinte maneira:
Código existente
TempInvoicingSpecification."Quantity Invoiced (Base)" += TempInvoicingSpecification."Qty. to Invoice (Base)";
TempTrackingSpecification := TempInvoicingSpecification;
TempTrackingSpecification."Buffer Status" := TempTrackingSpecification."Buffer Status"::MODIFY;
// Delete the following line.
TempTrackingSpecification.INSERT;
UNTIL TempInvoicingSpecification.NEXT = 0;
TempInvoicingSpecification.DELETEALL;
END;
Código de substituição
TempInvoicingSpecification."Quantity Invoiced (Base)" += TempInvoicingSpecification."Qty. to Invoice (Base)";
TempTrackingSpecification := TempInvoicingSpecification;
TempTrackingSpecification."Buffer Status" := TempTrackingSpecification."Buffer Status"::MODIFY;
// Add the following lines.
IF NOT TempTrackingSpecification.INSERT THEN BEGIN
TempTrackingSpecification.GET(TempInvoicingSpecification."Entry No.");
TempTrackingSpecification."Qty. to Invoice (Base)" += TempInvoicingSpecification."Qty. to Invoice (Base)";
IF TempInvoicingSpecification."Qty. to Invoice (Base)" = TempInvoicingSpecification."Quantity Invoiced (Base)" THEN
TempTrackingSpecification."Quantity Invoiced (Base)" += TempInvoicingSpecification."Quantity Invoiced (Base)"
ELSE
TempTrackingSpecification."Quantity Invoiced (Base)" += TempInvoicingSpecification."Qty. to Invoice (Base)";
TempTrackingSpecification."Qty. to Invoice" += TempInvoicingSpecification."Qty. to Invoice";
TempTrackingSpecification.MODIFY;
END;
// The end of the lines.
UNTIL TempInvoicingSpecification.NEXT = 0;
TempInvoicingSpecification.DELETEALL;
END;
Pré-requisitos
Você deve ter um dos seguintes produtos instalados para aplicar este hotfix:
- Microsoft Dynamics NAV 2009
- Microsoft Dynamics NAV 2009 SP1
- Microsoft Dynamics NAV 5.0 SP1
- Microsoft Dynamics NAV 5,0
Informações sobre remoção
Você não pode remover esse hotfix.
Mais informações
Para obter mais informações sobre o mesmo problema no lado da compra no Microsoft Dynamics NAV 4.0, clique no número do artigo a seguir para exibir o artigo na Base de Dados de Conhecimento da Microsoft:
934145 Mensagem de erro ao postar uma fatura que tem muito número no Microsoft Dynamics NAV 4.0: "Acompanhamento da entrada de especificação nº. ' [Número]' já existe"
Status
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".
A MICROSOFT E/OU SEUS FORNECEDORES NÃO FAZEM REPRESENTAÇÕES OU GARANTIAS SOBRE A ADEQUAÇÃO, A CONFIABILIDADE OU A PRECISÃO DAS INFORMAÇÕES CONTIDAS NOS DOCUMENTOS E NOS GRÁFICOS RELACIONADOS PUBLICADOS NESTE SITE (OS "MATERIAIS") PARA QUALQUER FINALIDADE.
O MATERIAL PODE INCLUIR IMPRECISÕES TÉCNICAS OU ERROS TIPOGRÁFICOS E PODE SER REVISADO A QUALQUER MOMENTO SEM AVISO PRÉVIO. NA MEDIDA MÁXIMA PERMITIDA PELA LEI APLICÁVEL, A MICROSOFT E/OU SEUS FORNECEDORES SE ISOLAM E EXCLUEM TODAS AS REPRESENTAÇÕES, GARANTIAS E CONDIÇÕES EXPRESSAS, IMPLÍCITAS OU ESTATUTÁRIAS, INCLUINDO, MAS NÃO SE LIMITANDO A REPRESENTAÇÕES, GARANTIAS OU CONDIÇÕES DE TÍTULO, NÃO VIOLAÇÃO, CONDIÇÃO OU QUALIDADE SATISFATÓRIAS, COMERCIALIZABILIDADE E APTIDÃO PARA UMA FINALIDADE ESPECÍFICA, COM RELAÇÃO AOS MATERIAIS.