KB3197758 - CORREÇÃO: Erro de tempo limite ao processar várias partições em paralelo no SQL Server 2016 Analysis Services (modelo Tabular)

Aplica-se a
SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use)

Sintomas

Suponha que você use uma instância do Microsoft SQL Server 2016 Analysis Services (modelo Tabular). Quando você processa várias partições de uma tabela em paralelo, o Analysis Services pode falhar. Além disso, a operação de processamento pode falhar com um erro de tempo limite.

Causa

Esse problema ocorre porque o número de operações de processamento de partição pode exceder a configuração MaxActiveConnections no objeto Datasource.

Observação Por padrão, MaxActiveConnections é igual a 10.

Resolução

Informações sobre a atualização cumulativa

A correção para esse problema está incluída na seguinte atualização cumulativa para o SQL Server:

Sobre atualizações cumulativas para o SQL Server

Cada nova atualização cumulativa do SQL Server contém todos os hotfixes e todas as correções de segurança incluídas na atualização cumulativa anterior. Confira as atualizações cumulativas mais recentes para o SQL Server:

Atualização cumulativa mais recente do SQL Server 2016
      

      

Solução alternativa

Como solução alternativa para esse problema, use os seguintes métodos:

  • Reduza o paralelismo do processamento.
  • Aumente o número máximo de conexões ativas com a fonte de dados.

Status

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Referências

Saiba mais sobre a terminologia que a Microsoft usa para descrever atualizações de software.