Sintomas
Suponha que você use um AG (grupo de disponibilidade) Always On que contenha tabelas de heap. A partir do SQL Server 2016, o thread paralelo para operações de refazer é usado em réplicas secundárias. Nesse caso, a operação de refazer tabelas de heap pode gerar um despejo de declaração de runtime ou o SQL Server pode falhar com um erro de violação de acesso em alguns casos.
Causa
Esse problema ocorre depois que você aplica a atualização cumulativa mencionada no artigo a seguir:
4018866 CORREÇÃO: O refazer paralelo causa alto uso de memória no SQL Server 2016 quando comparado ao SQL Server 2014 ou versões anteriores
Resolução
Esse problema é corrigido nas seguintes atualizações cumulativas para o SQL Server:
Atualização cumulativa 9 para o SQL Server 2016 SP1
Atualização cumulativa 1 para o SQL Server 2016 SP2
Atualização cumulativa 38 para o SQL Server 2017 (Build 50785)
Sobre atualizações cumulativas para o SQL Server
Cada nova atualização cumulativa do SQL Server contém todos os hotfixes e correções de segurança que estavam no build anterior. Confira a atualização cumulativa mais recente do SQL Server:
Atualização cumulativa mais recente do SQL Server 2016
Atualização cumulativa mais recente do SQL Server 2017
Solução alternativa
Para contornar esse problema, desabilite a refazer paralela habilitando o sinalizador de rastreamento 3459.
Status
A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".
Referências
Saiba mais sobre a terminologia padrão que a Microsoft usa para descrever atualizações de software.