KB4530468 - CORREÇÃO: as consultas do PolyBase Hadoop podem falhar quando o serviço launchpadd for reiniciado ou encerrado no SQL Server 2019

Aplica-se a
SQL Server 2019 on Linux

Sintomas

Suponha que você use o PolyBase para executar consultas no Hadoop no SQL Server 2019. Você pode observar que as consultas não respondem ou receber uma mensagem de erro semelhante a "A ponte Java remota ainda não foi anexada" quando o serviço launchpadd é reiniciado ou encerrado.

Observação O problema existe apenas no SQL Server para Linux e no Cluster de Big Data.

Causa

Esse problema pode ocorrer porque o processo da ponte Hadoop Remota não foi fechado corretamente.

Status

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Resolução

Esse problema é corrigido na seguinte atualização cumulativa para o SQL Server:

Sobre atualizações cumulativas para o SQL Server:
      

Cada nova atualização cumulativa do SQL Server contém todos os hotfixes e todas as correções de segurança incluídas na atualização cumulativa anterior. Confira as atualizações cumulativas mais recentes para o SQL Server:

Mais informações

Saiba mais sobre a terminologia que a Microsoft usa para descrever atualizações de software.