Resumo
Este artigo explica como usar o recurso Mala Direta no Microsoft Word para criar e imprimir cartas modelo usando dados de uma planilha do Microsoft Excel.
Quando você usa o recurso Mala Direta do Word, o Word mescla um documento principal com uma lista de destinatários para gerar um conjunto de documentos de saída:
O documento principal contém o texto básico que é o mesmo em todos os documentos de saída. Ele pode conter um papel timbrado, texto e instruções em campos de mesclagem para inserção de texto (como nomes de destinatários e endereços) que variam de um documento de saída para outro.
A lista de destinatários é um banco de dados que contém os dados que devem ser mesclados nos documentos de saída. Por exemplo, a lista de destinatários é um arquivo de banco de dados do Microsoft Access ou uma planilha do Excel.
Esse banco de dados normalmente é uma lista de nomes, endereços, números de telefone e outras categorias de informações pessoais.
Os documentos de saída são o resultado da mala direta. O texto em um documento de saída pode ser o mesmo em todos os documentos de saída, mas você pode aplicar formatação a documentos específicos.
Etapa 1: Configurar o arquivo de dados do Excel
Antes de prosseguir com o Assistente de Mala Direta, verifique se a planilha do Excel está bem estruturada para essa finalidade. Observe os seguintes requisitos para a tabela de dados:
- A primeira linha deve conter nomes de campo para cada coluna -- por exemplo, Título, Saudação, Nome, Nome do Meio, Sobrenome, Endereço1 e Endereço2.
- Cada nome de campo deve ser exclusivo.
- Cada linha deve fornecer informações sobre um item específico. Por exemplo, em uma lista de endereçamento, cada linha pode incluir informações sobre um destinatário específico.
- A tabela não deve conter linhas em branco.
Crie seu arquivo de dados do Excel e organize-o usando os campos que você deseja usar para sua carta, conforme mostrado no arquivo de dados de exemplo a seguir.
Depois de criar o arquivo de dados do Excel, salve-o e feche o arquivo de dados.
Para obter mais informações sobre como criar uma lista de endereços de mala direta, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
294688 Como criar e configurar uma lista de endereços de mala direta no Word 2002 e em versões posteriores do Word
Etapa 2: Configurar o documento principal
No Microsoft Office Word 2003 e em versões anteriores do Word, aponte para Cartas e Correspondências no menu Ferramentas e clique em Assistente de Mala Direta.
No Microsoft Office Word 2007, clique em Iniciar Mala Direta no grupo Iniciar Mala Direta na guia Correspondências e clique em Assistente de Mala Direta Passo a Passo.
Em Selecionar tipo de documento, clique em Cartas.
O documento ativo torna-se o documento principal. O documento principal contém o texto e os gráficos que são iguais para cada versão do documento mesclado. Por exemplo, o endereço do remetente e a saudação em uma carta modelo são os mesmos para cada versão.
Clique em Avançar: Iniciando o documento.
Use um dos seguintes métodos:
Comece com o documento mostrado atualmente na janela do documento. Para fazer isso, clique em Usar o documento atual.
Em seguida, você pode digitar a letra na janela do documento ou aguardar até que o assistente solicite que você faça isso em uma etapa posterior.
Comece com um modelo. Para fazer isso, siga estas etapas:
Clique em Iniciar a partir de um modelo.
Clique em Selecionar modelo.
Na guia Mala Direta, selecione o modelo desejado na caixa de diálogo Selecionar Modelo e clique em OK.
Comece com um documento existente. Para fazer isso, siga estas etapas:
- Clique em Iniciar do documento existente.
- Na caixa Iniciar a partir de existente , selecione o documento desejado e clique em Abrir.
- Se você não vir o documento, clique em Mais arquivos e em Abrir. Na caixa de diálogo Abrir, localize o documento desejado e clique em Abrir.
Clique em Avançar: Selecione os destinatários.
Etapa 3: Especificar a fonte de dados do Excel
Em Selecionar destinatários, clique em Usar uma lista existente.
Clique em Procurar.
Na caixa de diálogo Selecionar Fonte de Dados , localize e clique na planilha do Excel que você deseja usar.
Por padrão, o Word abre a pasta "Minhas Fontes de Dados".
Clique em Abrir.
Se a planilha do Excel contiver informações sobre várias guias, selecione a guia que contém as informações desejadas e clique em OK.
Todas as entradas na fonte de dados são exibidas na caixa de diálogo Destinatários da Mala Direta. Aqui, você pode refinar a lista de destinatários a serem incluídos na mesclagem.
Etapa 4: selecionar os destinatários
Na caixa de diálogo Destinatários da Mala Direta, selecione os destinatários que você deseja incluir. Para fazer isso, utilize um dos métodos seguintes:
Use as caixas de marca para designar destinatários.
Este método é mais útil quando a lista é pequena. Clique para marcar as caixas de seleção ao lado dos destinatários que você deseja incluir e, em seguida, clique para desmarcar as caixas de marcação ao lado dos destinatários que você deseja excluir.
Observação Se você souber que deseja incluir a maior parte da lista em sua mesclagem, clique em Selecionar Tudo e clique para limpar registros específicos. Da mesma forma, se você quiser incluir apenas alguns registros na lista, clique em Limpar Tudo e selecione os registros desejados.
Classificar itens na lista.
Esse método é útil se você quiser ver os itens em ordem alfabética ou numérica. Clique no título da coluna do elemento pelo qual você deseja classificar. Por exemplo, se quiser exibir a lista em ordem alfabética pelo sobrenome, clique no título da coluna Sobrenome.
Filtrar itens na lista.
Esse método será útil se a lista contiver registros que você sabe que não deseja ver ou incluir na mesclagem. Depois de filtrar a lista, você pode usar as caixas de marca para incluir e excluir registros, conforme descrito anteriormente. Para filtrar a lista, siga estas etapas:
Clique na seta ao lado do título da coluna do elemento pelo qual você deseja filtrar.
Clique em qualquer uma das seguintes opções:
- (Blanks): Esta opção exibe todos os registros em que o campo correspondente está em branco.
- (Nonblanks): Esta opção exibe todos os registros nos quais o campo correspondente contém informações.
- Se a fonte de dados contiver registros que compartilham as mesmas informações e se houver 10 ou menos valores exclusivos na coluna, você poderá filtrar por informações específicas. Por exemplo, se houver vários endereços que listam a Austrália como o país, você poderá filtrar por Austrália.
A caixa de diálogo Destinatários da Mala Direta exibe somente os registros designados. Para exibir todos os registros novamente, clique em (Todos).
Anotações
- Para classificação e filtragem avançadas, clique na seta ao lado de qualquer nome de coluna e clique em (Avançado). Use as guias Filtrar Registros e Classificar Registros para configurar a consulta de classificação ou filtragem desejada.
- Se você tiver instalado o software de validação de endereço, clique em Validar na caixa de diálogo Destinatários da Mala Direta para validar os endereços dos destinatários.
Clique em OK para retornar ao Assistente de Mala Direta.
O Word usa os destinatários que você designou para a mala direta.
Clique em Avançar: Escreva sua carta.
Etapa 5: Preencher a carta e adicionar campos de mesclagem
Se você ainda não tiver feito isso, digite o texto que deseja que apareça em cada carta modelo no documento principal.
Inserir campos de mesclagem
Insira os campos de mesclagem nos quais você deseja mesclar nomes, endereços e outras informações da fonte de dados. Para inserir campos de mesclagem, siga estas etapas:
No documento principal, clique no local em que deseja inserir o campo.
Insira uma das seguintes opções:
Bloco de endereços com nome, endereço e outras informações:
Clique em Bloco de Endereço.
Na caixa de diálogo Inserir Bloco de Endereço, selecione os elementos do endereço que deseja incluir, os formatos desejados e clique em OK. Para obter ajuda sobre uma opção, clique no ponto de interrogação e, em seguida, clique na opção.
Para obter ajuda sobre uma opção, clique no ponto de interrogação e, em seguida, clique na opção. Se a caixa de diálogo Coincidir Campos for exibida, o Word talvez não consiga encontrar algumas das informações necessárias para o bloco de endereço. Clique na seta ao lado de
(não disponível) e, em seguida, selecione o campo da sua fonte de dados que corresponde ao campo obrigatório para a mala direta.
Linha de saudação:
Clique em Linha de saudação.
Selecione o formato de linha de saudação que inclui a saudação, o formato do nome e a pontuação seguinte.
Selecione o texto que deseja exibir nos casos em que o Word não consegue interpretar o nome do destinatário. Por exemplo, o Word não pode interpretar o nome quando a fonte de dados não contém nome ou sobrenome de um destinatário, mas apenas o nome de uma empresa.
Clique em OK.
Se a caixa de diálogo Coincidir Campos for exibida, o Word talvez não consiga encontrar algumas das informações necessárias para a linha de saudação. Clique na seta ao lado de (não disponível) e selecione o campo da fonte de dados que corresponde ao campo obrigatório para a mala direta.
Outros campos de informação:
Clique em Mais itens.
Use um dos seguintes métodos:
- Clique em Campos de Endereço para selecionar campos de endereço que serão mapeados automaticamente para campos correspondentes em sua fonte de dados, mesmo que os campos da fonte de dados não tenham o mesmo nome que seus campos.
- Clique em Campos do Banco de Dados para selecionar nos campos que sempre obtêm dados diretamente de uma coluna em um banco de dados.
Na caixa Campos, clique no campo desejado.
Clique em Inserir e depois em Fechar.
Se a caixa de diálogo Coincidir Campos for exibida, o Word talvez não consiga encontrar algumas das informações necessárias para inserir o campo. Clique na seta ao lado de (não disponível) e selecione o campo da fonte de dados que corresponde ao campo obrigatório para a mala direta.
Observação Se você inserir um campo da lista Campos do Banco de Dados e, posteriormente, mudar para uma fonte de dados que não tenha uma coluna com o mesmo nome, o Word não poderá inserir essas informações de campo no documento mesclado.
Postagem eletrônica:
Para adicionar postagem eletrônica, primeiro você deve instalar um programa de postagem eletrônica, como um que você pode comprar de um provedor terceirizado na Web. Para usar a postagem eletrônica, siga estas etapas:
Clique em Postagem eletrônica.
Se você não tiver um programa de postagem eletrônica instalado, o Word solicitará que você instale um e oferecerá a conexão ao seguinte site do Microsoft Office:
Imprimir Postagem Online
http://office.microsoft.com/services/service.aspx?sid=2.4Insira a postagem de acordo com as instruções do programa.
Para adicionar postagem eletrônica, primeiro você deve instalar um programa de postagem eletrônica, como um que você pode comprar de um provedor terceirizado na Web. Para usar a postagem eletrônica, siga estas etapas:Código de barras postal: Você deve selecionar um tipo de carta ou envelope que suporte o código de barras POSTNET. Para usar o código de barras CEP, siga estas etapas:
Clique em Código de Barras.
Na caixa de diálogo Inserir Código de Barras Postal , selecione os campos de endereço apropriados.
Observação A opção Código de Barras Postal será exibida somente se você estiver usando a versão do Word para os EUA.
Repita as etapas a e b para todos os campos que você deseja inserir. OBSERVAÇÕES:
- Você não pode digitar caracteres de campo de mesclagem (" ") ou inseri-los usando o comando Símbolo no menu Inserir.
- Se os campos de mesclagem aparecerem entre chaves, como { MERGEFIELD City }, o Word está exibindo códigos de campo em vez de resultados de campo. Isso não afeta a mesclagem, mas se você quiser exibir os resultados, clique com o botão direito do mouse no código de campo e clique em Alternar Códigos de Campo no menu de atalho.
Por exemplo, usando o banco de dados de exemplo mostrado anteriormente, sua carta pode conter os campos AddressBlock e GreetingLine e, portanto, sua primeira página parece semelhante à seguinte:
26 de fevereiro de 2002AddressBlock
GreetingLine
Digite sua carta aqui.
Atenciosamente,
Digite seu nome aqui
Observação Você também pode usar a barra de ferramentas Mala Direta para inserir campos de mala direta, trabalhar com o documento principal da mala direta ou executar uma mala direta. Para exibir a barra de ferramentas Mala Direta, aponte para Cartas e Correspondências no menu Ferramentas e clique em Mostrar Barra de Ferramentas de Mala Direta.
A barra de ferramentas Mala Direta fornece comandos adicionais que não estão incluídos nos painéis de tarefas do Assistente de Mala Direta. Por exemplo, você pode usar o menu Inserir Campo do Word na barra de ferramentas Mala Direta para inserir campos do Word para controlar o processo de mala direta. Por exemplo, você pode inserir um campo SE que insere texto somente se um determinado campo de mesclagem tiver um valor especificado.
Como alternativa, você pode clicar em Verificar Erros para que o Word execute a mala direta e relate quaisquer erros contidos no documento principal.
Alterar o formato dos dados mesclados
Para formatar os dados mesclados, você deve formatar os campos de mesclagem no documento principal. Não formate os dados na fonte de dados, pois a formatação não é mantida quando você mescla os dados no documento. Para alterar o formato dos dados mesclados, siga estas etapas:
No documento principal, selecione o campo que contém as informações que você deseja formatar, incluindo os caracteres do campo de mesclagem delimitador (<<>>).
No Word 2003 e em versões anteriores do Word, clique em Fonte no menu Formatar e selecione as opções desejadas.
No Word 2007, clique na opção desejada na caixa Fontes do Tema no grupo Fonte da guia Página Inicial.
Formatar usando códigos de campo
Para controlar outros aspectos da formatação, pressione ALT+F9 para exibir códigos de campo e adicione opções aos campos de mesclagem. Quando você trabalha com campos, uma opção é uma instrução especial que faz com que uma ação específica ocorra. Geralmente, uma opção é adicionada a um campo para modificar um resultado.
Veja a seguir exemplos de como usar comutadores:
- Para exibir o número 34987,89 como US$ 34.987,89, adicione a opção Imagem Numérica (\#).
- Para imprimir nomes de clientes em letras maiúsculas, adicione a opção Formato (\*).
- Para garantir que as informações mescladas tenham a mesma fonte e tamanho de ponto que você aplica ao campo de mesclagem, adicione a opção Charformat (\*).
Etapa 6: Salvar o documento
Depois de concluir o documento principal e inserir todos os campos de mesclagem, salve o documento antes de continuar. Para fazer isso, siga estas etapas:
No Word 2003 e em versões anteriores do Word, clique em Salvar como no menu Arquivo.
No Word 2007, clique no Botão do Microsoft Office e em Salvar Como.
Nomeie o documento e clique em Salvar.
Clique em Avançar: Visualizar suas cartas.
Passo 7: Visualize as cartas e Fine-Tune a lista de destinatários
Quando o assistente exibe o painel de tarefas "Etapa 5: Mala Direta", o assistente substitui cada um dos campos de mesclagem no documento principal que contém o texto real da primeira entrada da lista de destinatários. Portanto, você pode ver como será a aparência do seu primeiro documento de saída.
Por exemplo, se você continuar a usar o banco de dados de exemplo mostrado anteriormente, a primeira página deverá ser semelhante à página seguinte depois que você clicar em Avançar: Visualize suas cartas:
26 de fevereiro de 2002
Andrew Fuller
908 W. Capital Way
Tacoma 98401
Caro Andrew Fuller,
Digite sua carta aqui.
Atenciosamente,
Digite seu nome aqui Para visualizar entradas adicionais, use um dos seguintes métodos:
- Para visualizar os itens em ordem, clique nos botões de seta para a esquerda ou para a direita.
- Para localizar e visualizar um item específico, clique em Localizar um destinatário e insira os critérios de pesquisa na caixa de diálogo Localizar Entrada.
Ajuste a lista de destinatários, se desejar. Para fazer isso, utilize um dos métodos seguintes:
- Para excluir um destinatário específico da operação de mesclagem, clique em Excluir este destinatário.
- Para alterar a lista de destinatários, clique em Editar lista de destinatários e faça as alterações na caixa de diálogo Destinatários da Mala Direta .
Etapa 8: concluir a mesclagem
Para concluir a mesclagem, use qualquer um dos seguintes métodos.
Personalizar cartas individuais
Para personalizar itens individuais, você realmente conclui a mesclagem e, em seguida, edita as informações desejadas no documento mesclado resultante. Para fazer isso, siga estas etapas:
Clique em Editar letras individuais.
Na caixa de diálogo Mesclar para Novo Documento , selecione os registros que deseja mesclar.
Clique em OK.
O Word cria e abre um novo documento mesclado. O documento principal também permanece aberto e você pode voltar a ele se quiser alterar todos os documentos.
Role até as informações que deseja editar e faça as alterações.
Imprima ou salve o documento da mesma forma que faria com qualquer documento normal.
Imprimir as cartas
Para imprimir as cartas, use um dos seguintes métodos:
Se você personalizou os itens e se o documento mesclado está ativo, siga estas etapas:
No Word 2003 e em versões anteriores do Word, clique em Imprimir no menu Arquivo.
No Word 2007, clique no Botão do Microsoft Office e em Imprimir.
Selecione as opções desejadas.
Se você deseja imprimir diretamente do Assistente de Mala Direta, siga estas etapas:
Na Etapa 6 do Assistente de Mala Direta (Concluir a mesclagem), clique em Imprimir.
Na caixa de diálogo Mesclar para Impressora , use um dos seguintes métodos e clique em OK:
- Para imprimir todos os documentos, clique em Todos.
- Para imprimir o documento que você vê na janela do documento, clique em Registro atual.
- Para imprimir um intervalo de documentos, clique em De e digite os números dos registros nas caixas De e Para.
Na caixa de diálogo Imprimir, selecione as opções desejadas.
Salvar as letras mescladas para uso posterior
Se você deseja editar letras mescladas ou salvá-las para uso posterior, é possível coletá-las em um único documento. Para fazer isso, siga estas etapas:
Clique em Editar letras individuais.
Na caixa de diálogo Mesclar em um Novo Documento , use um dos seguintes métodos e clique em OK:
- Para mesclar todos os documentos, clique em Todos.
- Para mesclar apenas o documento que você vê na janela do documento, clique em Registro atual.
- Para mesclar um intervalo de documentos, clique em De e digite os números dos registros nas caixas De e Para.
O Word abre um único novo documento que contém todas as letras individuais. Em seguida, você pode salvá-lo para usá-lo posteriormente, como faria com qualquer documento normal.
Referências
Para obter mais informações, clique nos seguintes números de artigos para ler o conteúdo na Base de Dados de Conhecimento Microsoft:
318117 Como usar endereços de uma planilha do Excel para criar etiquetas no Word
318115 Como criar uma carta modelo usando informações de um banco de dados do Access no Word 2002
318112 Como usar endereços de um banco de dados do Access 2002 para criar rótulos no Word 2002
294686 Como usar a mala direta para criar uma lista classificada por categoria no Word 2002 e em versões posteriores do Word
290408 Perguntas freqüentes sobre mala direta no Word 2002
294688 Como criar e configurar uma lista de endereços de mala direta no Word 2002 e em versões posteriores do Word
294693 Como usar a mala direta para criar um diretório no Word 2002 e em versões posteriores do Word
294683 Como usar a mala direta para criar cartas modelo no Word 2002 e em versões posteriores do Word