Sintoma
Registros mostrados para algumas entidades, mas não para outras no resultado da busca.
Por exemplo, a entidade Filas é esperada aqui, mas está ausente.
Causa
Três causas possíveis
-
A entidade não está habilitada para UCI (Cliente Móvel)
-
A entidade não é adicionada ao aplicativo UCI.
-
Para pesquisa de várias entidades, se a entidade não for adicionada ao aplicativo, o controle de pesquisa não recuperará os metadados para ela e, portanto, não mostrará a guia ou o registro de pesquisa nele)
-
Problema comum para a pesquisa de Proprietários que mostra Usuários e Equipes. O Teams não aparece porque o usuário não o adicionou ao aplicativo.
-
-
Isso não importa para o controle de busca de entidade única, pois os registros devem aparecer independentemente de a entidade ter sido adicionada ao aplicativo UCI.
-
-
Se a entidade for uma nova entidade personalizada e não for exibida em Relação à Pesquisa, talvez seja porque ela não está configurada como uma das atividades.
Mitigação
Solução para cada causa
-
Habilitar a entidade. Essa configuração está no designer de entidades. Algumas entidades principais, como ConnectionRole, não são configuráveis pelo usuário e não têm suporte no UCI, portanto, não são editáveis por design.
-
Adicione a entidade ao aplicativo UCI.
Por exemplo, Adicionar a entidade Equipe ao aplicativo UCI
-
Certifique-se de que a caixa "Atividade" está marcada para que essa entidade seja uma das atividades em Relação à Pesquisa.