Aplicável a:

Microsoft .NET Framework 4.6.2 Microsoft .NET Framework 4.7 Microsoft .NET Framework 4.7.1 Microsoft .NET Framework 4.7.2

LEMBRETE O Windows 7, Windows Server 2008 R2, Windows Embedded Standard 7 e o Windows Embedded POS Ready 7 chegaram ao fim do suporte base e agora estão com suporte de segurança estendido (ESU). O Windows Thin PC atingiu o fim do suporte base; no entanto, o suporte da ESU não está disponível. 

A partir de julho de 2020, não haverá mais lançamentos opcionais não relacionados à segurança (conhecidos como lançamentos "C") para este sistema operacional. Os sistemas operacionais em suporte estendido têm apenas atualizações de segurança mensais cumulativas (conhecidas como a lançamento "B" ou Atualização de terça-feira).

Verifique se você instalou as atualizações necessárias listadas na seção Como obter esta atualização antes de instalar esta atualização. 

Clientes que compraram a Atualização de segurança estendida (ESU) para as versões locais desses sistemas operacionais deverão seguir os procedimentos na KB4522133 para continuar recebendo atualizações de segurança após o término do suporte estendido em 14 de janeiro de 2020. Para obter mais informações sobre a ESU e quais edições têm suporte, consulte KB4497181.

Como a ESU está disponível como um SKU separado para cada um dos anos em que eles são oferecidos (2020, 2021 e 2022) - e como a ESU só pode ser comprada em períodos específicos de 12 meses - você deve comprar o terceiro ano de cobertura da ESU separadamente e ativar uma nova chave em cada dispositivo aplicável para que seus dispositivos continuem recebendo atualizações de segurança em 2022.

Se sua organização não comprou o terceiro ano de cobertura da ESU, você deve comprar a ESU do Ano 1, do Ano 2 e do Ano 3 para seus dispositivos Windows 7 SP1 ou Windows Server 2008 R2 SP1 aplicáveis antes de instalar e ativar as chaves MAK do Ano 3 para receber atualizações. As etapas para instalar, ativar e implantar ESUs são as mesmas para a cobertura de primeiro, segundo e terceiro ano. Para obter mais informações, consulte Obtendo Atualizações de Segurança Estendidas para dispositivos Windows elegíveis para o processo de Licenciamento por Volume e Comprando ESUs do Windows 7 como um Provedor de Soluções em Nuvem para o processo CSP. Para dispositivos inseridos, entre em contato com o fabricante do equipamento original (OEM).

Para obter mais informações, consulte o blog da ESU.

LEMBRETE A partir de agosto de agosto de 2019, as atualizações do .NET Framework 4.6 e superior, para Windows Server 2008 SP1, Windows Server 2008 R2 SP1 e Windows 7 SP1, exigem suporte à assinatura de código SHA-2. Verifique se você possui todas as atualizações mais recentes do Windows antes de aplicar esta atualização para evitar problemas de instalação. Para obter informações mais detalhadas sobre as atualizações de suporte de assinatura de código SHA-2, consulte a KB 4474419.

LEMBRETE Todas as atualizações para o .NET Framework 4.7.2, 4.7.1, 4.7, 4.6.2, 4.6.1 e 4.6 exigem que a atualização d3dcompiler_47.dll seja instalada. Recomendamos que você instale a atualização d3dcompiler_47.dll incluída antes de aplicar esta atualização. Para obter mais informações sobre d3dcompiler_47.dll, consulte KB 4019990.

Se você instalar um pacote de idiomas depois de instalar esta atualização, será necessário reinstalar a atualização. Portanto, recomendamos que você instale qualquer pacote de idiomas necessário antes de instalar esta atualização. Para obter mais informações, consulte Adicionar pacotes de idiomas ao Windows.

Resumo

Essa atualização de segurança aborda uma vulnerabilidade existente nas bibliotecas System.Data.SqlClient e Microsoft.Data.SqlClient, em que um tempo limite que ocorre sob carga alta pode fazer com que dados incorretos sejam retornados como resultado de uma consulta ou comando executado de forma assíncrona. Para obter mais informações, consulte CVE-2022-41064.

Informações adicionais sobre esta atualização

Os artigos a seguir contêm informações adicionais sobre esta atualização para versões de produto individuais.

  • 5020681 Descrição da Atualização Somente de Segurança do .NET Framework 4.6.2 para Windows Server 2008 SP2 (KB5020681)

  • 5020678 Descrição da Atualização Somente de Segurança do .NET Framework 4.6.2, 4.7, 4.7.1, 4.7.2, 4.8 para Windows 7 SP1 e Windows Server 2008 R2 SP1 (KB5020678)

Problemas conhecidos nesta atualização

No momento, a Microsoft não está ciente de problemas nesta atualização.

Como obter e instalar a atualização

Antes de instalar esta atualização

Pré-requisito:

Para aplicar essa atualização, você deve ter o .NET Framework 4.6.2, 4.7, 4.7.1, 4.7.2 instalado.

Instale esta atualização

Canal de lançamento

Disponível

Próxima etapa

Catálogo do Microsoft Update

Sim

Para obter o pacote autônomo dessa atualização, acesse o site do Catálogo do Microsoft Update.

WSUS (Windows Server Update Services)

Sim

Esta atualização será automaticamente sincronizada com o WSUS se você configurar Produtos e Classificações da seguinte maneira:

Produto:Windows 7 SP1 e Windows Server 2008 R2 SP1 e Windows Server 2008 SP2

Classificação: Atualizações de Segurança

Necessidade de reinicialização

Você precisará reiniciar o computador após instalar esta atualização se qualquer arquivo afetado estiver sendo usado. Recomendamos sair de todos os aplicativos baseados no .NET Framework antes de aplicar essa atualização.

Informações da implantação de atualizações

Para obter detalhes de implantação sobre esta atualização de segurança, acesse o seguinte artigo na Base de Dados de Conhecimento Microsoft:

20221108 Informações de implantação da atualização de segurança: 8 de novembro de 2022

Informações sobre a remoção da atualização

Observação Não é recomendável remover as atualizações de segurança. Para remover esta atualização, use o item Programas e Recursos no Painel de Controle.

Atualizar as informações de reinício

Esta atualização não requer uma reinicialização do sistema após você aplicá-los, a menos que os arquivos que estão sendo atualizados estejam bloqueados ou em uso.

Informações sobre os arquivos

x86

Nome do arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

msvcp120_clr0400.dll

12.0.52519.0

485,576

20 a outubro de 2022

07:01

msvcr120_clr0400.dll

12.0.52519.0

987,840

20 a outubro de 2022

07:01

System.Data.dll

4.7.4005.0

3,467,696

20 a outubro de 2022

07:01

x64

File name

Versão do arquivo

Tamanho do arquivo

Data

Hora

msvcp120_clr0400.dll

12.0.52519.0

690,008

20 a outubro de 2022

06:52

msvcp120_clr0400.dll

12.0.52519.0

485,576

20 a outubro de 2022

07:01

msvcr120_clr0400.dll

12.0.52519.0

993,632

20 a outubro de 2022

06:52

msvcr120_clr0400.dll

12.0.52519.0

987,840

20 a outubro de 2022

07:01

System.Data.dll

4.7.4005.0

3,529,608

20 a outubro de 2022

06:52

System.Data.dll

4.7.4005.0

3,467,696

20 a outubro de 2022

07:01

Pré-requisitos

Para aplicar essa atualização, você deve ter o .NET Framework 4.6.2, 4.7, 4.7.1, 4.7.2 instalado.

Necessidade de reinicialização

Você deverá reinicializar o computador depois de aplicar esta atualização se qualquer arquivo afetado estiver sendo usado. Recomendamos sair de todos os aplicativos baseados no .NET Framework antes de aplicar essa atualização.

Como obter ajuda e suporte para esta atualização

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?

Obrigado pelos seus comentários!

×