Sintomas
Você recebe regularmente os seguintes erros durante a execução dos fluxos da área de trabalho:
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AgentNotReachable – O agente solicitado não é acessível
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UnresponsiveAgent - O agente rpa não está respondendo
Causa
Esses erros são causados quando o serviço de automatização de energia em execução no computador não pode mais se comunicar com o agente na sessão do usuário executando seu fluxo. Normalmente, elas são causadas pelo desempenho de máquina sub-ideal, como alto uso de CPU, e podem bloquear temporariamente a comunicação entre o serviço e o agente.
Solução
Se você estiver tendo esses erros regularmente, verifique se o computador atende aos requisitos mínimos.
Se você ainda estiver tendo esse problema, poderá tentar aumentar o tempo limite que o serviço de automatização de energia usa para conversar com o agente. Por padrão, esse valor é definido como 10 segundos. Para fazer isso:
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Abra o registro para: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Power Automate Desktop\Service
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Adicione um novo DWORD (32 bits) e nomeie-o a seguir: AgentPingTimeoutSeconds
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Clique duas vezes no valor para alterar sua configuração. Antes de definir o valor, clique no botão de rádio "Decimal ". Se você estiver usando a conectividade direta do computador (ou seja, você está usando o aplicativo de runtime do computador para conectar seu computador à nuvem), tente aumentar o valor para 30. Se você estiver usando o gateway de dados local (não recomendado), altere o valor para 15.
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Reinicie o serviço de automatização de energia acessando o gerenciador de tarefas (CTRL-SHIFT-ESC), selecionando a guia "Serviços", selecionando "UIFlowService" na lista, clicando com o botão direito do mouse e selecionando a reinicialização.