Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

Sintomas

Se você inserir e remover um dispositivo USB rápida e repetidamente, a porta USB poderá parar de responder. Quando a porta estiver nesse estado, ela não reconhecerá os dispositivos USB e o dispositivo não funcionará.

Este artigo ajuda você a corrigir o problema.

Pré-requisitos

É necessário usar credenciais administrativas para efetuar logon no Windows para executar alguns dos métodos de solução de problemas listados neste artigo. Se esse for seu computador pessoal, é provável que você já esteja conectado com uma conta de administrador. Se esse computador fizer parte de uma rede no trabalho, é provável que você tenha que pedir assistência ao administrador do sistema para obter ajuda. 

Resolução

Para corrigir esse problema, use os seguintes métodos na ordem em que são apresentados. Após cada método, verifique o dispositivo USB para ver se o problema foi corrigido. Se o problema não tiver sido corrigido, tente o próximo método.

Este artigo também inclui uma solução alternativa que você pode usar se esses métodos não funcionarem.

Método 1: Usar o Gerenciador de Dispositivos para verificar se há alterações de hardware

Use o Gerenciador de Dispositivos para verificar se há alterações de hardware. Depois que o seu computador verificar se há alterações de hardware, ele deverá reconhecer o dispositivo USB que estiver conectado à porta USB.

Para verificar se há alterações de hardware, siga estas etapas:

  1. Clique em Iniciar e em Executar.

    Observação Se você estiver executando o Windows Vista, clique em Iniciar e, em seguida, use a caixa Iniciar Pesquisa.

  2. Digite devmgmt.msc e clique em OK. Gerenciador de Dispositivos será aberto.

  3. No Gerenciador de Dispositivos, clique no seu computador para que ele seja realçado.

  4. Clique em Ação e, em seguida, clique em Verificar se há alterações de hardware.

  5. Verifique o dispositivo USB para verificar se ele está funcionando.

Se a verificação de alterações de hardware resolveu o problema, significa que método foi concluído. Se esse método não corrigiu o problema, vá para o método 2.

Método 2: Reinicie o computador

Se a verificação do novo hardware não corrigiu o problema, tente reiniciar o computador. Depois que o computador for reiniciado, verifique o dispositivo USB para ver se ele está funcionando.

Se reiniciar o computador corrigiu o problema, você terá concluído o método. Se esse método não corrigiu o problema, vá para o Método 3.

Método 3: Desative e reative o controlador USB

Use o Gerenciador de Dispositivos para desabilitar e reabilitar todos os controladores USB. Isso permite que os controladores recuperem a porta USB a partir da condição de não estar respondendo. Os controladores USB representam as portas USB no Gerenciador de Dispositivos. Se você não estiver familiarizado com a solução de problemas avançada, experimente as etapas na seção "Solução alternativa".

Para desativar e reativar controladores USB, execute estas etapas:

  1. Clique em Iniciar e em Executar.

    Observação Se você estiver executando o Windows Vista, clique em Iniciar e, em seguida, use a caixa Iniciar Pesquisa.

  2. Digite devmgmt.msc e clique em OK. Gerenciador de Dispositivos será aberto.

  3. Expanda Controladores USB (barramento serial universal).

    Observação Talvez seja necessário rolar a lista para baixo para localizar esse item.

  4. Clique com o botão direito do mouse no primeiro controlador USB em Controladores USB e clique em Desinstalar para removê-lo.

  5. Repita a etapa 4 para cada controlador USB listado em Controladores USB.

  6. Reinicie o computador. Depois que o computador for iniciado, o Windows verificará as alterações de hardware automaticamente e reinstalará todos os controladores USB desinstalados.

  7. Verifique o dispositivo USB para verificar se ele está funcionando.

Se a porta USB reconhecer o dispositivo e for possível usá-lo, você terá solucionado o problema.

Se esse método resolveu o problema, você concluiu o processo. Se esse método não corrigiu o problema, vá para a seção "Solução alternativa".

Solução alternativa

Se nenhum desses métodos funcionou para você, será possível desativar o recurso Suspensão Seletiva. No entanto, esteja ciente de que quando o recurso Suspensão Seletiva for desativado, todos os drivers do controlador de host USB (e todas as portas e dispositivos USB conectados) serão afetados. Por esse motivo, o computador não pode suspender dispositivos USB conectados a ele. Os dispositivos USB podem continuar a usar a energia enquanto estiverem conectados ao computador. Além disso, a caixa de seleção O computador pode desligar o dispositivo para economizar energia não é exibida na guia Gerenciamento de Energia do USB Root Hub.

Esta seção é destinada a usuários avançados de computador.

Você pode desativar o recurso Suspensão Seletiva de USB para solucionar o problema editando o registro. O dispositivo USB pode parar de responder devido a uma condição de corrida no recurso Suspensão Seletiva. O recurso Suspensão Seletiva suspende o dispositivo USB para manter de forma eficiente a energia da bateria permitindo que o computador desative esse dispositivo. No entanto, às vezes esse recurso pode não despertar o dispositivo USB corretamente. Portanto, o dispositivo USB não responderá quando você tentar utilizá-lo.

Convém desativar esse recurso para produtos de servidor onde o gerenciamento de energia não é importante ou necessário.

Importante Este método, seção ou tarefa contém etapas que informam como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para ter mais proteção, faça um backup do Registro antes de modificá-lo. Dessa forma, se ocorrer algum problema, você poderá restaurar o Registro. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:

Como fazer o backup e a restauração do Registro no WindowsPara desativar o recurso Suspensão Seletiva, execute estas etapas:

  1. Clique em Iniciar e em Executar.

    Observação Se você estiver executando o Windows Vista, clique em Iniciar e, em seguida, use a caixa Iniciar Pesquisa.

  2. Digite regedit e clique em OK. O Editor do Registro será aberto.

  3. Localize e clique na seguinte subchave do Registro:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\USB

  4. Se a entrada do Registro DisableSelectiveSuspend estiver presente, clique nela duas vezes. Se não estiver presente, crie a entrada. Para criar a entrada, execute as seguintes etapas:

    1. No menu Editar, aponte para Novo e clique em DWORD.

    2. Digite DisableSelectiveSuspend e pressione ENTER.

    3. No menu Editar, clique em Modificar.

  5. No campo de dados Valor, digite 1 para desativar o recurso Suspensão Seletiva e, em seguida, clique em OK.

Agora, vá para a seção "O problema foi corrigido?" .

Motivo

Esse problema pode ocorrer devido a um problema de tempo que impede que o computador detecte o dispositivo USB.

A Microsoft e os fornecedores de hardware que fabricam os chips usados para USB têm investigado o problema. No entanto, os resultados não foram conclusivos devido à natureza intermitente do problema.

Status

A Microsoft está pesquisando esse problema e publicará mais informações neste artigo assim que estiverem disponíveis.

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×