Applies ToMicrosoft Windows XP Professional Microsoft Windows XP Home Edition Genuine Windows

Sintomas

Ao tentar validar uma cópia do Microsoft Windows XP, você recebe a seguinte mensagem de erro do Windows Genuine Advantage (WGA):

0x80080201 não pode detectar a ID do produto (PID)

Causa

Esse problema ocorre porque o Windows XP está em um estado que impede que o WGA acesse a ID do produto (PID). Esse Estado pode ocorrer por qualquer um dos seguintes motivos:

  • O arquivo%windir%\System32\Wpa.dbl está ausente ou corrompido.

  • As configurações de segurança ou as configurações de atributo para o arquivo%windir%\System32\Wpa.dbl estão incorretas.

  • Algumas ferramentas que podem ser baixadas mudaram ou modificaram a identificação do produto.

  • O valor da ID do produto no registro está ausente ou corrompido.

  • Um ou mais dos seguintes arquivos pode estar com uma versão incorreta ou podem estar cancelados:

    • Licdll.dll

    • Licwmi.dll

    • Legitcheckcontrol.dll

Resolução

Para resolver esse problema, siga estes passos.

Etapa 1: Verifique se a verificação de validação está falhando

  1. Clique em Iniciar, clique em executar, digite oobe/msoobe/ae clique em OK. Observação Há um espaço entre msoobe e /a.

  2. A caixa de diálogo ativar o Windows será exibida. Siga as instruções que aparecem na tela para ativar o Windows XP. Se você ainda receber uma mensagem de erro, vá para a etapa 2.

Etapa 2: baixar e registrar a versão mais recente do arquivo LegitCheckControl. dll

  1. Para baixar o arquivo LegitCheckControl. cab , acesse o seguinte site da Microsoft:

  2. Extraia o arquivo LegitCheckControl. cab para um diretório temporário em seu computador.

  3. Copie o arquivo LegitCheckControl. dll no diretório temporário para o diretório %windir%\System32 .

  4. Clique em Iniciar, Executar, digite cmd e clique em OK.

  5. Registre a nova versão do arquivo LegitcheckControl. dll digitando o seguinte comando no prompt de comando:

    regsvr32 %windir%\system32\legitcheckcontrol.dll

  6. Reinicie o computador.

  7. Depois que o computador for reiniciado, execute a etapa 1 novamente para determinar se o problema ainda existe. Se ainda receber a mensagem de erro, vá para a etapa 3.

Etapa 3: registrar novamente o arquivo Licwmi. dll

  1. Clique em Iniciar, Executar, digite cmd e clique em OK.

  2. No prompt do comando, digite o seguinte comando e pressione ENTER:

    regsvr32 /u %windir%\system32\licwmi.dll

  3. Execute a etapa 1 novamente. Se ainda receber a mensagem de erro, vá para a etapa 4.

Etapa 4: registrar novamente o arquivo licdll. dll

  1. Clique em Iniciar, Executar, digite cmd e clique em OK.

  2. No prompt de comando, digite os seguintes comandos. Pressione ENTER após cada um deles.

    regsvr32/u%windir%\system32\licdll.dllnet stop winmgmt

  3. Após o serviço Winmgmt parar, digite o seguinte comando no prompt de comando e pressione ENTER:

    net start winmgmt

  4. Execute a etapa 1 novamente. Se ainda receber a mensagem de erro, vá para a etapa 5.

Etapa 5: verificar o valor da ProductID no registro

  1. Clique em Iniciar, em Executar, digite regedit e clique em OK.

  2. Localize e clique com o botão direito do mouse no seguinte valor do registro:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProductID

  3. Verifique se o valor do registro é exibido no seguinte formato:

    <12345-VER-1234567-89012>

  4. Se o valor for exibido corretamente, reinicie o computador e execute a etapa 1 novamente.

  5. Se ainda receber a mensagem de erro, vá para a etapa 6.

Etapa 6: Certifique-se de que os atributos do arquivo WPA. duplo não estão definidos como somente leitura

  1. Clique em Iniciar, clique em executar, digite attrib-r%windir%\system32\wpa.dble clique em OK.

  2. Execute a etapa 1 novamente. Se ainda receber a mensagem de erro, vá para a etapa 7.

Etapa 7: verificar as configurações de segurança para o arquivo WPA. duplo

  1. No Windows Explorer, localize o arquivo%windir%\System32\Wpa.dbl.

  2. Clique com o botão direito do mouse em WPA. duploe, em seguida, clique em Propriedades.

  3. Na guia segurança , clique para selecionar o grupo sistema. Verifique se a caixa de seleção permitir para controle total está marcada. Se controle total não estiver selecionado para o grupo sistema, selecione-o e clique em OK.

  4. Execute a etapa 1 novamente. Se ainda receber a mensagem de erro, vá para a etapa 8.

Observação No Windows XP Home Edition, a guia segurança é exibida somente quando o computador está em execução no modo de segurança. Além disso, no Windows XP Professional, a guia segurança é exibida somente quando a caixa de seleção usar o compartilhamento simples de arquivo (recomendado) na caixa de diálogo Opções de pasta não está marcada.

Etapa 8: executar a ferramenta Microsoft Genuine Advantage Diagnostic (MGADIAG)

  1. Para executar a ferramenta, acesse o seguinte site da Microsoft:

    http://go.microsoft.com/fwlink/?linkid=52012

  2. Na caixa de diálogo download de arquivo-aviso de segurança , clique em executar.

  3. Na caixa de diálogo Internet Explorer-aviso de segurança , clique em executar.

  4. Na caixa de diálogo ferramenta de diagnóstico do Microsoft Genuine Advantage , clique em continuar.

  5. Quando a ferramenta MGADIAG for concluída, clique em copiar.

  6. Acesse o fórum de problemas de validação da vantagem do Windows XP original no seguinte site da Microsoft:

    http://forums.microsoft.com/Genuine/ShowForum.aspx?ForumID=442&SiteID=25 Você pode criar um novo thread nesse site que inclua as informações que você copiou da ferramenta MGADIAG.

Status

A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicável a".

Informações adicionais

Para obter mais informações sobre o WGA, acesse o seguinte site da Microsoft:

http://www.microsoft.com/genuine/downloads/whyValidate.aspxPara obter mais informações, clique nos seguintes números de artigos para ler o conteúdo na Base de Dados de Conhecimento Microsoft:

892130 Descrição da WGA (vantagens do Windows original)

916247 O Windows Genuine Advantage não valida uma cópia do Windows XPPara obter mais informações sobre como ativar o Windows XP, clique no número abaixo para ler o artigo na base de dados de conhecimento da Microsoft:

307890 Como ativar o Windows XP

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.