Sintomas
Depois que uma sincronização do PONTO de Atualização de Software (SUP) com o WSUS (Serviços de Atualização de Software) do Windows for concluída, as atualizações de software implantadas anteriormente serão exibidas como inválidas no Console do Administrador no Microsoft System Center Configuration Manager 2007. Especificamente, o ícone de atualização de software inválido (uma seta vermelha) aparece junto com as atualizações quando você exibe as atualizações no nó Gerenciamento de Implantação do Console do Administrador. Além disso, essas atualizações não estão mais listadas no nó Pacotes de Implantação.
Causa
Esse problema pode ocorrer devido a alterações feitas no serviço Microsoft Update em outubro de 2012. Essas melhorias contêm atualizações de metadados que afetam todos os servidores do WSUS. Essas alterações fez com que algumas atualizações fossem marcadas como tendo uma alteração de conteúdo, mesmo que os binários de atualização não fossem alterados. Para alguns administradores, as alterações de metadados podem ter sido aplicadas automaticamente quando o WSUS foi sincronizado com os servidores do Microsoft Update em outubro. Outros administradores receberam as alterações aplicando a atualização 2734608 seus servidores WSUS.
Resolução
Para resolver esse problema, instale esse pacote de hotfix em servidores de site primário e System Center Configuration Manager 2007 SP2.
Depois de aplicar esse hotfix, uma atualização que contém uma alteração somente para metadados e não para o conteúdo do arquivo não fará com que a atualização seja exibida como inválida.
Esse hotfix não atualizará o status das atualizações que foram marcadas anteriormente como inválidas. No entanto, você pode baixar novamente essas atualizações usando o assistente para Baixar Software do nó Atualizações de Software do Console do Administrador.
Para identificar atualizações que exibem o ícone de atualização de software inválido, você pode criar uma nova pasta de pesquisa. Para fazer isso, use as seguintes propriedades de objeto ao criar a pasta de pesquisa:
-
Deployed=Yes
-
Downloaded=No
Além disso, você deve ter a caixa de seleção Pesquisar todas as pastas sob esse recurso.
Depois de executar a consulta, verifique se apenas as atualizações de software inválidas são retornadas. Você pode selecionar as atualizações e baixá-las novamente diretamente na janela de resultados. Você pode colocar as atualizações nos pacotes de implantação originais, se eles forem conhecidos. Como alternativa, você pode colocar as atualizações em um novo pacote de implantação. As implantações ativas serão atualizadas automaticamente para reconhecer o status de download revisado das atualizações.
Para obter mais informações sobre como configurar pastas de pesquisa para atualizações de software, acesse o seguinte site do Microsoft TechNet:
Como configurar pastas de pesquisa para atualizações de software
Informações sobre o hotfix
Um hotfix com suporte está disponível na Microsoft. No entanto, esse hotfix destina-se a corrigir apenas o problema descrito neste artigo. Aplique esse hotfix somente a sistemas que estão enfrentando o problema descrito neste artigo. Esse hotfix pode receber testes adicionais. Portanto, se você não for gravemente afetado por esse problema, recomendamos aguardar a próxima atualização de software que contém esse hotfix.
Se o hotfix estiver disponível para download, haverá uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não aparecer, entre em contato com o Serviço de Atendimento ao Cliente e o Suporte da Microsoft para obter o hotfix.
Observação Se ocorrerem problemas adicionais ou se alguma solução de problemas for necessária, talvez seja necessário criar uma solicitação de serviço separada. Os custos usuais de suporte serão aplicados a perguntas e problemas de suporte adicionais que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de Atendimento ao Cliente e Suporte da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=supportObservação O formulário "Download de hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Para instalar esse hotfix, você deve estar executando System Center Configuration Manager 2007 Service Pack 2 (SP2).
Informações do Registro
Para instalar esse hotfix, você não precisa fazer nenhuma alteração no Registro.
Necessidade de reinicialização
Você não precisa reiniciar o computador depois de instalar esse hotfix.
Informações sobre a substituição de hotfixes
Esse hotfix não substitui nenhum hotfix lançado anteriormente.
Informações do arquivo
A versão global deste hotfix instala arquivos que têm os atributos listados nas tabelas a seguir. As datas e as horas desses arquivos estão listados no formato UTC (Tempo Universal Coordenado). As datas e as horas desses arquivos no computador local são exibidas no horário local, com o ajuste de DST (horário de verão) atual. Além disso, as datas e as horas poderão ser alteradas quando você realizar algumas operações nos arquivos.
File name |
Versão do arquivo |
Tamanho do arquivo |
Data |
Horário |
Platform |
---|---|---|---|---|---|
Updmgr.dll |
4.0.6487.2220 |
156,232 |
01 de fevereiro de 2010 |
1,855 |
x86 |
Informações adicionais
Para obter mais informações sobre esse problema, acesse a seção "Problema 2 – Melhorias adicionais" da seguinte postagem no blog no site do Microsoft TechNet:
Dica de suporte: Configuration Manager pacotes de implantação do cliente podem não ser implantados devido a atualizações que precisam ser baixadas novamentePara obter mais informações sobre 2734608 atualização, clique no seguinte número de artigo para exibir o artigo na Base de Dados de Conhecimento Microsoft:
2734608 Uma atualização do Windows Server Update Services 3.0 Service Pack 2 está disponível (KB2734608)Para obter mais informações sobre a sincronização de atualizações de software, acesse o seguinte site do Microsoft TechNet:
Informações gerais sobre a sincronização de atualizações de softwarePara obter mais informações sobre metadados de atualizações de software, acesse o seguinte site do Microsoft TechNet:
Informações gerais sobre metadados de atualizações de softwarePara obter mais informações sobre o glossário de ícone para atualizações de software, acesse o seguinte site do Microsoft TechNet:
Informações gerais sobre o glossário de ícone para atualizações de software