Para obter uma versão deste artigo do Microsoft Publisher 98, consulte 191131.

Resumo

Se você tiver um comportamento inesperado ao usar uma publicação no Microsoft Publisher, a publicação poderá estar danificada. Os sintomas de uma publicação danificada incluem o seguinte:

  • Você recebe uma falha de página inválida, uma falha de proteção geral ou uma mensagem de erro de instrução ilegal.

  • Ao tentar abrir a publicação, você recebe uma das seguintes mensagens de erro:

    -Esta não é uma publicação do Publisher.

    -O Publisher não pode abrir o tipo de arquivo representado pelo arquivo <>.

    -Parte do arquivo está ausente.

  • Você recebe uma mensagem de erro de falta de memória ou uma mensagem de erro de poucos recursos do sistema.

Observação Você pode receber uma dessas mensagens de erro por razões diferentes de uma publicação danificada. No entanto, se esse comportamento ocorrer apenas quando você usar uma publicação específica, essa publicação estará provavelmente danificada.

Informações adicionais

Para solucionar esse problema, reinicie o computador no modo de segurança. Em seguida, use os métodos de solução de problemas apropriados para o seu problema.Observação Como há várias versões do Microsoft Windows, as etapas a seguir podem ser diferentes no seu computador. Se esse for o caso, consulte a documentação do produto para concluir essas etapas.

Reiniciar o computador no modo de segurança

Para reiniciar o computador no modo de segurança, use o método apropriado para a sua versão do Microsoft Windows.

  1. Desligue e reinicie o computador.

  2. Quando vir a mensagem "Selecione o sistema operacional para iniciar", pressione F8.

  3. No menu de Opções avançadas do Windows , use as teclas de direção para selecionar o modo de segurançae, em seguida, pressione Enter.

  4. Se você tiver um computador de inicialização dupla ou um computador multi-inicializador, selecione o sistema operacional apropriado na lista e pressione ENTER.

Para obter mais informações sobre o modo de segurança, clique no número abaixo para ler os artigos na base de dados de conhecimento da Microsoft:

315222 Uma descrição das opções de inicialização no Modo de Segurança do Windows XP

202485 Descrição do modo de inicialização seguro no Windows 2000

180902 Como iniciar um computador baseado no Windows 98 no modo de segurança

Tentar abrir a publicação

Depois de iniciar o computador no modo de segurança, tente abrir a publicação. Se você não receber uma mensagem de erro, um programa ou um dispositivo carregado quando o computador está no modo normal pode interferir na publicação.

Se você não conseguir abrir a publicação

Se você não conseguir abrir a publicação após iniciar o computador no modo de segurança, use os métodos a seguir na ordem em que eles são apresentados.

Colar a publicação no arquivo de programa do Publisher

Você poderá abrir a publicação colando-a no arquivo de programa do Publisher. Para fazer isto, siga as seguintes etapas:

  1. Inicie o Windows Explorer.

  2. Localize o arquivo de publicação.

  3. Clique com o botão direito do mouse no arquivo de publicação e clique em copiar.

  4. Encerre o Windows Explorer.

  5. Clique em Iniciar, clique em executar, digite uma das linhas a seguir na caixa abrir e clique em OK:

    Para o Publisher 2003c:\Program Files\Microsoft Office\Office11para o Publisher 2002C:\Program Files\Microsoft Office\Office10para o Publisher 2000C:\Program Files\Microsoft Office\Office

  6. Clique com o botão direito do mouse no arquivo de programa MSPUB. exe e clique em colar.

Se você não conseguir abrir a publicação, vá para o próximo método.

Clique duas vezes no arquivo de publicação no Windows Explorer

Para clicar duas vezes no arquivo de publicação no Windows Explorer, siga estas etapas:

  1. Clique em Iniciar, aponte para Programas e clique em Windows Explorer.

  2. Localize o arquivo de publicação.

  3. Clique duas vezes no arquivo de publicação.

Se você não conseguir abrir a publicação, vá para o próximo método.

Configurar o Publisher para ocultar imagens

Para configurar o Publisher para ocultar imagens, siga estas etapas:

  1. Inicie o Publisher e, em seguida, abra uma nova publicação em branco.

  2. No menu Exibir , clique em exibição de imagem no Publisher 2000 ou clique em imagens no Publisher 2003 ou no Publisher 2002.

  3. Clique em ocultar imagense, em seguida, clique em OK.

  4. No menu Arquivo, clique em Abrir.

  5. Localize o arquivo de publicação.

  6. Clique para selecionar a publicação e, em seguida, clique em abrir.

Se você conseguir abrir a publicação, a publicação poderá conter um objeto danificado ou um espaço reservado para objeto. Para remover ou substituir um espaço reservado de objeto ou objeto danificado, vá para o próximo método. Se você não conseguir abrir a publicação, vá para o método "copiar a publicação para um segundo computador".

Localizar e remover um espaço reservado de objeto ou objeto danificado

Para localizar e remover um espaço reservado de objeto ou objeto danificado, siga estas etapas:

  1. Na publicação, clique com o botão direito do mouse em um espaço reservado para objeto e clique em excluir objeto.

  2. No menu Arquivo, clique em Salvar como.

  3. Na caixa nome , digite um novo nome para a publicação e clique em salvar.

  4. No menu Exibir , clique em exibição de imagem no Publisher 2000 ou clique em imagens no Publisher 2003 ou no Publisher 2002.

  5. Clique em exibição detalhadae, em seguida, clique em OK.Observação Se você receber uma mensagem de erro, vá para a etapa 8.

  6. No menu Arquivo, clique em Fechar.

  7. No menu arquivo , clique em abrire, em seguida, clique na publicação que você salvou na etapa 3. Se você conseguir abrir a publicação, o objeto ou o espaço reservado do objeto que você excluiu na etapa 1 estará danificado. Ajuste seu layout para o objeto ausente ou o espaço reservado para objeto. Ou, se preferir, desenhe um novo espaço reservado para objeto e substitua o objeto excluído por um que não esteja danificado. Para fazer isso, use o método apropriado para a sua fonte de objetos.Na Galeria clip-arts

    1. No menu Inserir , aponte para imageme clique em Clip-Art.

    2. Em uma das categorias disponíveis, clique para inserir a imagem, o som ou o clipe de animação desejado.

    3. Salve e feche a publicação. Em seguida, tente reabrir a publicação.

    De um local diferente da Galeria de clip-arts

    1. Use a ferramenta quadro de imagem para desenhar um novo espaço reservado para objeto.

    2. Clique para selecionar o espaço reservado, aponte para imagem no menu Inserir e, em seguida, clique em do arquivo.

    3. Localize a imagem que você deseja inserir e, em seguida, clique para selecioná-la.

    4. Clique em Inserir.

    5. Salve e feche a publicação. Em seguida, tente reabrir a publicação.

    Se você não conseguir abrir a publicação, repita o método "configurar o Publisher para ocultar imagens". Em seguida, vá para a etapa 8.

  8. Repita as etapas 1 a 7 até que você possa abrir a publicação com a opção de exibição detalhado habilitada.

  9. Quando você conseguir abrir a publicação, use um dos seguintes métodos:

    • Substitua o objeto ou o espaço reservado do objeto excluído por um que não esteja danificado.

    • Ajuste o layout para o objeto ausente ou o espaço reservado para objeto.

  10. No menu Arquivo, clique em Salvar.

Se ainda assim você não conseguir abrir a publicação, vá para o próximo método.

Mover o arquivo de publicação para outro disco

Se o arquivo de publicação estiver localizado em um disco removível, como um disquete ou disco zip, talvez o Windows não consiga ler o arquivo. Nesse cenário, copie o arquivo para o disco rígido. Se não for possível copiar o arquivo do disco removível, o arquivo pode estar com vínculo cruzado com outros arquivos ou pastas. Ou, se preferir, o arquivo pode estar localizado em um setor danificado do disco. Em qualquer um dos cenários, vá para o método "executar verificação de erros no disco".

Copiar a publicação para um segundo computador

Em alguns cenários, você pode abrir uma publicação danificada depois de copiar a publicação para um segundo computador com o Publisher instalado. Para fazer isto, siga as seguintes etapas:

  1. Inicie o Windows Explorer.

  2. Localize o arquivo de publicação.

  3. Clique com o botão direito do mouse no arquivo de publicação e clique em copiar.

  4. Use um dos seguintes métodos para copiar a publicação para um segundo computador:

    • Copie o arquivo de publicação para um disco removível, como um disquete ou disco zip. Em seguida, copie a publicação do disco removível para um segundo computador.

    • Copiar o arquivo de publicação para um segundo computador em uma rede.

  5. No segundo computador, inicie o Windows Explorer.

  6. Localize e clique duas vezes no arquivo de publicação.

Se você conseguir abrir a publicação, examine cada página para determinar se os espaços reservados para objetos em branco estão presentes. Para cada espaço reservado de objeto em branco que você encontrar, clique com o botão direito do mouse no arquivo e, em seguida, clique em excluir. Salve a publicação e, em seguida, copie o arquivo de publicação de volta para o primeiro computador. Se você não conseguir abrir a publicação, vá para o próximo método.

Executar a verificação de erros no disco

Executar a verificação de erros para reparar todos os erros no disco. Instrua a verificação de erros para reparar todos os arquivos com vínculo cruzado e para converter fragmentos perdidos em arquivos.Observação Embora a verificação de erros possa determinar que o arquivo de publicação tem uma vínculo cruzado e, em seguida, reparar o arquivo, esse método não garante que o Publisher possa ler o arquivo após a verificação de erros ter concluído a verificação e a correção de erros. Para executar a verificação de erros, siga estas etapas:

  1. Feche todos os programas que estejam em execução.

  2. Clique duas vezes no ícone meu computador na área de trabalho.

  3. Clique com o botão direito do mouse no disco local que você deseja verificar e, em seguida, clique em Propriedades.

  4. Na guia ferramentas , clique em verificar agora em verificação de erros.

  5. Em verificar opções de disco, clique para marcar a caixa de seleção procurar setores defeituosos e tentar recuperá -los. Em seguida, clique em Iniciar.

  6. Quando a verificação de erros concluir a verificação e corrigir erros, clique em fechar.

  7. Inicie o Publisher e tente abrir a publicação.

Se você não conseguir abrir a publicação, vá para o próximo método.

Tentar recuperar o texto na publicação

Esse método descreve como recuperar o texto da publicação danificada e como inserir o texto recuperado em uma nova publicação em branco. Em seguida, você deve recriar o layout e inserir novamente todos os objetos da publicação danificada na nova publicação. Para recuperar texto da publicação danificada e inserir o texto em uma nova publicação, siga estas etapas:

  1. Inicie o Publisher e crie uma nova publicação em branco e em página inteira.

  2. Use a ferramenta quadro de texto no Publisher 2000 ou a ferramenta caixa de texto no Publisher 2003 ou no Publisher 2002 para desenhar um quadro de texto na página em branco.

  3. No menu Inserir , clique em arquivo de texto.

  4. Na caixa arquivos do tipo , clique emarquivos do Publisher (*. pub).

  5. Clique em sua publicação e, em seguida, clique em OK. Se você receber uma mensagem que informa como o texto que você deseja inserir se encaixa na página, clique em Sim.

Se você conseguir abrir a publicação danificada

Se você conseguir abrir a publicação no modo de segurança, use um dos seguintes métodos para recriar a publicação.

Copiar páginas da publicação danificada para uma nova publicação

Para copiar páginas de uma publicação danificada para uma nova publicação, siga estas etapas:

  1. Inicie o Publisher e, em seguida, abra a publicação danificada.

  2. Inicie outra instância do Publisher.

  3. Crie uma publicação nova e em branco que esteja configurada da mesma forma que a publicação danificada.

  4. Na publicação danificada, selecione todos os objetos em uma página específica.

  5. No menu Editar, clique em Copiar.

  6. Pressione ALT + TAB para alternar para a nova publicação.

  7. No menu Editar, clique em Colar.

  8. Repita as etapas de 4 a 7 até que todas as páginas sejam coladas na nova publicação.

Observação Se você observar um comportamento estranho na nova publicação depois de copiar uma página para a nova publicação, é provável que a página copiada contenha um objeto danificado. Nesse cenário, use um dos seguintes métodos para contornar esse problema:

  • Copie um objeto por vez da página problema para a nova publicação para determinar qual objeto está danificado. Em seguida, certifique-se de que não inclua o objeto danificado na nova publicação.

  • Recriar a página problema na nova publicação.

Se cada página da publicação estiver danificada, vá para o próximo método.

Salvar a publicação no formato RTF (Rich Text Format)

Se o dano à sua publicação parecer generalizado, salve a publicação no formato RTF para recuperar o texto da publicação. Para fazer isto, siga as seguintes etapas:

  1. Abrir a publicação.

  2. Clique em um quadro de texto.

  3. Na caixa salvar como tipo , clique emformato Rich Text (*. rtf).

  4. Na caixa nome do arquivo , digite o nome do arquivo que você deseja.

  5. Na caixa salvar em , clique na pasta na qual você deseja salvar o texto da publicação.

  6. Clique em salvare, em seguida, clique em OK.

  7. Fechar a publicação.

  8. No menu Arquivo, clique em Abrir.

  9. Na caixa arquivos do tipo , clique emformato Rich Text (*. rtf).

  10. Na lista de arquivos, clique no arquivo de texto que você salvou na etapa 6.

  11. Clique em Abrir.

  12. Dispor e formatar o texto de uma maneira que duplique como o texto é disposto e formatado na publicação danificada.

Referências

Para obter mais informações sobre como solucionar problemas com publicações danificadas do Publisher, clique no número abaixo para ler o artigo na base de dados de conhecimento da Microsoft:

315222 Uma descrição das opções de inicialização no Modo de Segurança do Windows XP

164519 Solução de problemas de erros do Office Kernel32. dll no Windows 95

179095 Mensagem de erro do link de arquivo ao abrir o Publisher

Precisa de mais ajuda?

Expanda suas habilidades

Explore o treinamento >

Obtenha novos recursos primeiro

Ingressar no Microsoft Insider >

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?

Obrigado pelos seus comentários!

×