Sintomas
Suponha que você use um aplicativo de segurança de dados, como o IBM InfoSphere Guardium, que executa as seguintes tarefas:
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Monitora todas as conexões de banco de dados na rede
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Armazena informações relevantes
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Cria relatórios sobre as informações armazenadas para aplicativos do BizTalk Server
Nessa situação, o aplicativo de segurança de dados consistentemente determina que cada conexão significa um novo aplicativo. Finalmente, o volume de informações armazenados se torna bastante trabalhosa e faz com que o programa falha.
Observação: O aplicativo de segurança de dados armazena as informações por aplicativo com base no valor de "Nome do aplicativo" for especificado na sequência de conexão.
Causa
Esse problema ocorre porque o BizTalk Server utiliza um GUID exclusivo para "Nome do aplicativo" em todas as conexões para determinadas chamadas para que o número de registrados elementos "Nome do aplicativo" aumenta infinitamente e aciona está em conflito com o aplicativo de monitoração.
Resolução
Informações da atualização cumulativa
Esse problema foi corrigido primeiramente nas seguintes atualizações cumulativas para o BizTalk Server:
Status
A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".
Referências
Para obter informações sobre os service packs e atualizações cumulativas lista do BizTalk Server, consulte 2555976 KB: Service pack e a lista de atualização cumulativa para o BizTalk Server.
Para obter mais informações sobre os hotfixes do BizTalk Server, consulte 2003907 KB: suporte de atualização de informações sobre os hotfixes do BizTalk e cumulativas.