Sintomas
No Microsoft Commerce Server 2007 ou no Microsoft Commerce Server 2009, você selecionar o tipo de importação Substituir para executar uma importação de catálogo. Se houver dados do catálogo, a importação leva muito tempo para ser concluída. Por exemplo, se você importar um novo catálogo, a importação leva cerca de 10 minutos. Se você usar o tipo de importação Substituir para importar o mesmo arquivo de catálogo novamente após a primeira importação, a importação leva uma hora para ser concluída.
Causa
O problema ocorre porque ctlg_RepairCatalogsAfterImport seleciona um plano de consulta ineficiente para o processo de importação de catálogo.
Resolução
Informações sobre o hotfix
Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix. Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix. Observação caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=supportObservação o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Você deve ter uma das seguintes versões instaladas:
-
Microsoft Commerce Server 2007 SP2
-
Microsoft Commerce Server 2009
Requisitos de reinicialização
Você não precisa reiniciar o computador. No entanto, você deve reiniciar os serviços de informações da Internet (IIS) e o Commerce Server catálogo importação Host aplicativo COM+ após aplicar esse hotfix. Para reiniciar o IIS, em um prompt de comando, digite o seguinte comando e pressione ENTER:
IISRESET /RESTART Observação Essa opção para e reinicia todos os serviços do IIS que estão executando.
Informações sobre substituição
Esse hotfix não substitui nenhum hotfix lançado anteriormente.
Informações sobre o arquivo
A versão global deste hotfix usa um pacote do Microsoft Windows Installer para instalar o hotfix. As datas e horas desses arquivos estão listadas no tempo Universal Coordenado (UTC) na tabela a seguir. Quando você exibe as informações do arquivo, a data é convertida para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Para o Microsoft Commerce Server 2007
Nome do arquivo |
Versão do arquivo |
Tamanho do arquivo |
Data |
Hora |
Plataforma |
---|---|---|---|---|---|
Catalogcreate.sql |
Not applicable |
1,153,421 |
25-Feb-2011 |
10:38 |
Not applicable |
Para o Microsoft Commerce Server 2009
Nome do arquivo |
Versão do arquivo |
Tamanho do arquivo |
Data |
Hora |
Plataforma |
---|---|---|---|---|---|
Catalogcreate.sql |
Not applicable |
1,157,103 |
25-Feb-2011 |
10:38 |
Not applicable |
Cs2009hotfixhelper.exe |
6.0.4171.40 |
13,080 |
28-Feb-2011 |
08:01 |
x86 |
Informações de instalação de hotfix
Após extrair o pacote de hotfix, você pode obter os seguintes arquivos:
-
Para o Commerce Server 2007:
-
CommerceServer2007SP2-KB2513798-ENU.exe
-
KB2513798.sql
Instale o arquivo CommerceServer2007SP2-KB2513798-ENU.exe para atualizar o arquivo Catalogcreate.sql.
-
-
Para o Commerce Server 2009:
-
CommerceServer2007SP3-KB2513798-ENU.exe
-
KB2513798.sql
Instale o arquivo CommerceServer2007SP3-KB2513798-ENU.exe para atualizar o arquivo Catalogcreate.sql.
-
Você precisa instalar o hotfix apropriado para certificar-se de que esse problema não ocorre para novos bancos de dados do catálogo. Além disso, você deve executar o arquivo KB2513798.sql em relação os bancos de dados existentes do catálogo para atualizar os procedimentos armazenados.
Informações adicionais
Para obter mais informações sobre como importar catálogos no Commerce Server, visite a seguinte página da Web do MSDN: