Sintomas
Quando você executa o Microsoft BizTalk 2010 Accelerator para SWIFT (A4SWIFT) em um servidor que esteja executando o Microsoft BizTalk Server 2010, as seguintes mensagens de erro podem ser registradas no log do aplicativo:
Data de tempo Aviso 5 serviço do BAM EventBus servername.fqdn erro de lote de execução. Informações de exceção: TDDS falhou para a execução de lotes de fluxos. SQLServer: nome_do_servidor, banco de dados: BAMPrimaryImport.Parameter não é válido.
Data detempo Erro 6 BAM EventBus Service servername.fqdn erro de evento de execução. Ocorreram erros durante a execução de eventos, consulte TDDS_FailedTrackingData tabela para obter mais detalhes. SQLServer: nome_do_servidor, banco de dados: BAMPrimaryImport.Observação: Esse problema ocorre durante o processamento de uma mensagem de confirmação negativa (NACK) ou um reconhecimento (ACK).
Causa
Esse problema ocorre porque alguns parâmetros importantes, como ErrorNack, sessão, TimeSente a sequência, não são definidos no arquivo de definição de FrrActivities.xml.
Resolução
Antes de aplicar esta correção, você deve executar o seguinte comando em um prompt de comando elevado:
C:\Program Files (x86)\Microsoft BizTalk Server 2010\Tracking\bm.exe" remove-all -DefinitionFile:"C:\Program Files (x86)\Microsoft BizTalk Accelerator for SWIFT\BAMTracking\FrrActivities.xml
Depois de aplicar esta correção, você deve executar o seguinte comando em um prompt de comando elevado:C:\Program Files (x86)\Microsoft BizTalk Server 2010\Tracking\bm.exe" deploy-all -DefinitionFile:"C:\Program Files (x86)\Microsoft BizTalk Accelerator for SWIFT\BAMTracking\FrrActivities.xml"
Informações sobre o hotfix
Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.
Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix. Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e Suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:http://support.microsoft.com/contactus/?ws=supportObservação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos:
Para aplicar esse hotfix, você deve ter o BizTalk Server 2010 instalado.
Informações sobre reinicialização
Você não precisa reiniciar o computador após aplicar esse hotfix.
Informações sobre substituição
Esse hotfix não substitui nenhum hotfix lançado anteriormente.
A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas na Hora Universal Coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso Horário no item Data e Hora no Painel de Controle.
Nome do Arquivo |
Versão do arquivo |
Tamanho do arquivo |
Data |
Hora |
Plataforma |
---|---|---|---|---|---|
Frractivities.xml |
Não aplicável |
10,689 |
18-Jul-2013 |
21:34 |
Não aplicável |
Status
A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".
Mais informações
Para obter mais informações, consulte suporte de atualização de informações sobre os hotfixes do BizTalk e cumulativas.