Sintomas
Considere o seguinte cenário no Microsoft SQL Server 2016 ou 2017:
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Você configura backups gerenciados pelo SQL Server em um ou mais de seus bancos de dados.
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Você define um cronograma de trabalho para executar um backup de log a cada n minutos ou horas. Por exemplo, você agenda para executar o backup de log a cada 5 minutos.
Nesse cenário, você pode encontrar o backup de log não ocorre conforme programado, e o evento estendido mostra as seguintes informações:
Resumo do carimbo de data/hora (UTC)
data hora + 00:00 [SSMBackup2WADebugXevent] nome do banco de dados = database_name, ID do banco de dados = Database_ID, informações adicionais = SSMBackup2WA não agendar o backup de log porque nenhuma das condições correspondeu.
Causa
Os seguintes fatores podem causar instabilidade de um backup de log:
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Demora muito tempo para concluir o backup do log. Por exemplo, você agenda um backup de log para ser executado a cada 6 horas, mas, na verdade, demora cerca de 11 horas para que o processo de backup seja concluído.
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Há uma alteração muito grande na frequência de backup de log. Por exemplo, você altera o backup de log agendado de cada 5 minutos a cada 6 horas.
Resolução
Esta correção está incluída nas seguintes atualizações cumulativas do SQL Server:
Atualização cumulativa 1 para SQL Server 2017
Atualização cumulativa 5 para SQL Server 2016 Service Pack 1
Sobre as compilações do SQL Server
Cada novo Build do SQL Server contém todos os hotfixes e todas as correções de segurança incluídas na compilação anterior. Recomendamos que você instale as atualizações cumulativas mais recentes do SQL Server:
Status
A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplicável a".
Referências
Saiba mais sobre a terminologia usada pela Microsoft para descrever atualizações de software.