Sintomas
Quando você concluir a instalação do Portal de Negócios no Microsoft Dynamics GP ou no Microsoft Dynamics SL e iniciar o Portal de Negócios, receberá a seguinte mensagem de erro nas várias Web Parts exibidas:
Erro do servidor no aplicativo '/'. Acesso negado ao 'Microsoft Dynamics'. Falha ao iniciar o monitoramento de alterações de arquivo. Descrição: ocorreu uma exceção não acarretada durante a execução da solicitação da Web atual. Revise o rastreamento de pilha para obter mais informações sobre o erro e de onde ele se originou no código. Detalhes da exceção: System.Web.HttpException: Acesso negado ao 'Microsoft Dynamics'. Falha ao iniciar o monitoramento de alterações de arquivo.
Causa
Microsoft ASP.NET requer as seguintes permissões para a conta de processo ASP.NET e para a conta de Serviço de Rede. Essas permissões são necessárias na pasta raiz do site e em cada pasta no diretório virtual:
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Leitura
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Executar
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Listar
ASP.NET requer essas permissões para acessar os arquivos e monitorar as alterações nos arquivos.
Resolução
Para resolver esse problema, use um dos métodos a seguir.
Método 1
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Conceda as permissões necessárias para a conta ASP.NET processo. Para fazer isso, siga estas etapas:
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No Windows Explorer, localize a pasta de instalação do aplicativo. Ou localize a pasta do diretório virtual. Veja a seguir o local padrão do diretório virtual do Portal de Negócios:
C:\Arquivos de Programas\Microsoft Dynamics\Portal de Negócios
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Clique com o botão direito do mouse na pasta e clique em Propriedades.
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Na guia Segurança, clique em Adicionar.
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No campo Inserir os nomes de objeto a ser selecionado, digite o seguinte e clique em OK:
ComputerName\ASPNET Note Substitua o espaço reservado ComputerName pelo nome do computador que está executando o Portal de Negócios.
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Na área Permissões, habilita as seguintes opções na lista Permitir e clique em OK:
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Ler & Executar
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Listar Conteúdo da Pasta
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Leitura
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Clique em Salvar para fechar a janela e reinicie Serviços de Informações da Internet (IIS).
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Conceda as permissões necessárias para a conta de Serviço de Rede. Para fazer isso, siga estas etapas:
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No Windows Explorer, localize a pasta do aplicativo para o site. Ou localize a pasta do diretório virtual. Veja a seguir o local padrão do diretório virtual do Portal de Negócios:
C:\Arquivos de Programas\Microsoft Dynamics\Portal de Negócios
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Clique com o botão direito do mouse na pasta e clique em Propriedades.
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Na guia Segurança, clique em Adicionar.
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No campo Inserir os nomes de objeto a ser selecionado, digite Serviço de Rede.
Observação Esta conta de usuário é uma conta de usuário local. -
Na área Permissões, habilita as seguintes opções na lista Permitir e clique em OK:
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Ler & Executar
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Listar Conteúdo da Pasta
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Leitura
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Clique em Salvar para fechar a janela e reinicie o IIS.
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Método 2
Certifique-se de que os nomes de pasta no caminho do site contenham menos de nove caracteres.
Observações
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Para determinar os nomes de pastas no caminho, siga estas etapas:
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No Gerenciador do IIS, clique com o botão direito do mouse no site no qual o Portal de Negócios está instalado e clique em Propriedades.
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Clique na guia Diretório Home e, em seguida, anote os nomes de pasta do caminho na caixa Caminho Local.
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Se você renomear uma pasta para que o nome da pasta contenha menos de nove caracteres, será preciso fazer a mesma alteração no IIS para o site. Depois de fazer a alteração, pare e inicie o IIS.
Informações adicionais
Para obter mais informações, clique nos seguintes números de artigo para exibir os artigos na Base de Dados de Conhecimento da Microsoft:
317955 mensagem de erro "Falha ao iniciar o monitoramento de alterações de diretório" quando você navega para uma página ASP.NET página
316721 Mensagem de erro "Falha ao iniciar o monitoramento de alterações de diretório" quando você navega para ASP.NET página