Sintomas
Você recebe a seguinte mensagem de erro no Portal de Negócios para o Microsoft Dynamics GP:
Erro do servidor no aplicativo '/'.
Não é possível serializar o estado da sessão. No modo 'StateServer' e 'SQLServer', o ASP.NET serializará os objetos de estado da sessão e, como resultado, objetos não serializáveis ou objetos MarshalByRef não são permitidos. A mesma restrição se aplica se a serialização semelhante for feita pelo armazenamento de estado de sessão personalizado no modo 'Personalizado'.
Esse problema ocorrerá se uma das seguintes condições for verdadeira:
-
Clique para selecionar a caixa de seleção Exigir Horário de Início/Parada no Pacote de Autoatendados de Gerenciamento de Recursos Humanos no Portal de Negócios.
-
Você salva um quadro de horários Project Tempo & Despesas para o Microsoft Dynamics GP.
-
Você cria uma nova requisição no Gerenciamento de Requisitos para o Microsoft Dynamics GP.
Causa
Esse problema ocorre porque outro aplicativo altera o <modo sessionState> elemento no arquivo Web.config.
Resolução
Para resolver esse problema, altere o elemento <sessionState> para usar os parâmetros necessários para o Portal de Negócios. Para fazer isso, siga estas etapas:
-
Localize o Web.config para Portal de Negócios. Esse arquivo está localizado no diretório virtual na pasta Inetpub no servidor no qual o Portal de Negócios está instalado. Por exemplo, esse arquivo pode estar no seguinte local:
C:\Inetpub\wwwroot\wss\VirtualDirectories\81
-
Faça uma cópia do arquivo Web.config.
-
Em Bloco de notas ou em outro editor de texto, abra o arquivo Web.config de texto.
-
No menu Editar, clique em Encontrar.
-
Na caixa Encontrar o que, digite sessionState mode e clique em Encontrar Próximo.
-
Verifique se o <modo sessionState> elemento aparece da seguinte forma.
<sessionState mode="InProc" />
-
Se o elemento <modo sessionState> não usar o valor do atributo "InProc", edite o elemento <> modo> sessionState para usar o valor do atributo "InProc".
-
Salve o Web.config arquivo.
-
Para habilitar as alterações no arquivo Web.config, execute o comando iisreset. Para fazer isso, siga estas etapas:
-
No servidor no qual o Portal de Negócios está instalado, clique em Iniciare clique em Executar.
-
Digite o seguinte comando na caixa Abrir e pressione ENTER:
iisreset
-