Não é possível resolver um nome de subdomínio porque o cache negativo é contagem regressiva em um servidor DNS que esteja executando o Windows Server 2012 R2

Sintomas

Considere o seguinte cenário:

  • Configurar uma autoridade Domain Name System (DNS) que tenha uma zona como contoso.com em um servidor que esteja executando o Windows Server 2012 R2.

  • Configurar o tempo de vida (TTL) para o registro de recurso início de autoridade (SOA) em 1 (um) minuto. Deixe a zona mínima TTL definido na SOA em sua configuração padrão de 1 (uma) hora.

  • Configurar um servidor recursivo que usa um encaminhador condicional para a zona de contoso.com. O encaminhador condicional aponta para o servidor que está configurado no primeiro ponto de marcador.

  • No servidor recursivo, você deve consultar o localhost para um registro de subdomínio não existe na região, como sales.contoso.com. Observe que você receberá uma resposta que contém a SOA, conforme configurado no TTL de 3600 (não 60, que é o valor correto por RFC do DNS).

  • Consultar o mesmo registro de subdomínio inexistente novamente e observe que o cache negativo é contagem regressiva.

  • Você pode criar o registro do subdomínio "vendas" no servidor autoritativo. Em seguida, repita item com marcador 3 a consulta para este novo registro.


Nesse cenário, você não pode resolver o nome de subdomínio porque o cache negativo ainda é contagem regressiva.

Causa

Quando o sistema de nomes de domínio (DNS) responde enviando uma resposta de autoridade vazio ou um erro de nome, o TTL do registro SOA na resposta deve ser o TTL mínimo para o TTL SOA e o TTL mínimo SOA.

No entanto, um servidor DNS baseados no Windows Server 2012 R2 recursiva incorretamente sempre usa o TTL mínimo de SOA quando ele calcula o valor TTL. Esse hotfix força o servidor a usar o valor mínimo para o TTL SOA e o TTL mínimo SOA.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft Support. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e Suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

Observação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Para aplicar esta atualização no Windows Server 2012 R2, você deve primeiramente ter a atualização instalada.

Requisitos de reinicialização:

Você não precisa reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:

Esse hotfix não substitui nenhum hotfix lançado anteriormente.

A versão em inglês (Estados Unidos) deste hotfix instala arquivos que possuem os atributos listados nas tabelas a seguir. As datas e horas desses arquivos estão listadas no Tempo Universal Coordenado (UTC). As datas e horas desses arquivos em seu computador local são exibidas em sua hora local com a diferença de horário de verão (DST) atual. Além disso, as datas e as horas podem ser alteradas quando você realizar determinadas operações nos arquivos.

Notas e informações de arquivo do Windows Server 2012 R2Importante: Os hotfixes do Windows 8.1 e o Windows Server 2012 R2 estão incluídos nos pacotes para o mesmos. No entanto, apenas "Windows 8.1" é listado na página solicitação de Hotfix. Para solicitar o pacote de hotfix que se aplica a um ou ambos os sistemas operacionais, selecione o hotfix listado em "Windows 8.1" na página. Sempre consulte a seção "Aplicar a" nos artigos para determinar o sistema operacional real que cada hotfix se aplica.

  • Os arquivos que se aplicam a um produto, etapa (RTM, SPn) e ramificação do serviço (LDR, GDR) podem ser identificados ao examinar os números da versão do arquivo conforme mostrado na tabela a seguir.

  • Os arquivos MANIFEST (. manifest) e os arquivos MUM (. mum) instalados para cada ambiente são listados separadamente na seção "Informações adicionais sobre arquivos para Windows 8.1 e do Windows Server 2012 R2". MUM e arquivos de manifesto e os arquivos de catálogo (. cat) de segurança associadas são extremamente importantes para manter o estado dos componentes atualizados. Os arquivos do catálogo de segurança, para os quais os atributos não estejam listados, são assinados com uma assinatura digital da Microsoft.

Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Referências

Saiba mais sobre a usada pela Microsoft para descrever as atualizações de software.

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×