O computador para de responder quando você renomear uma pasta no Windows Server 2008, no Windows Vista, no Windows 7 e no Windows Server 2008 R2

Sintomas

Considere o seguinte cenário:

  • Você tem um computador que esteja executando o Windows Server 2008, Windows Vista, Windows 7 ou Windows Server 2008 R2.

  • Não há um volume em um sistema de arquivos NTFS neste computador. Há muitos dos arquivos que estão em uma pasta neste volume. Por exemplo, suponha que há mais de 5000 arquivos nesta pasta.

  • Muitos arquivos na pasta foram abertos anteriormente pelo menos uma vez.

  • Você tentar renomear a pasta.

Nesse cenário, o computador para de responder por algum tempo. Portanto, o computador responde a um botão do mouse clique ou para uma tela de atualização muito lentamente.

Observação: Se o recurso cluster de Failover está instalado no computador, os recursos de cluster que são hospedados no computador failover em outros nós devido a esse problema.

Causa

A operação de renomeação de um diretório verifica se um arquivo na pasta é aberto por um usuário. Durante a operação, um bloqueio de bloco (VCB) de controle de volume é obtido e quaisquer outras solicitações de i/o para o volume são bloqueadas. Se o número de arquivos no diretório for grande, esse processo de verificar se um arquivo for aberto pode levar um tempo longo desnecessariamente. Portanto, o computador para de responder por esse tempo. No entanto, o computador recupera eventualmente.

Resolução

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

Observação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Para aplicar esse hotfix, você deve estar executando um dos seguintes sistemas operacionais:

  • Windows Vista Service Pack 1 (SP1)

  • Windows Vista Service Pack 2 (SP2)

  • Windows Server 2008

  • Windows Server 2008 Service Pack 2 (SP2)

  • Windows 7

  • Windows Server 2008 R2



Para obter mais informações sobre como obter um service pack do Windows Vista, clique no número abaixo para ler o artigo na Base de Conhecimento da Microsoft:

como obter o service pack mais recente para o Windows Vista

Para obter mais informações sobre como obter um service pack do Windows Server 2008, clique no número abaixo para ler o artigo na Base de Conhecimento da Microsoft:

como obter o service pack mais recente para o Windows Server 2008

Informações do registro:

Para usar o hotfix neste pacote, não é necessário efetuar quaisquer alterações no registro.

Requisitos de reinicialização:

Você terá que reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações sobre o arquivo:

A versão global deste hotfix instala arquivos que possuam os atributos listados nas tabelas a seguir. As datas e horas desses arquivos estão listadas no Tempo Universal Coordenado (UTC). As datas e horas desses arquivos em seu computador local são exibidas em sua hora local com a diferença de horário de verão (DST) atual. Além disso, as datas e as horas podem ser alteradas quando você realizar determinadas operações nos arquivos.

Informações sobre o arquivo do Windows Vista e Windows Server 2008

Importante: Os hotfixes do Windows Vista e Windows Server 2008 hotfixes estão incluídos nos pacotes para o mesmos. No entanto, apenas "Windows Vista" é listado na página solicitação de Hotfix. Para solicitar o pacote de hotfix que se aplica a um ou ambos os sistemas operacionais, selecione o hotfix listado em "Windows Vista" na página. Sempre consulte a seção "Aplica-se a" nos artigos para determinar o sistema operacional real que cada hotfix se aplica.

  • Os arquivos que se aplicam a um produto específico, SR_Level (RTM, SPn) e ramificação do serviço (LDR, GDR) podem ser identificados ao examinar os números de versão do arquivo conforme mostrado na tabela a seguir:

  • Os arquivos MANIFEST (. manifest) e os arquivos MUM (. mum) instalados para cada ambiente são listados separadamente na seção "Informações adicionais sobre arquivos para Windows Server 2008 e Windows Vista". Os arquivos MUM e arquivos de manifesto e os arquivos de catálogo (. cat) de segurança associadas são extremamente importantes para manter o estado do componente atualizado. Os arquivos do catálogo de segurança, para os quais os atributos não estejam listados, são assinados com uma assinatura digital da Microsoft.

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×