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Sintomas

Você pode enfrentar um ou mais dos seguintes problemas no Windows Small Business Server (SBS) 2011.

Ao instalar o Windows SBS 2011, você recebe uma ou mais das seguintes mensagens de erro:

  • Instalação: Aqui está a lista de erros encontrados durante a instalação.

  • Instalação: O Exchange Server 2010 não pode ser instalado

  • ConfigureWSSOutgoingEmailTask: Os emails de entrada e saída para o Microsoft SharePoint Foundation não estão configurados.

Após instalar o Windows SBS 2011, os seguintes problemas ocorrem:

  • O Exchange Server 2010 é executado em um modo de avaliação e exige uma chave de ativação.

  • Não é possível criar novos usuários no Console do Windows SBS.

  • Não é possível aplicar funções aos usuários no Console do Windows SBS.

  • Não é possível concluir o Assistente "Conectar à Internet" ou o Assistente "Gerenciamento de Endereço de Internet".

Quando você abre o Console de Gerenciamento do Exchange em um computador executando o Windows SBS 2011, você receberá a seguinte mensagem:

Os seguintes servidores na sua organização executando o Exchange Server 2010 estão sem licença no momento.

Observação Esta mensagem também exibe o nome do computador executando o Windows SBS 2011 Standard.

Causa

Estes problemas podem ocorrer se uma das seguintes condições for verdadeira:

  • Condição 1

    Durante a instalação do Windows SBS 2011, o Exchange Server 2010 não é instalado. O Exchange Server 2010 foi instalado posteriormente de forma manual.

  • Condição 2

    O Exchange Server 2010 foi desinstalado do Windows SBS 2011 e foi reinstalado.

  • Condição 3

    Uma instalação de reparo do Exchange Server 2010 foi concluída no servidor do Windows SBS 2011.

Resolução

Para resolver o problema da Condição 1 ou da Condição 2, siga as etapas na seção "Scrip do PowerShell para resolver problemas do Exchange Server". Instale o hotfix descrito na seção "Informações de Hotfix".

Para resolver o problema enfrentado na Condição 3, instale o hotfix descrito na seção "Informações de Hotfix".

Script do PowerShell para resolver problemas do Exchange Server




Importante Antes de concluir essas etapas, o Exchange Server 2010 deve ser instalado corretamente. Não conclua as etapas descritas neste artigo se as seguinte funções do Exchange Server 2010 não estiverem instaladas corretamente:

  • Caixa de correio

  • Hub/Transporte

  • CAS (Servidor de acesso do cliente)

  • Gerenciamento

As seguintes etapas definem o Exchange Server 2010 para as configurações padrões de uma instalação bem-sucedida do Windows SBS 2011.

Observação Se você definiu manualmente as configurações no Exchange, as configurações podem ser alteradas e o fluxo de email pode parar até você concluir os assistentes corretos para o Windows SBS ou até que o Exchange Server seja reconfigurado. Além disso, você deve ter uma topologia de rede suportada de um adaptador de rede único e de uma subrede de Classe C.

Estas etapas fazem as seguintes alterações:

  • Define o nome do Banco de dados da caixa de correio no Registro

  • Corrige a versão da função de ferramentas administrativas no Registro

  • Adiciona um valor padrão do atributo msSBSEmailQuota do Active Directory para as três funções padrões do Windows SBS

  • Configura as funções de segurança corretas para gerenciar o servidor executando o Exchange Server

  • Adiciona permissões no nível organizacional para oferecer acesso à conta do sistema

  • Cria os seguinte grupos, se os grupos não foram criados:

    • SBSAdmins

    • Allusers

    • Postmaster

    • FSRMReports

  • Define a mesma associação e configurações para cada um desses grupos

  • Define as configurações de transporte para servidores internos e um endereço de postmaster

  • Religa o conector de recepção padrão para a rede interna, não incluindo o IP interno do roteador

  • Exclui o conector de recepção cliente padrão

  • Habilita o certificado emitido por conta própria do Windows SBS que possui CN = Sites

  • Remove o certificado auto-assinado do Exchange Server

  • Define as configurações de mensagem de email de saída no Microsoft SharePoint

  • Adiciona um Registro de host no DNS para o servidor SMTP (Simple Mail Transfer Protocol) do SharePoint

  • Adiciona várias chaves de Registro para remover os problemas de instalação

  • Ativa o Exchange Server usando a ferramenta fornecida

Para resolver estes problemas se o Exchange Server 2010 foi instalado manualmente após a instalação do Windows SBS 2011 ou se o Exchange Server 2010 foi reinstalado no servidor do Windows SBS 2011, siga estas etapas:

  1. Selecione o comando Executar como administrador para executar o Shell de Gerenciamento do Exchange em um modo elevado.

  2. No Shell de Gerenciamento do Exchange, execute o seguinte comando nesta ordem:

    #SBS 2011 Std
    #Iniciar pelo Shell de Gerenciamento do Exchange como um administrador.
    #Esse script conclui as tarefas restantes após uma falha na instalação do Exchange durante uma migração.

    # Executar cada seção, separada pelos comentários individualmente.

    ##A instalação do Exchange deve ser concluída usando os parâmetros adequados antes de executar esse script.


    ##Configurar o Nome da Caixa de Correio no Registro
    $mbx = Get-MailboxDatabase -server $env:COMPUTERNAME
    Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Messaging" -name "MailboxDatabaseName" -value $mbx.Name

    ##Adicionar uma chave de Registro para as ferramentas administrativas. Isso é necessário devido a maneira que o SBSSetup é empacotado.
    $Version = get-itemproperty "HKLM:\Software\Microsoft\ExchangeServer\V14\AdminTools"
    Set-ItemProperty "HKLM:\Software\Microsoft\ExchangeServer\V14\AdminTools" -name "ConfiguredVersion" -value $Version.UnpackedVersion

    ##Configurar o atributo do Exchange nas funções de usuário. Isso pode falhar se as funções de usuário estão ausentes.
    Import-Module ActiveDirectory
    set-aduser "Standard User" -Add @{msSBSEmailQuota=2097152}
    set-aduser "WebWorkplaceTools" -Add @{msSBSEmailQuota=2097152}
    set-aduser "Network Admin" -Add @{msSBSEmailQuota=2097152}

    ##ExchangeAdminPrep
    Add-RoleGroupMember -Identity "Organization Management" -Member "$env:USERDOMAIN\Domain Admins" -BypassSecurityGroupManagerCheck
    Add-RoleGroupMember -Identity "View-Only Organization Management" -Member "$env:USERDOMAIN\$env:COMPUTERNAME$" -BypassSecurityGroupManagerCheck
    $org = Get-OrganizationConfig
    add-adpermission -Identity $org.DistinguishedName -User "SYSTEM" -AccessRights "GenericAll" -InheritanceType "All"

    ##CreateMailDisributionGroupsTask
    # Se os grupos já existem, você pode receber um erro. Isso está correto, é só um sinal de que a instalação do SBS foi realizada várias vezes e a fonte nunca foi restaurada de um backup.

    New-DistributionGroup -SamAccountName "sbsadmins" -Alias "sbsadmins" -Name "Windows SBS Administrators" -OrganizationalUnit $env:USERDNSDOMAIN"/MyBusiness/Distribution Groups" -Type "Distribution" -ErrorAction SilentlyContinue

    New-DistributionGroup -SamAccountName "allusers" -Alias "allusers" -Name "All Users" -OrganizationalUnit $env:USERDNSDOMAIN"/MyBusiness/Distribution Groups" -Type "Distribution" -ErrorAction SilentlyContinue

    Enable-DistributionGroup -Identity "All Users" -Alias "allusers" -WarningAction SilentlyContinue -ErrorAction SilentlyContinue

    Enable-DistributionGroup -Identity "Windows SBS Administrators" -Alias "sbsadmins" -WarningAction SilentlyContinue -ErrorAction SilentlyContinue

    Set-DistributionGroup -RequireSenderAuthenticationEnabled $false -Identity "Windows SBS Administrators" -ForceUpgrade

    New-DistributionGroup -SamAccountName "postmaster" -Alias "postmaster" -Name "Postmaster and Abuse Reporting" -OrganizationalUnit $env:USERDNSDOMAIN"/MyBusiness/Distribution Groups" -Type "Distribution" -WarningAction SilentlyContinue -ErrorAction SilentlyContinue

    Set-DistributionGroup -Identity "Postmaster and Abuse Reporting" -RequireSenderAuthenticationEnabled $false -HiddenFromAddressListsEnabled $true -EmailAddresses "SMTP:postmaster@$env:USERDNSDOMAIN","SMTP:abuse@$env:USERDNSDOMAIN" -EmailAddressPolicyEnabled $false -ForceUpgrade -WarningAction SilentlyContinue -ErrorAction SilentlyContinue

    Add-DistributionGroupMember -Identity "Postmaster and Abuse Reporting" -Member "Windows SBS Administrators"

    New-DistributionGroup -SamAccountName "fsrmreports" -Alias "fsrmreports" -Name "File Server Resource Manager Reports" -OrganizationalUnit $env:USERDNSDOMAIN"/MyBusiness/Distribution Groups" -Type "Distribution" -WarningAction SilentlyContinue -ErrorAction SilentlyContinue

    Set-DistributionGroup -Identity "File Server Resource Manager Reports" -HiddenFromAddressListsEnabled $true -ForceUpgrade
    Add-DistributionGroupMember -Identity "File Server Resource Manager Reports" -Member "Windows SBS Administrators"

    ##ConfigureIntranetSMTPTask

    Set-TransportConfig -InternalSMTPServers 127.0.0.1
    set-transportconfig -ExternalPostmasterAddress "postmaster@$env:USERDNSDOMAIN"

    ##rebind Default receive connector
    # Esta seção alterará o conector de recepção padrão para detectar apenas na subrede interna (sem roteador). O fluxo de email pode parar neste ponto.

    $ip=(gwmi Win32_NetworkAdapterConfiguration | ? { $_.IPAddress -ne $null }).ipaddress.get(0)
    $gateway=(gwmi Win32_NetworkAdapterConfiguration | ? { $_.IPAddress -ne $null }).DefaultIPGateway
    $gw="$gateway"
    $gwIp=$gw.split('.')
    $subnet=$gw.Remove($gw.LastIndexOf('.'))+".0"
    $range=$subnet+"-"+$gw.Remove($gw.LastIndexOf('.'))+"."+($gwIp.get(3)-1)+","+$gw.Remove($gw.LastIndexOf('.'))+"."+([int]$gwIp.get(3)+1)+"-"+$gw.Remove($gw.LastIndexOf('.'))+".255"

    $con = get-receiveconnector -Identity "Default $env:computername"
    $ip+=":25"
    $con.Bindings=$ip
    set-receiveconnector -Identity "Default $env:computername" -Bindings $con.Bindings

    $ipAdd= $range.Split(',')
    $con.remoteipranges = $ipAdd[0]
    $con.remoteipranges += $ipAdd[1]

    set-receiveconnector -Identity "Default $env:computername" -RemoteIpRanges $con.remoteipranges


    ##delete default client receive connector
    # Se estiver em uso no momento, esta etapa precisa ser pulada ou o conector recriado.
    remove-receiveconnector -Identity "Client $env:computername" -Confirm:$false

    ##Remover o certificado do exchange padrão e ativar o nosso certificado
    Get-ExchangeCertificate | ? {$_.Subject -eq "CN=Sites"} | Enable-ExchangeCertificate -services SMTP -force:$true
    #remove
    Get-ExchangeCertificate | ? {$_.FriendlyName -eq "Microsoft Exchange"} | Remove-ExchangeCertificate

    ##Novo conector de recepção
    #Criar o conector de recepção interno para o SharePoint, o fax e o conector POP3

    new-receiveconnector -Name "Windows SBS Fax Sharepoint Receive $env:computername" -RemoteIPRanges 127.0.0.1-127.0.0.1 -Bindings "127.0.0.1:25" -AuthMechanism "BasicAuth" -PermissionGroups "AnonymousUsers, ExchangeUsers" -Usage "Custom" -Server "$env:COMPUTERNAME" -ConnectionTimeout "00.06:00:00"


    ##ConfigureWSSOutgoingEmailTask
    # Configura o roteamento de email de saída do SharePoint para usar o Exchange.
    # Isto pode não funcionar se o SharePoint não estiver usando as configurações padrões ou não estiver funcionando.

    Add-PsSnapin Microsoft.SharePoint.PowerShell
    $spWebApp=Get-SPWebApplication
    $mail="CompanyWebAdmin@"+$env:userdnsdomain
    $spWebApp.UpdateMailSettings("SharepointSMTPServer",$mail,$mail,65001)
    dnscmd $env:computername /recordadd $env:userdnsdomain SharepointSMTPServer A 127.0.0.1

    ##Adicionar componentes de mensagens da chave de Registro
    $val = get-itemproperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Components\"
    Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Components" -name "Messaging" -value $val.administration

    ##Corrigir problemas de exibição
    Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Setup" -name "DisplayIssues" -value False

    ##Marca d´água do script da tag
    $date=Get-Date
    Set-ItemProperty "HKLM:\SOFTWARE\Microsoft\SmallBusinessServer\Setup" -name "RepairScript" -value "ExchangeFailureCompleteSetup $date"

  3. Adicione usuários usando o Console do Windows SBS.

  4. Conclua o Assistente "Gerenciamento de Endereço da Internet".

  5. Instale o pacote de hotfixies relacionado para ativar o Exchange Server.

Vá para a próxima seção para instalar o pacote de hotfixies para ativar o Exchange Server.

Informações do hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix estiver disponível para download, haverá uma seção "Baixar hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se essa seção não for exibida, envie uma solicitação ao Suporte e Atendimento ao Cliente da Microsoft para obter o hotfix.

Observação Caso outros problemas ocorram ou qualquer solução de problemas seja necessária, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem a esse hotfix. Para obter uma lista completa dos números de telefone do Suporte e Atendimento ao Cliente da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ln=pt-br&ws=support#tab0Observação O formulário "Baixar hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso seu idioma não seja exibido, não há um hotfix disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve estar executando o Windows Small Business Server 2011.

Informações do Registro

Para usar o hotfix nesse pacote, não é necessário realizar nenhuma mudança no Registro.

Requisitos de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix

Esse hotfix não substitui nenhum hotfix lançado anteriormente.

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