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Importante: Este artigo contém informações sobre como modificar o registro. Certifique-se de fazer backup do registro antes de modificá-lo. Certifique-se de que você saiba como restaurar o registro caso ocorra um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de Conhecimento Microsoft:

256986 descrição do registro do Microsoft Windows

Sintomas

Em um controlador de domínio que esteja executando o Microsoft Windows Server 2003, o processo do servidor de autenticação de segurança Local (Lsass.exe) pode parar de responder se as seguintes condições forem verdadeiras:

  • Você tem muitas relações de confiança externas e várias solicitações simultâneas de logon.

  • Essas solicitações de logon não especificar o nome do domínio.

Sintomas adicionais podem ser lentas ou atrasadas autenticação para usuários solicitando autenticação de legado (NTLM). Além disso, se monitorar o objeto de desempenho Netlogon, o contador de desempenho de tempo médio do semáforo mantenha pode mostrar atrasos para os usuários de outros domínios.

Causa

Esse problema ocorre porque o processo de Lsass.exe é executado sem recursos se o número de logons simultâneos multiplicados pelo número de relações de confiança seja maior que 1.000.

Resolução

Aviso: Problemas sérios podem ocorrer se você modificar o Registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir a reinstalação do sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro de sua responsabilidade.

Para resolver esse problema, aplique o service pack mais recente para o Windows Server 2003 ou o seguinte hotfix. Em seguida, habilite a configuração de NeverPing .

Importante: Essa configuração pode causar efeitos colaterais indesejáveis se você tem clientes que não especifique nomes de domínio nas solicitações de logon. Esses clientes podem incluir clientes Microsoft Windows 98 e o Outlook Web Access. Esses clientes funcionam corretamente se as contas de usuário de logon solicita uso estão no domínio do Windows Server 2003 ou no catálogo global. Problemas ocorrem apenas se uma conta de usuário estiver em um domínio externo.

Para habilitar a configuração de NeverPing , execute essas etapas:

  1. Clique em Iniciar, clique em Executar, digite Regedite, em seguida, clique em OK.

  2. Localize a seguinte subchave do registro:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters

  3. Clique com botão direito nesta subchave, aponte para novoe, em seguida, clique em Valor DWORD.

  4. Digite NeverPing como o nome da entrada do registro e pressione ENTER.

  5. Clique duas vezes em NeverPing, digite 1 na caixa de texto dados do valor e, em seguida, clique em OK.

  6. Saia do Editor de Registro.

Informações do service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número de artigo a seguir para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:

889100 como obter o service pack mais recente para o Windows Server 2003

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente aos sistemas que apresentarem esse problema específico. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportObservação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Não existem pré-requisitos.

Requisitos de reinicialização:

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo:

A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas na Hora Universal Coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.

Windows Server 2003, versões com base em x86

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Netlogon.dll

5.2.3790.573

419,328

08-Aug-2006

13:01

x86

Windows Server 2003, versões com base em Itanium

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Ramificação do serviço

Netlogon.dll

5.2.3790.573

959,488

07-Aug-2006

21:58

IA-64

RTMQFE

Wnetlogon.dll

5.2.3790.573

419,328

07-Aug-2006

22:01

x86

WOW

Status

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Windows Server 2003 Service Pack 2.

Mais informações

Esse problema ocorre quando os aplicativos usam a autenticação NTLM herdada e não enviar o domínio em que o usuário está associado ao enviar uma solicitação de autenticação. Quando o comportamento herdado é exigido pelo cliente os controladores de domínio devem usar métodos herdados para localizar o domínio do usuário correta para que o domínio autoritativo para que o usuário possa fornecer verificação de credenciais do usuário. O comportamento herdado é uma comunicação de rede sequencial com cada controlador de domínio do domínio relações de confiança. Esse problema piora quando há maior número de domínios e do número de solicitações de autenticação não tem a parte de domínio das credenciais de usuários.


Esse problema pode ser identificado em Netlogon logs de depuração do serviço nos controladores de domínio procurando por entradas de SamLogon que exibem "< nulll > \username". Basta pesquisar os logs para "< null > \" revelará se o problema está ocorrendo em todos os.

Esse problema pode agravar os gargalos de desempenho de autenticação existentes. Para obter mais informações sobre isso, consulte o artigo da Base de Conhecimento:

975363 São solicitadas credenciais intermitentemente ou enfrentar tempos limite quando você se conectar a serviços autenticados

Para obter mais informações sobre um problema semelhante no Microsoft Windows 2000, clique no número abaixo para ler o artigo na Base de Conhecimento da Microsoft:

825107 Lsass.exe o processo pode parar de responder se você tiver várias relações de confiança externas em um controlador de domínio baseado no Windows 2000 Server

Em algumas situações, os problemas de desempenho ainda podem ser vistos mesmo depois de definir a configuração Neverping. Nesses casos o MaxConcurrentApi configuração deve ser definida para um valor mais alto. Para obter mais informações sobre como estimar a melhor configuração de MaxConcurrentApi podem ser encontradas no artigo do Knowledge Base abaixo.

2688798 como fazer o ajuste de desempenho para a autenticação NTLM, usando a configuração MaxConcurrentApi

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