Word não salva alterações ou você recebe uma mensagem de erro em um programa do Office depois de instalar o Adobe Acrobat 7.0

Importante

Este artigo descreve um problema de compatibilidade conhecido entre o Adobe Acrobat 7.0 e versões anteriores do Microsoft Office. Se estiver a utilizar uma versão atual do Microsoft 365 ou uma versão mais recente do Adobe Acrobat, este artigo poderá não se aplicar ao seu ambiente.

Sintomas

Quando utiliza um programa do Microsoft Office listado na secção "Aplica-se a", poderá detectar um ou mais dos seguintes sintomas:

  • Quando altera a área de trabalho no Microsoft Word, as alterações não são guardadas quando sai do Word. Estas alterações à área de trabalho incluem os seguintes exemplos:

    • Criar uma macro.
    • Pode alterar o tipo de letra predefinido.
    • Adiciona uma entrada de texto automático.
    • Adicionar uma barra de ferramentas.
  • Quando reinicia o Word, os itens que alterou ou adicionou não estarão disponíveis.

    Observação Esse comportamento ocorre mesmo se a caixa Solicitar para salvar o modelo Normal marcar estiver marcada.

  • Quando tenta iniciar um programa do Office, recebe uma mensagem de erro semelhante a uma das seguintes:

    Observação

    Erro de tempo de execução do Visual C++

    Observação

    Biblioteca de runtime do Microsoft Visual C++

    Program files\Microsoft office\office10\product name.exe

    This application has requested the runtime to terminate it in an unusual way.

  • Quando abre um documento Word, recebe a seguinte mensagem de erro:

    Observação

    Não há memória ou espaço em disco insuficiente. Word não pode apresentar o tipo de letra pedido.

  • Quando Word é fechado, faça duplo clique num ficheiro para o abrir no Word. Neste cenário, Word deixa de responder (bloqueia).

Causa

Esses problemas podem ocorrer depois de instalar o Adobe Acrobat 7.0 Professional, Adobe Acrobat 7.0 Standard ou Adobe Acrobat 7.0 Elements.

O Acrobat 7.0 instala um suplemento COM na seguinte pasta:

\Acrobat 7.0\PDFMaker\OfficeEste suplemento COM fornece ícones PDFMaker e comandos de menu para programas do Office.

Solução alternativa

Para contornar este problema, utilize um dos seguintes métodos consoante a sua situação. Se as alterações não forem guardadas quando sair do Word, utilize o método 1 ou o método 2. Se receber uma mensagem de erro quando tentar iniciar um programa do Office ou quando tentar abrir um documento Word, utilize o método 3 ou o método 4.

Método 1: Guardar macros, preferências e definições personalizadas no Word utilizando o comando "Guardar Tudo" no menu Ficheiro

Observação Esse método não se aplica ao Microsoft Office Word 2007.

Para guardar manualmente macros, preferências e definições personalizadas no Word 2003 e em versões anteriores do Word, siga estes passos:

  1. Prima sem soltar a tecla SHIFT.
  2. No menu Arquivo , clique em Salvar Tudo.

As alterações são guardadas. Além disso, as alterações estão disponíveis noutros documentos Word.

Método 2: adicionar o comando "Guardar Tudo"

No Word, clique no comando Guardar Tudo sempre que criar uma macro, uma preferência ou uma definição personalizada.

Para adicionar o comando Guardar Tudo ao Word, execute uma das seguintes ações:
 

  • No Word 2007, siga estes passos para adicionar o comando Guardar Tudo à Barra de Ferramentas de Acesso Rápido:

    1. Clique no Botão do Microsoft Office e em Opções do Word.
    2. Clique em Personalizar.
    3. Na caixa Escolher comandos de , clique em Todos os Comandos.
    4. Na lista na caixa Escolher comandos de , clique em Guardar Tudo e, em seguida, clique em Adicionar.
    5. Clique em OK para fechar a caixa de diálogo Opções do Word.
  • No Word 2003 e em versões anteriores do Word, siga estes passos para adicionar o comando Guardar Tudo ao menu Ficheiro:

    1. No menu Ferramentas, clique em Personalizar.
    2. Na guia Comandos , clique em Arquivo em Categorias.
    3. Em Comandos, arraste Guardar Tudo para o menu Ficheiro . Quando o menu Ficheiro for aberto, coloque o comando Guardar Tudo onde pretende.
    4. Feche a caixa de diálogo Personalizar .

Método 3: contactar a Adobe

Entre em contato com a Adobe Systems Incorporated para determinar se uma atualização está disponível para o Acrobat 7.0.

A Microsoft fornece informações de contato de terceiros para ajudá-lo a encontrar suporte técnico. Essas informações de contato podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações para contato com outras empresas.

Método 4: remover o suplemento da Adobe do Office

Se remover o suplemento da Adobe, não pode guardar um ficheiro como um ficheiro PDF (Portable Document File) num programa do Office.

Para remover o suplemento da Adobe, siga estas etapas.

Observação Como há várias versões do Microsoft Windows, as etapas a seguir podem ser diferentes no seu computador. Se esse for o caso, consulte a documentação do produto para concluir essas etapas.

  1. Feche todos os programas.
  2. Clique em Iniciar, aponte para Configurações e clique em Painel de Controle.
  3. Clique duas vezes em Adicionar ou Remover Programas.
  4. Em Programas atualmente instalados, clique em Adobe Acrobat Professional 7.0 e, em seguida, clique em Alterar.
  5. Clique em Modificar e, em seguida, clique em Seguinte.
  6. Expanda Criar Adobe PDF.
  7. Expanda o Acrobat PDFMaker.
  8. Clique na seta junto a Microsoft Office e, em seguida, clique em Não instalado.
  9. No assistente de instalação do Adobe Acrobat Professional 7.0, clique em OK.
  10. Feche Adicionar ou Remover Programas.

Se você ainda estiver enfrentando os sintomas mencionados anteriormente depois de concluir essas etapas, convém remover manualmente o suplemento da Adobe do Registro.

Importante Antes de remover manualmente o suplemento da Adobe, entre em contato com a Adobe para obter mais informações.

Importante Esta seção, seção ou tarefa contém etapas que informam como modificar o Registro. No entanto, podem ocorrer problemas graves se você modificar o registro incorretamente. Portanto, fique atento e siga estas etapas com atenção. Para se proteger ainda mais, faça o backup do registro antes de modificá-lo. Dessa forma, se ocorrer algum problema, você poderá restaurar o Registro. Para obter mais informações sobre como fazer o backup e a restauração do Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:

322756 Como fazer o backup e a restauração do Registro no Windows

Para remover manualmente o suplemento da Adobe, siga estas etapas:

  1. Clique em Iniciar e em Executar, digite regedit e clique em OK.

  2. Localize e clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin

  3. No menu Arquivo , clique em Exportar, digite um nome de arquivo e clique em Salvar.

  4. Clique com o botão direito do rato na entrada de registo PDFMaker.OfficeAddin e, em seguida, clique em Eliminar.

  5. Execute os passos 3 e 4 para eliminar as entradas de registo do suplemento nas seguintes subchaves do registo:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\PDFMaker.OfficeAddin

       

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook

  6. Saia do Editor do Registro.

Mais informações

O modelo global (o ficheiro Normal.dotm no Word 2007 e o ficheiro Normal.dot no Word 2003 e em versões anteriores do Word) é o modelo predefinido utilizado pelo Word. Por padrão, as alterações que afetam todos os novos documentos são salvas no modelo global. Esse comportamento ocorre a menos que você especifique outro modelo ao salvar as alterações. O Acrobat 7.0 pode impedir que o Word salve automaticamente as alterações no modelo global.

Para obter mais informações sobre esse problema, acesse o seguinte site da Adobe:

http://www.adobe.com/products/acrobat.html?promoid=IUGXF