Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

Sintomas

Considere o seguinte cenário:

  • Você tem um servidor de impressão baseado no Windows Server 2008.

  • Este servidor de impressão possui vários clientes de impressora baseado no Windows Vista.

Nesse cenário, o uso de memória do serviço de Spooler de impressão aumenta significativamente ao longo do tempo. Por exemplo, esse problema ocorre quando vários clientes milhares de impressora enviam seus trabalhos de impressão ao servidor de impressão. Finalmente, o servidor de impressão para de responder e você deve reiniciar o servidor para resolver esse problema. Dependendo da carga de impressão, esse problema pode ocorrer depois que o sistema está em execução de um dia ou de várias semanas.

Além disso, quando um usuário tenta imprimir documentos a partir de um computador baseado no Windows Vista, o trabalho de impressão falha aleatoriamente, e o usuário recebe a seguinte mensagem de erro:

O Windows não pode se conectar à impressora. O serviço de spooler de impressão do servidor não está executando. Reinicie o spooler no servidor ou máquina do servidor

Causa

Esse problema ocorre devido a um vazamento de memória no serviço de Spooler de impressão. O serviço de Spooler de impressão mantém uma fila de notificação do cliente não vinculado. Além disso, o serviço de Spooler de impressão armazena em cache uma impressora estrutura DEVMODE para cada identificador de cliente é aberto. Juntas, essas duas funcionalidades consumam muita memória quando vários clientes de impressora acessam este servidor de impressão.

Além disso, os clientes de impressão baseado no Windows Vista usam chamadas assíncronas de procedimento remoto (RPCs) para recuperar as notificações de alteração de impressora. Portanto, muitos RPCs assíncronos são agendados quando vários clientes de impressora usam o servidor de impressão. Depois que o número total de RPCs despachados atinge um limite de 6.000, o usuário do cliente recebe a mensagem de erro mencionada na seção "Sintomas".

Resolução

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente aos sistemas que apresentarem esse problema específico. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportObservação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Os hotfixes do Windows Vista e Windows Server 2008 importantes estão incluídos nos pacotes para o mesmos. No entanto, apenas um desses produtos pode estar listado na página "Solicitação de Hotfix". Para solicitar o pacote de hotfix que se aplica ao Windows Vista e Windows Server 2008, basta selecionar o produto que está listado na página.

Pré-requisitos:

Não existem pré-requisitos.

Requisitos de reinicialização:

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo:

A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas na Hora Universal Coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso Horário no item Data e Hora no Painel de Controle.

Windows Server 2008, versões com base em x86

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Localspl.dll

6.0.6001.22200

634,368

11-Jun-2008

05:23

x86

Spoolss.dll

6.0.6001.22200

163,840

11-Jun-2008

05:23

x86

Spoolsv.exe

6.0.6001.22200

126,976

11-Jun-2008

03:41

x86

Windows Server 2008, versões com base em Itanium

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Ramificação do serviço

Localspl.dll

6.0.6001.22200

1,617,920

11-Jun-2008

05:36

IA-64

Não disponível

Spoolss.dll

6.0.6001.22200

446,464

11-Jun-2008

05:39

IA-64

Não disponível

Spoolsv.exe

6.0.6001.22200

437,248

11-Jun-2008

04:19

IA-64

Não disponível

Localspl.dll

6.0.6001.22200

634,368

11-Jun-2008

05:23

x86

SysWOW64

Spoolss.dll

6.0.6001.22200

163,840

11-Jun-2008

05:23

x86

SysWOW64

Windows Server 2008, versões com base em x64

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Ramificação do serviço

Localspl.dll

6.0.6001.22200

788,480

11-Jun-2008

05:50

x64

Não disponível

Spoolss.dll

6.0.6001.22200

241,664

11-Jun-2008

05:50

x64

Não disponível

Spoolsv.exe

6.0.6001.22200

268,800

11-Jun-2008

04:26

x64

Não disponível

Localspl.dll

6.0.6001.22200

634,368

11-Jun-2008

05:23

x86

SysWOW64

Spoolss.dll

6.0.6001.22200

163,840

11-Jun-2008

05:23

x86

SysWOW64

Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Mais informações

Para obter mais informações sobre a terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de Conhecimento da Microsoft:

824684 descrição da terminologia padrão usada para descrever as atualizações de software

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×