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PROBLEMA

O Office 365 ou assinantes autônomos de Proteção Online de Intercâmbio que anteriormente subscreveram a proteção on-line for exchange (FOPE) independente recebe um relatório de erro de sincronização de diretório que identifica o seguinte conflito:

Um objeto com o mesmo endereço proxy já existe no Diretório Ativo do Windows Azure, mas é de um tipo de objeto incompatível (classes de objetos: contato, grupo ou usuário). Corrija esse problema nos serviços de diretório local ou no Diretório Ativo do Windows Azure e tente novamente.

O seguinte é um exemplo alternate text do relatório de erro: Colunas adicionais no relatório de erro listam a identidade e o ID de objeto no local para objetos conflitantes.

MOTIVO

Esse problema ocorre porque grupos de distribuição migrados e contatos do FOPE autônomo para a Troca de Proteção On-line foram criados com uma classe de objetoincorreta incorreta para correspondência suave de sincronização do diretório.

SOLUÇÃO

Para resolver esse problema, remova os usuários conflitantes do Office 365. Para fazer isso, crie uma lista de usuários para ser removido e, em seguida, execute um comando do Windows PowerShell para executar o processo de remoção. Para fazer isso, siga estas etapas:

  1. Conecte-se ao AD do Azure usando o Módulo de Diretório Ativo Do Microsoft Azure para Windows PowerShell. Para obter mais informações sobre como fazer isso, consulte o AD do Azure usando o Windows PowerShell.

  2. Entre no centro de administração da Exchange e, em seguida, defina todos os domínios afetados no Internal Relay para garantir que o fluxo de e-mails não seja afetado durante o intervalo de correção do tipo objeto. Para obter mais informações sobre como fazer isso, consulte domínios aceitos gerenciados no Exchange Online.

  3. Executar o seguinte comando para exportar uma lista de todos os usuários do Office 365 ou Exchange Online Protection para um arquivo Users.csv:

    Get-MsolUser -All | Where {$_.ImmutableID -eq $null -and $_.IsLicensed -eq $false –and $_.ProxyAddresses –ne “”} | Export-CSV C:\users.csvU 
  4. Use o Microsoft Excel ou um editor de texto para abrir o arquivo Users.csv. Importante Quando você executa essas etapas, não modifique ou exclua as duas principais linhas da planilha, pois elas contêm informações importantes de cabeçalho.

    1. Na planilha, exclua as linhas que estão associadas aos usuários que você deseja manter no Office 365.

    2. Salve o arquivo como usuários modificados.csv.

  5. Executar o comando a seguir para remover os usuários do Office 365:

    Import-CSV C:\users-modified.csv | Remove-MsolUser –Force 
  6. Sincronização do diretório da força. Para mais informações sobre como isso, consulte sincronizar seus diretórios.

  7. Executar o seguinte comando para remover os usuários da lixeira:

    Import-CSV C:\users-modified.csv | Get-MsolUser -ReturnDeletedUsers | Remove-MsolUser -RemoveFromRecycleBin  –Force 

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