Entrar com a conta da Microsoft
Entrar ou criar uma conta.
Olá,
Selecionar uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.

Sintomas

Um computador baseado no Windows Server 2003 para de responder quando você desligar o computador em uma sessão de console remoto. Esse problema ocorre aleatoriamente.

Observação: Você pode estabelecer uma sessão de console remoto usando a ferramenta conexão de área de trabalho remota (Mstsc.exe) em conjunto com a opção /console .

Causa

Em um processo de desligamento normal do Windows Server 2003, o sistema operacional tem um período de tempo limite durante o qual o service control manager (SCM) desliga serviços. Se o SCM não concluiu o encerramento todos os serviços dentro do período de tempo limite, o sistema operacional continua a desligar sem espera. O período de tempo limite é especificado na entrada do registro WaitToKillServiceTimeout. O período limite padrão dura 20 segundos.

Entretanto, se você desligar um computador em uma sessão de console remoto, o sistema operacional continua a desligar independentemente do período de tempo limite. Nesse caso, o sistema operacional continua a desligar alguns segundos depois do SCM envia uma notificação de desligamento para o serviço. Em seguida, o driver NTFS começa a desligar como parte do processo de desligamento do sistema. O driver NTFS começa a desligar mais cedo do que o esperado quando o serviço ainda está sendo desligado. O serviço pode acessar recursos de disco durante o processo de desligamento. Um deadlock é provável de ocorrer entre a operação de desligamento do NTFS e o acesso aos recursos de disco.

Resolução

Importante: Esse hotfix substitui um hotfix anterior que foi lançado com o mesmo número de artigo da Base de Conhecimento Microsoft (930045). Se você já aplicou o hotfix antigo, remova o hotfix antigo e, em seguida, instale o hotfix atual. Para remover o hotfix anterior, use o item Adicionar ou remover programas no painel de controle.

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente aos sistemas que apresentarem esse problema específico. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportObservação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Para aplicar esse hotfix, você deve ter o Windows Server 2003 Service Pack 1 ou Windows Server 2003 Service Pack 2 instalado no computador. Para obter mais informações, clique no número abaixo para ler o artigo na Base de Conhecimento da Microsoft:

889100 como obter o service pack mais recente para o Windows Server 2003

Requisitos de reinicialização:

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo:

A versão em inglês deste hotfix possui os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas na Hora Universal Coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso Horário no item Data e Hora no Painel de Controle.

Windows Server 2003 com Service Pack 1, versões com base em x86

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Termsrv.dll

5.2.3790.3043

246,272

14-Nov-2007

09:19

x86

Windows Server 2003 com Service Pack 2, versões com base em x86

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Termsrv.dll

5.2.3790.4188

246,272

14-Nov-2007

09:15

x86

Windows Server 2003 com Service Pack 1, versões com base em Itanium

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Termsrv.dll

5.2.3790.3043

698,368

14-Nov-2007

07:08

IA-64

Windows Server 2003 com Service Pack 2, versões com base em Itanium

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Termsrv.dll

5.2.3790.4188

698,880

14-Nov-2007

07:12

IA-64

Windows Server 2003, versões com base em x64

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Termsrv.dll

5.2.3790.3043

365,056

14-Nov-2007

07:08

x64

Windows Server 2003 com Service Pack 2, versões com base em x64

Nome do Arquivo

Versão do arquivo

Tamanho do arquivo

Data

Hora

Plataforma

Termsrv.dll

5.2.3790.4188

365,056

14-Nov-2007

07:14

x64

Solução alternativa

Para contornar esse problema, não reinicie o computador baseado no Windows Server 2003 em uma sessão de console remoto. Ou não desligar o computador baseado no Windows Server 2003 em uma sessão de console remoto.

Status

A Microsoft confirma que este é um problema em seus produtos listados na seção "Aplica-se a".

Mais informações

Para obter mais informações, clique no número de artigo a seguir para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:

824684 descrição da terminologia padrão usada para descrever as atualizações de software

Precisa de mais ajuda?

Quer mais opções

Explore os benefícios da assinatura, procure cursos de treinamento, saiba como proteger seu dispositivo e muito mais.

As comunidades ajudam você a fazer e responder perguntas, fazer comentários e ouvir especialistas com conhecimento avançado.

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?
Ao pressionar enviar, seus comentários serão usados para aprimorar os produtos e serviços da Microsoft. Seu administrador de TI poderá coletar esses dados. Política de Privacidade.

Agradecemos seus comentários!

×