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Introdução

O AD DS (serviços de domínio Active Directory) atribui SIDs (identificadores de segurança exclusivos) a usuários, computadores, grupos e relações de confiança que são criados no Active Directory. Os SIDs consistem em um prefixo de domínio concatenado com um identificador relativo que aumenta monotônicomente (RID). Cada domínio do Active Directory é atribuído a um pool RID global que consiste em 1.000.000.000 RIDs. Para habilitar cada controlador de domínio do Active Directory para criar novos objetos de segurança, cada controlador de domínio é alocado em pools de RID atuais e em espera do mestre de RID. Quando o pool de RID global do domínio e para os pools locais em controladores de domínio individuais em um domínio ficar esgotado, usuários adicionais, computadores e grupos não poderão mais ser criados no domínio. Para contornar esse problema, você pode criar e migrar objetos e aplicativos para um novo domínio. Este artigo descreve uma condição na qual uma falha lógica pode resultar em muitas solicitações de pool RID. Isso leva à exaustão global do pool RID.

Sintomas

Em determinadas circunstâncias raras, os controladores de domínio do Active Directory podem consumir inesperadamente uma grande quantidade de recursos de RID. Esse comportamento exaustão o pool de RID global. Quando esse problema ocorre, você enfrenta um ou mais dos seguintes problemas:

  • RIDs no pool global RID estão sempre sendo consumidas ao longo do tempo.

  • O número de RIDs que são consumidos no pool global RID é maior do que o esperado, considerando o número de entidades de segurança criadas intencionalmente durante o tempo de vida do domínio.

  • O teste do Gerenciador de RID DCDIAG indica que há uma falha na pesquisa do atributo RidSetReferences . Além disso, a seguinte mensagem de erro é exibida:

    Iniciando o teste: RidManager Aviso: atributo rIdSetReferences ausente de CN =Name, ou = Domain Controllers, DC =Name, DC =Name, DC =Name, DC =Name Não foi possível obter a referência do conjunto RID: falhou com o 8481: Falha na pesquisa ao recuperar atributos do banco de dados. ......................... nome falha teste RidManager

O hotfix na KB 2618669 permite detectar e evitar esse comportamento em controladores de domínio baseados no Windows Server 2008 R2.

Esse comportamento está incluído nas versões RTM do 

  • Versões do sistema operacional lançadas após o Windows Server 2019

  • Windows Server 2019

  • Windows Server 2016

  • Windows Server 2012 R2

  • Windows Server 2012

Causa

Em determinadas circunstâncias raras, um controlador de domínio pode emitir solicitações recorrentes para RIDs do pool de RID global a cada 30 segundos. Se solicitações repetitivas para atualizações de pool RID puderem continuar por um período de tempo significativo, o pool de RIDs global poderá ter um consumo de RID excessivo. Em casos extremos, o pool de RIDs global pode ficar totalmente esgotado.

Resolução

Para evitar muitos consumos de RID no pool global RID, recomendamos que você execute as seguintes ações:

  • Instale a última atualização mensal lançada após (setembro de 2016, KB3185278) em todos os controladores de domínio do Windows Server 2008 R2 existentes.

  • Integre a atualização à mídia de instalação do Windows Server 2008 R2. Ao fazer isso, você garante que controladores de domínio futuros também terão essa atualização.

  • Implante a função do Active Directory em versões mais recentes do sistema operacional que contenham essa funcionalidade na versão RTM.

Informações sobre o hotfix

Um hotfix compatível está disponível na Microsoft. No entanto, esse hotfix destina-se apenas a corrigir o problema descrito neste artigo. Aplique esse hotfix somente aos sistemas que estiverem enfrentando o problema descrito neste artigo. Esse hotfix pode receber testes adicionais. Portanto, se você não tiver sido seriamente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix. Se o hotfix estiver disponível para download, há uma seção "download de hotfix disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta seção não aparecer, entre em contato com o suporte e atendimento ao cliente da Microsoft para obter o hotfix. Observação Se ocorrerem problemas adicionais ou se for necessário solucionar problemas, talvez seja necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados às perguntas e problemas de suporte adicionais que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone do atendimento ao cliente da Microsoft ou para criar uma solicitação de serviço separada, acesse o seguinte site da Microsoft:

http://support.microsoft.com/contactus/?ws=support Observação O formulário "download de hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, isso ocorre porque um hotfix não está disponível para esse idioma.

Status

A Microsoft confirmou que este é um problema nos produtos Microsoft listados na seção "Aplicável a".

Informações adicionais

Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na base de dados de conhecimento da Microsoft:

824684 Descrição da terminologia padrão utilizada para descrever as atualizações de software da Microsoft

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